(Topic ID: 255178)

Stern spike system 2 speakers poping

By sushko

2 years ago



Topic Stats

  • 4 posts
  • 2 Pinsiders participating
  • Latest reply 2 years ago by KenLayton
  • No one calls this topic a favorite

You

Topic Gallery

View topic image gallery

20191108_142854 (resized).jpg

#1 2 years ago

I have two Stern spike system 2 games Black knight and JP. I got the Black knight before the JP. The front speakers sounded like they were getting low frequency signals that they could not handle. I was thinking that it was just this game as the Black knight has a deep voice that's not the case. I found the same problem with my JP. So I would like to share my solution with the group as it makes it sound much better.

Just add bass blockers to the front speakers and your all set. Here is a link to the ones I used.

BB-199 6 x 9" 6 x 8, 7 10" 199 UF BASS BLOCKERS 200Hz @ 4 OHM 4 PCS amazon.com link »

Good luck

20191108_142854 (resized).jpg
#2 2 years ago

In the game software (starting with Spike 2 games) , check your speaker impedance settings. The audio settings can be set for whichever speaker impedance the speakers are that are installed in your particular machine: 4 ohms or 8 ohms. Yours might be set incorrectly.

Example: if your speakers are 8 ohms and the audio settings are set to 4 ohm, that could make a difference.

#3 2 years ago

I can't find what you are talking about. It's not in the settings is it a dip switch? I don't know why stern would ship with the wrong setting ether. But if this is the problem I would like to corecrt it. thanks for your help.

#4 2 years ago

Here it is from the game code updates readme files:

Added UTIL->"VOL adjustments", "SPEAKER BALANCE", "BACKBOX SPEAKER TYPE", and
"CABINET SPEAKER TYPE" for Spike 1/2 games.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside