(Topic ID: 300094)

Stern SB-100 needed

By Envy-Me

46 days ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 45 days ago by Quench
  • No one calls this topic a favorite

You

Linked Games

#1 46 days ago

I need help fixing a Stern SB-100 Sound Card in a Hot Hand. I have recently revived a Hot Hand from the dead and it plays pretty good. Sound is a constant garbled mess that starts immediatly when the game is turned on. I can hear some faint changes in tone when score switches are hit, but the sound is running many sounds at one time continuously. I did take a look for cold solder joints suggested by one website, but have seen none. I will take another look tonight.

Or, If anyone has a working board that they would like to part with, contact me. Thanks!

#2 46 days ago

Send me pic front and back of your old one. I have a good one I’ll trade. But I’m not selling without a core board. You say you are getting some sounds

#3 46 days ago

It just came out of my Hot Hand....

#4 45 days ago
Quoted from Envy-Me:

Sound is a constant garbled mess that starts immediatly when the game is turned on.

This is usually a bad connection between the MPU board and the SB100 over the ribbon cable. Can be:
- bad ribbon cable
- cracked solder joints on the SB100 32-pin pin header
- tarnished pin headers on either the MPU board or SB100 where the ribbon cable connects

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside