(Topic ID: 199326)

Stern RBION Ball Won't Feed - Diagnostics Pass

By Lawlor_and_Order

4 years ago



Topic Stats

  • 4 posts
  • 2 Pinsiders participating
  • Latest reply 4 years ago by TheLaw
  • No one calls this topic a favorite

You

Linked Games

#1 4 years ago

Howdy, my Ripley's Believe It or Not! has been working great, but all of a sudden it decided a ball was missing after a drain in mid-game. Long story short, it's now in a state where if I run the diagnostics the following occurs:

- Boot up finds all four balls. No "missing pinball" message, in other words.

- The "Clear Trough" diagnostic shows four balls (presumably meaning the optos are detecting them fine) BUT an attempt to RUN the Clear Trough sequence doesn't do anything.

- The ball isn't fed at all to the plunger lane. The game thinks it's there, though, and sits as if you're about to plunge the non-existent ball.

I removed all four balls manually and did a factory reset in software, tried it again, twice, but it always comes back to this state.

I don't even know what diagnostics to run, since the screens aren't showing any faults. Presumably if this was a loose wire for the ball feeder it would show up someplace.

Any ideas about things to try?

#2 4 years ago

are you sure none of your mods have fallen in the trough?

I kid, so with the coin door closed the does the coil fire that loads a ball in the shooter lane?
Does the test SHOW one of the balls have left the trough when you say "it thinks it's in the lane?"

My first guess is optos are faulty which is common with Stern Trough Optos. Taking them out, reflowing solder can fix it if needed but let's answer these things first

#3 4 years ago

Ha ha (on mods 8-)

The coil does not fire.

The CLEAR test, when I hit "RUN" does nothing. Balls are shown as being in the trough, not in the lane. What I mean by "thinks it's in the lane" is the machine doesn't do a ball search or display a pinballs missing message, but sits patiently as if waiting for the player to launch the ball.

I can post a picture of the CLEAR TROUGH graphic if that helps.

THANK YOU!! TheLaw !!

#4 4 years ago

OK so let's assume we know the white interlock switches have to be pressed in for coils to work in test mode or the door closed and hitting the start button to make the clear trough work.... Then it's telling us the coil isn't working to put the ball in the shooter lane does not work.
Although after putting the ball in the lane the graphic would change showing it in the lane

So go into diagnostic and test that coil... And other coils to see what's happening then report back

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside