(Topic ID: 265939)

Stern Lightning - static playfield lighting issue


By Blubberpud

9 months ago



Topic Stats

  • 13 posts
  • 5 Pinsiders participating
  • Latest reply 9 months ago by Quench
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 9 months ago

Stern Lightning (1981); working on getting this back to former glory, games starts and plays, having an issue with the static playfield lamps right now.

All flashing and dynamic lights work and interact with the game as they should, but static lighting is out (backbox is fine). I'm just not sure where I need to start looking for cause of this?

Any help much appreciated, thanks in advance!

#2 9 months ago

Check for continuity on the wiring

#3 9 months ago

Does this game have a GI relay?

Besides from that, check votlage across the lamps. Should be 6.3VAC. if not there, check it at the rectifier board, etc

#4 9 months ago
Quoted from pinmike:

Check for continuity on the wiring

Hmm continuity to ground on both sides of a few lamps......short somewhere? Where to start?

#5 9 months ago
Quoted from zacaj:

Does this game have a GI relay?
Besides from that, check votlage across the lamps. Should be 6.3VAC. if not there, check it at the rectifier board, etc

Where would I look for the GI relay? No voltage across lamps, I believe there is a short somewhere, but I am getting 7VAC across rectifier board TP4.

#6 9 months ago

GI relay is usually either mounted on the bottom panel near the rectifier board or in the bottom of the backbox

#7 9 months ago
Quoted from zacaj:

GI relay is usually either mounted on the bottom panel near the rectifier board or in the bottom of the backbox

No, I don't think so, only see a flipper relay on SDU Board in backbox and nothing by the rectifier board.

#8 9 months ago

Only other thing in the chain then is the connector from the rectifier to the playfield, and the wiring itself...

#9 9 months ago

Okay, I'll trace from rectifier board, are backbox lights on a different circuit (must be they are still working would you happen to have a schematic? Any idea of what pin to start with on rectifier board?

Sorry for the flurry of questions

#10 9 months ago

Well....looks like it was the harness right off the rectifier board, the white wire (playfield lighting) was a little burnt and brittle at close inspection. I will replace that harness.

Thank you for your help! zacaj and pinmike.

#11 9 months ago

One connector on the rectifier goes to the playfield, one to the back box. Same fuse for both though. The GI pins commonly burn on them. Best to replace both gi pins with trifurcon if possible

#12 9 months ago

One thing to note is the GI circuit also runs through connector J3 on the speech board. IIRC, if you blow the fuse for GI, you will not only lose GI but also speech.

#13 9 months ago
Quoted from Blubberpud:

would you happen to have a schematic?

Download the manual and schematics here:
https://www.ipdb.org/machine.cgi?id=1441

Promoted items from the Pinside Marketplace
From: $ 170.00
$ 5.00
Playfield - Decals
Doc's Pinball Shop
$ 12.00
Electronics
Third Coast Pinball
From: $ 170.00
From: $ 25.00
Boards
nvram.weebly.com
$ 149.95
Boards
Allteksystems
$ 6.00
Cabinet - Other
Siegecraft Electronics
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 10.00
From: $ 45.00
Displays
PinballSolutions.eu
$ 119.95
Boards
Allteksystems
$ 149.00
$ 42.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside