(Topic ID: 272159)

Stern Lightning not turning on/ no display


By xddanx

6 months ago



Topic Stats

  • 15 posts
  • 6 Pinsiders participating
  • Latest reply 6 months ago by xddanx
  • No one calls this topic a favorite

You

Linked Games

#1 6 months ago

Bought a Stern Lightning not working and looking for 1st steps.
When I turn it on the GI comes on, some feedback noise starts loud then get soft but steady and no display. Start button does nothing.
Where should I start?

#2 6 months ago
Quoted from xddanx:

Where should I start?

Taking note of how many LED flashes you get on the MPU and going from there

http://techniek.flipperwinkel.nl/ballyss/rep/index2.htm#flash

#3 6 months ago

1 solid light. Board looks immaculate around the battery and reset area. Still proceed with pulling the board without checking fuses or anything else? First time doing any board related stuff.

#4 6 months ago
Quoted from xddanx:

1 solid light. Board looks immaculate around the battery and reset area. Still proceed with pulling the board without checking fuses or anything else? First time doing any board related stuff.

"If you turn your Bally game on, and the LED stays on continually, this is one of the hardest problem to fix on these boards. "

Yeah all you can do is follow the guide and narrow it down.

#5 6 months ago

I am up to 3 flashes after just pressing in the chips going to explore the 6821 next.

#6 6 months ago

Slowly moving up!

#7 6 months ago

6 flashes now, off to buy some fuses tomorrow.

#8 6 months ago

With the new fuses I get 7 flashes after a long delay after 6. It comes quicker if I give the cabinet or coin door a smack. Still no display or coils firing.

#9 6 months ago

There is a fuse on the playfield for the coils. It is located next to one of the flipper assemblies. It is a one amp slo-blo fuse.

On that vintage of machine, Stern put a fuse for the score displays on the back of the insert light panel. It's also possible "someone" over the years may have replaced the Stern Solenoid Driver Board with a Bally one which "might" have a high voltage fuse on it for the displays.

#10 6 months ago

Any progress on this machine? I have a similar issue with a Meteor that I just fully refurbished.

When I turn on the power, the only thing I get is GI lights remaining on. There is no sound, no score display, no game reset.

I took out the solenoid driver board (which is a brand-new replacement) along with the power supply and did a bench test using power plugged directly into the solenoid driver board. Measuring all the test point voltages turned up positive, nothing showing an odd voltage.

I assume I should test the voltage coming in directly to the machine at the small metal box where the power cord (new) was soldered in? I forget what that gizmo is called.

Any other places I should check?

The only board NOT replaced in the head is the one for playfield lighting.

It sucks to work 8 months on rehabbing a machine and getting nothing when the power switch is tripped!!

-Nate

#11 6 months ago
Quoted from Pinball_Nate:

Any other places I should check?

Have you confirmed you have 5v at the mpu? You can check for 5v at the test points on it.

#12 6 months ago

I’d start with the guides on pin wiki, confirm voltages off power supply and test points. start working through steps from there.

#13 6 months ago

I am still on 7 flashes/ beeps. I went thru and changed some fuses. Still no display or energizing but if I hit one one the test buttons it does a switch test where all the coils fire. What should i focus next on to get the game running?

#14 6 months ago

Thanks frunch and jgreene, frunch I assume there are test points on the MPU, I'll check for that 5v.

jgreene, I have been using flipperwinkle, that's how I found out about how to power up the power supply out of the machine, all test points were fine when I did that.

They also mentioned the square connector running from the body to the head, I will check those connections.

Thanks guys, I'll report back - appreciate the comments.

-N

#15 6 months ago

I changed some fuses and added credits today it it fired up! No display what should i explore to get the display to work?

Promoted items from the Pinside Marketplace
$ 5.00
Playfield - Decals
Doc's Pinball Shop
$ 6.00
Cabinet - Other
Siegecraft Electronics
From: $ 25.00
Boards
nvram.weebly.com
From: $ 10.00
$ 149.95
Boards
Allteksystems
$ 119.95
Boards
Allteksystems
From: $ 45.00
Displays
PinballSolutions.eu
From: $ 170.00
From: $ 12.00
$ 12.00
Electronics
Third Coast Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 150.00
$ 10.00
$ 24.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside