(Topic ID: 300354)

Stern Godzilla Official Owners Club King Elwin

By beltking

8 months ago


Topic Heartbeat

Topic Stats

  • 10,868 posts
  • 830 Pinsiders participating
  • Latest reply 4 hours ago by joey_skittlz
  • Topic is favorited by 527 Pinsiders

You

Linked Games

Topic poll

“What model did you order?”

  • PRO 147 votes
    20%
  • PREMIUM 387 votes
    52%
  • LIMITED EDITION!!! 216 votes
    29%

(750 votes)

Topic Gallery

View topic image gallery

20220522_152157 (resized).jpg
pasted_image (resized).png
IMG_1425 Copy (resized).jpeg
IMG_1551 (resized).png
IMG_5785 (resized).png
IMG_5786 (resized).png
1EFF6D58-3BA5-43B2-9B42-A106DCEAC44A (resized).jpeg
40EE4801-B256-4798-8CF8-DC01C15AC6A8 (resized).jpeg
FEB6E4E9-A797-4070-8C35-0BA97A74085A (resized).jpeg
IMG_3430 (resized).jpg
PXL_20220520_022357143 (resized).jpg
4548ED1F-588B-4BB8-8FAF-7E93CFA8690E (resized).jpeg
6C2AA77C-5385-4670-9259-CFB79FAAF5D2 (resized).jpeg
D35BF98B-5B95-409E-8FEB-01FFF59D9BD5 (resized).jpeg
GZ Ball Stuck (resized).jpg
Screenshot_20220517-142755_Photos (resized).jpg

Topic index (key posts)

14 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 10,868 posts in this topic. You are on page 129 of 218.
#6401 4 months ago

Theres a thought that the multiball feeds STDM on purpose so that you can’t hit the building as it’s returning to the correct height. It’s basically designed that way to prevent you from breaking the mech

#6402 4 months ago

Installed the PL shaker just now. Other than the screws to mount the cover not doing the job this thing is awesome. Highly recommend installing a shaker as others have said. Code is very well implemented.

#6403 4 months ago
Quoted from digitaldocc:

Installed the PL shaker just now. Other than the screws to mount the cover not doing the job this thing is awesome. Highly recommend installing a shaker as others have said. Code is very well implemented.

Agreed. A shaker is a "must have" on GZ.

#6404 4 months ago
Quoted from Paddy-o:

Not sure I understand your comment. I installed mine, as well, and it's been fantastic! Drops right to the left flipper. Doesn't interfere with anything else. Care to explain? What am I missing here?

I think he might be referring to the possibility of damaging the building if you hit it with a shot while it's between floors before it's had a chance to get to it's next set position for shots.

I don't understand the big deal about balls going to the drain off the Godzilla multiball start. For me, I don't want a big cluster traffic jam of balls in front of the flipper when I'm trying to hit my first shots in the multiball. On mine the balls go to the edge of the left flipper, but I let all but the last one drain so I can get a cleaner shot off to start it out. If all three went to the drain I wouldn't care.

And, if I'm interpreting correctly that what Keith wrote means the delay for balls going to the drain also helps protect the building a bit as it changes levels, then so much the better.

#6405 4 months ago
Quoted from digitaldocc:

Installed the PL shaker just now. Other than the screws to mount the cover not doing the job this thing is awesome.

The cover on mine was a little tight against the rail next to the coin box, other than that I didn't have any issues with mine.

#6406 4 months ago

The Opto behind the building, in the ball guide, I can't find in the manual what that controls. Anyone able to help? Trying to confirm the ball guide that is not flush is not causing issues.

20220116_133651 (resized).jpg
#6407 4 months ago
Quoted from atg1469:

I placed my deposit down on September 14th and my distributor is saying he can’t guarantee I’ll be in the March delivery. He said it all depends on however many games they send him but it sounds as if you’re suggesting he should already know the allotment he’ll receive. Is that right??

I got on a list with cointaker around November , they aren’t taking full deposits only $1.00 place holders. I was told they had requested 150 machines but had no clue how many they’d actually get and I should expect nothing until September 2022

#6408 4 months ago
Quoted from EricHadley:

WTF you talking about. LOL

I mean he is the designer of the game. You might want to give what he says a little more credence and show him a little more respect. Just sayin.

#6409 4 months ago
Quoted from Blakester:

Has anyone used the Avengers Infinity Quest shooter rod on their GZ? Apparently it needs to be re-wired to work, it won't 'plug and play" unless mine is defective. I remember seeing that someone had but was unable to locate on this (long) thread. Thanks!

I put one on mine and thought I got a defective light. After researching, it sounds like the lights are software dependent. Haven’t been able to figure out how to get mine lit yet.

#6410 4 months ago
Quoted from EricHadley:

Installed my SDTM fix yesterday and its perfect! Highly recommend. Odd Stern didn’t do this from the factory.

I always assumed the SDTM was by design just to be funny. The balls all kick back out. I kind of like trying to save them. LOL

#6411 4 months ago
Quoted from mbl1116:

Theres a thought that the multiball feeds STDM on purpose so that you can’t hit the building as it’s returning to the correct height. It’s basically designed that way to prevent you from breaking the mech

That makes sense and if it is supposed to be that way makes the whole idea a waste and glad I still went with the pro.

#6412 4 months ago
Quoted from BallyKISS1978:

That makes sense and if it is supposed to be that way makes the whole idea a waste and glad I still went with the pro.

I really don’t feel it detracts from the experience whatsoever and I’m always a little surprised at the attention this gets. I wish someone from Stern would just come out and say what the deal is once and for all.

The only thing about the game i find really annoying is accidentally shooting directly to the left of the building and hitting that loop in reverse. That drains the ball back through the building SDTM almost every time. But thats more on my ability than a design flaw

#6413 4 months ago
Quoted from mbl1116:

I really don’t feel it detracts from the experience whatsoever and I’m always a little surprised at the attention this gets. I wish someone from Stern would just come out and say what the deal is once and for all.

Just a few posts back the designer of the game pretty much said what the deal is.

Quoted from sk8ball:

You'll find out why the first time you one-time it into the building or to one of the exposed ramp exits upon ball drop

#6414 4 months ago

Well whatever. I love this game, awesome! And I think the roof mod makes a lot of sense AND looks awesome. To each their own.

#6415 4 months ago
Quoted from sk8ball:

You'll find out why the first time you one-time it into the building or to one of the exposed ramp exits upon ball drop

Thanks for explaining the design thinking here. A little removable factory tag hanging from the building top explaining why the mech unloads the way it does would have been helpful, then. If lawnmowers have them NIB to explain certain assembly points, then pinball can, too. Would have saved everyone a lot of time.

#6416 4 months ago

They'll should have installed a lockup sensor on the building mech. I think the sdtm is a pretty lame "fix." Physical mb locks should release the ball to the player. Otherwise, what's the point?

#6417 4 months ago

I will admit it is not obvious even to experienced players

I play a GZ prem on location, and I just got into the habit of shaking the game to save the balls. I ASSumed the game was set up incorrectly (If this was in MY house, I would fix it good ).

I never had a problem with the game, but it seems like something that will inevitably cause an issue on location.

Is this supposed to break the game if balls are caught?

#6418 4 months ago
Quoted from BC_Gambit:

Is this supposed to break the game if balls are caught?

IF you one-shot it at just the right time as the building's moving, I could see a ball getting jammed and preventing the building from moving. If there's no failsafe in the software it could burn out the motor. But I have to believe the software is watching the building and will reverse it to release the jammed ball if it detects the building has stopped moving. If not, why ISN'T it?

#6419 4 months ago

is anyone else running into the issue of one to two balls sticking to the magnet during multiball and not releasing for quite a bit?

#6420 4 months ago
Quoted from Muymanwell:

is anyone else running into the issue of one to two balls sticking to the magnet during multiball and not releasing for quite a bit?

Are the balls magnetized? Are you running stock balls?

#6421 4 months ago
Quoted from mbl1116:

The only thing about the game i find really annoying is accidentally shooting directly to the left of the building and hitting that loop in reverse. That drains the ball back through the building SDTM almost every time. But thats more on my ability than a design flaw

I'd lean more towards that being a design flaw on the Premium/LE model unless there is some way to setup the game to completely avoid it? It shouldn't punish you for hitting the wallop shot.

#6422 4 months ago
Quoted from PinMonk:

Are the balls magnetized? Are you running stock balls?

nope, replaced with carbon steel ball barons. it's happened with stock and these both. it does eventually release, which tells me it's likely not the balls

#6423 4 months ago
Quoted from Muymanwell:

nope, replaced with carbon steel ball barons. it's happened with stock and these both. it does eventually release, which tells me it's likely not the balls

I don’t know of any multiballs that use the magnet? Sounds like yours are magnetized.

I recommended trying standard shiny balls from Titan pinball. I’ve never had one of those magnetize.

#6424 4 months ago
Quoted from Muymanwell:

nope, replaced with carbon steel ball barons. it's happened with stock and these both. it does eventually release, which tells me it's likely not the balls

Did you test them with a steel paperclip, though?

#6425 4 months ago
Quoted from PinMonk:

Did you test them with a steel paperclip, though?

yes, with a paperclip and with piano wire

#6426 4 months ago
Quoted from Muymanwell:

yes, with a paperclip and with piano wire

Well, now you're just showing off.

What's your pitch?

#6427 4 months ago
Quoted from PinMonk:

Well, now you're just showing off.
What's your pitch?

6.5 on the nose

#6428 4 months ago
Quoted from chuckwurt:

I don’t know of any multiballs that use the magnet? Sounds like yours are magnetized.
I recommended trying standard shiny balls from Titan pinball. I’ve never had one of those magnetize.

ya, I wasn't expecting the magnet to trigger, either

#6429 4 months ago
Quoted from Muymanwell:

ya, I wasn't expecting the magnet to trigger, either

I’m saying it didn’t. . What multiball was it during?

#6430 4 months ago

Is your post magnetized, maybe? Have you checked that with the game off? On? Residual magnetism holding on to balls?

#6431 4 months ago
Quoted from PinMonk:

Is your post magnetized, maybe? Have you checked that with the game off? On? Residual magnetism holding on to balls?

this is something i haven't tested. not really sure what i'll do if that's the case.

Quoted from chuckwurt:

I’m saying it didn’t. . What multiball was it during?

GZ. i'm sure there's zero chance of some stacking event triggering the magnet when it shouldn't be. we all know the code is perfect at 0.85, right?

edit: also, to be clear, out of >450 games, this has only happened 5 or so times. not common at all.

#6432 4 months ago
Quoted from EaglePin:

Just a few posts back the designer of the game pretty much said what the deal is.

Ah ok, definitely missed this. Hopefully that settles it (i say knowing it won’t)

#6433 4 months ago
Quoted from Muymanwell:

is anyone else running into the issue of one to two balls sticking to the magnet during multiball and not releasing for quite a bit?

I've had this happen a few times on MG MB, usually when the second ball kicks out and hits the one that I just cemented onto MG (and sometimes the third as well, though that's rarer) but it usually releases the chain after a few seconds... (I also use Ball Baron carbon steels.) ...but it hasn't really been much of an issue for me... Happens, but rarely, at least for me.

#6434 4 months ago
Quoted from SlamtiltAB:

I am in Canada and have been working with insider support with a similar issue for the last week. My game connects, allows to scan in but is not registering achievements. It does register “last game played” score on the insider page but nothing else.. even says all time loops and buildings destroyed zero although have got many while scanned in. One time i scanned in and all of a sudden got 5 achievements (from previous games) go across the screen before plunging the ball. The game also said it was “up to date” in settings at code .81 when .85 was available. When I run a speed test it won’t connect to speed test but says everything connected and scans me in. No issues on other wifi devices in house and strong signal. Might be worth reaching out to Stern support if the issue continues. I have managed to update the game and do a speed test but it seems to still be having issues. They now want me to test the CPU, SD and Micro SD to narrow down the issue as they don’t think it’s my network.

I bet it’s a time zone issue between the location of the pin and the servers. Call it an educated guess.

#6435 4 months ago
Quoted from Muymanwell:

edit: also, to be clear, out of >450 games, this has only happened 5 or so times. not common at all.

Ah, I thought it was happening all the time. If it's that few, sounds like an error in the software or glitch. I wouldn't worry about it until after 1.00.

#6436 4 months ago

One unrelated thing that I thought would require a physical adjustment which per Keith elsewhere will be addressed through code is having the behind the flipper skill shot consistently trigger when the ball passes through.

#6437 4 months ago
Quoted from MikeS:

I'd lean more towards that being a design flaw on the Premium/LE model unless there is some way to setup the game to completely avoid it? It shouldn't punish you for hitting the wallop shot.

It doesn’t. It shouldn’t go STDM. Mine does not. Check the level of your game. Bring the back right side up a smidge

#6438 4 months ago
Quoted from PinMonk:

Ah, I thought it was happening all the time. If it's that few, sounds like an error in the software or glitch. I wouldn't worry about it until after 1.00.

Agreed.

#6439 4 months ago
Quoted from PinMonk:

Thanks for explaining the design thinking here. A little removable factory tag hanging from the building top explaining why the mech unloads the way it does would have been helpful, then. If lawnmowers have them NIB to explain certain assembly points, then pinball can, too. Would have saved everyone a lot of time.

100%

#6440 4 months ago
Quoted from El_Patron:

The Opto behind the building, in the ball guide, I can't find in the manual what that controls. Anyone able to help? Trying to confirm the ball guide that is not flush is not causing issues.[quoted image]

When sorting out a loop switch problem a couple weeks ago (finally realizing it was just some wiring underneath the pf preventing that far right loop switch from fully depressing, now corrected), I also explored this opto.

This opto does purposefully sit at a bit of an askew angle across that orbit. I believe its function is to assist in registering the destruction jackpot once the ball is hit across the right loop switch and then across that opto.

If you're concern is whether or not that opto is working...just go into switch test and roll a ball back and forth across the pathway of that opto to ensure that it is registering. Whether the back orbit guide is flush or not, any ball passing through that opto path should trigger it, regardless of its angle.

As above, if you're having a problem registering the loop in general, explore under the playfield and do make sure that you do not have any wiring interfering with that far right loop switch.

#6441 4 months ago
Quoted from Palmer:

It doesn’t. It shouldn’t go STDM. Mine does not. Check the level of your game. Bring the back right side up a smidge

The LE I play on route does this all of the time and even caused me to lose a tournament once. I've seen it reported on Pinside and FB groups as well so I wasn't sure how widespread of an issue it was. I haven't ever had it happen on my Pro or either of the 2 Pros that I've played on route. I'm happy to hear that it can be avoided with proper game setup.

#6442 4 months ago
Quoted from blueberryjohnson:

One unrelated thing that I thought would require a physical adjustment which per Keith elsewhere will be addressed through code is having the behind the flipper skill shot consistently trigger when the ball passes through.

I read this too but i am wondering how that could be done, because on my game the spinner below this gate does not trigger on a rollback of the ball through this lane and what else is there to detect the skill shot?

#6443 4 months ago
Quoted from ChipScott:

When sorting out a loop switch problem a couple weeks ago (finally realizing it was just some wiring underneath the pf preventing that far right loop switch from fully depressing, now corrected), I also explored this opto.
This opto does purposefully sit at a bit of an askew angle across that orbit. I believe its function is to assist in registering the destruction jackpot once the ball is hit across the right loop switch and then across that opto.
If you're concern is whether or not that opto is working...just go into switch test and roll a ball back and forth across the pathway of that opto to ensure that it is registering. Whether the back orbit guide is flush or not, any ball passing through that opto path should trigger it, regardless of its angle.
As above, if you're having a problem registering the loop in general, explore under the playfield and do make sure that you do not have any wiring interfering with that far right loop switch.

Thanks much for reply, will do.

#6444 4 months ago
Quoted from Muymanwell:

is anyone else running into the issue of one to two balls sticking to the magnet during multiball and not releasing for quite a bit?

Depends on what you mean by "quite a bit".

I have seen ~2 times across 12 or so games (especially if you are backhanding the mechgodzilla shot when it is lit for multiball) that it registers, and sticks, but "hangs low". The trough kicks out more balls, auto launcher launches, and most or all end up hanging around MG's belly. They stay there for a while, while you stare at your wasted ball saver and regret life

Is this what you are seeing?

#6445 4 months ago
Quoted from BC_Gambit:

Depends on what you mean by "quite a bit".
I have seen ~2 times across 12 or so games (especially if you are backhanding the mechgodzilla shot when it is lit for multiball) that it registers, and sticks, but "hangs low". The trough kicks out more balls, auto launcher launches, and most or all end up hanging around MG's belly. They stay there for a while, while you stare at your wasted ball saver and regret life
Is this what you are seeing?

i *have* seen that, however, I'm talking about the magna grab magnet, and while i haven't timed it yet, it's always at least 30sec or longer, with no video, etc, that would make me think it's something else causing it. as i said in a later reply, it's only happened maybe 1% of my plays

#6446 4 months ago

On the pro model, does it still take the same amount of time (15 seconds or so) for GZ multiball to start as it does on the premium?

#6447 4 months ago
Quoted from Mattyk:

On the pro model, does it still take the same amount of time (15 seconds or so) for GZ multiball to start as it does on the premium?

Yes it's a long delay in my opinion, hopefully they will allow a double-flipper cancel of the video segment on the next update.

#6448 4 months ago
Quoted from MikeS:

The LE I play on route does this all of the time and even caused me to lose a tournament once. I've seen it reported on Pinside and FB groups as well so I wasn't sure how widespread of an issue it was. I haven't ever had it happen on my Pro or either of the 2 Pros that I've played on route. I'm happy to hear that it can be avoided with proper game setup.

Are you talking about the revese-building wallop shot? If so, the latest software update gives you a ball save when that happens. I have had it where a slow rolling ball doesn't trigger the wallop, but it's rare.

#6449 4 months ago

......Speaking of the next update.........if Stern is listening..........

Having the option to enable/disable controlling the drop timing anytime the ball is caught by the magnet (as is allowed in the magna-grab loops moment) would go a long way towards solving the problems an imperfect playfield or bad location set-up might provide.

The destruction jackpot is untouchable on my pro without getting a tilt warning due to the playfield being crowned in the middle and the ball hitting the top of the flipper every time without nudging. Stern is calling my playfield "within specs" (still pursuing this) and frankly it just sucks the life out of this machine compared to others I've played both on location and at a friends place.

As others observed and noted earlier in this thread, the Destruction Jackpot magnet hold seems to lock in a tighter position just before releasing, that could also probably be fixed (eliminated) in the code to help the general cause.

#6450 4 months ago
Quoted from WizzardRob:

I read this too but i am wondering how that could be done, because on my game the spinner below this gate does not trigger on a rollback of the ball through this lane and what else is there to detect the skill shot?

No idea - that's why I thought we'd need something physical - looking forward to finding out

Promoted items from the Pinside Marketplace
$ 100.00
Playfield - Protection
Chrome Candy
$ 30.00
Playfield - Other
YouBentMyWookie
16,900
Sale Pending! Machine - For Sale
Valparaiso, IN
From: $ 1.25
Hardware
Hippies Haven
7,900
Machine - For Sale
Las Vegas, NV
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 45.00
Cabinet - Decals
Inscribed Solutions
There are 10,868 posts in this topic. You are on page 129 of 218.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!