(Topic ID: 266590)

Starship Troopers Multi Ball auto Launch issues


By RaoulJuke

77 days ago



Topic Stats

  • 5 posts
  • 4 Pinsiders participating
  • Latest reply 76 days ago by chuckwurt
  • No one calls this topic a favorite

You

Linked Games

#1 77 days ago

Recently picked up a SST;s in a bulk lot and got to say, very fun game. Unfortunately i am having issues with the ball launching into play tho. I've managed to fix it to be ok when i launch using the plunger, but when multiball happens, or any time the aut launch coild mech is required, 7/10 times the ball launches with nt enough power to kick the ball into the upper part of the playfield and into play -so the ball ends up drainging immediately on the far right drain. Super annoying

I have pulled the mech apart and cleaned the coil sleeve up a lot (did not quite have that size availabe). cleaned the mech, the coil, & used novus on playfield in the trough launch portion.I noticed that the U shaped kicker that comes up through the playfield was a bit out of shape, and done my best to re-shape it.

Anyone have any ideass what the issue is? Is it most likely still the U shaped kicker or another part of the mech slightly out of position? The arm on the kicker also seems a little loos so it sits a bit off centre. anyone experienced this before and what was it they tweaked to get it right?

#2 77 days ago
Quoted from RaoulJuke:

Anyone have any ideass what the issue is?

Does it hit the ball square, a good blow ? Or one sided a glancing blow ?

You might have to try and watch it kick, the coil firing might be different than at rest or pulling the mech with your finger.

LTG : )

#3 76 days ago
Quoted from LTG:

Does it hit the ball square, a good blow ? Or one sided a glancing blow ?
You might have to try and watch it kick, the coil firing might be different than at rest or pulling the mech with your finger.
LTG : )

Cheers, i am thinking its something along those lines as after some readjustment ive gotten a bit more consistency, but once i get one go bad, i get a couple in a row.

If someone has a SST thats fires perfectly it
Would be a great help if the could post a couple of photos of the underneath & from behind of the launcher mech so i had something to compare it to

#4 76 days ago

This was a few years ago so I'm going off memory here. When I got my sst, one ball would not launch good, and then the other balls would hit it and they would all drain. The pivot point of the ball launch arm was really worn, and when I replaced that it fixed the problem.

#5 76 days ago

I would rebuild the entire ball launch mech. The SST I had this mech was really messed up. As you know it’s critical this mech works well on this game. Rebuild mech and make sure the bracket that attaches it to the playfield isn’t broken too.

Promoted items from the Pinside Marketplace
$ 99.00
Playfield - Other
Arcade Upkeep
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 65.00
Lighting - Backbox
Arcade Upkeep
Trade
Machine - For Trade
Boonville, IN
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 369.95
Boards
PinSound
$ 1,000.00
$ 999.00
Pinball Machine
Mircoplayfields
$ 36.99
Lighting - Interactive
Lee's Parts

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside