(Topic ID: 322575)

Star Wars Pro : Death star led issue + other leds issues

By Fredb31

4 days ago



Topic Stats

  • 3 posts
  • 1 Pinsider participating
  • Latest reply 1 day ago by Fredb31
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 4 days ago

Hello,

I just bought a Star Wars Pro pinball and I discovered 2 issues :

1 : Death Star leds are always on, even in attract mode. I checked it in diagnostic menu led check (Death Star laser 1-4 & center) and leds were always on, no blinking).

2 : No leds from card Node 9b work (in attract mode and during the game). Even the flash linked to CN2 doesn't work. I checked all the connectors (disconnect and reconnect), check each led in diagnostic menu and all leds stay off.

I need your help.
Thanks.
Fred

#2 2 days ago

Anybody got any ideas ?

I would like to test both node boards, 9b & 9c, but I don't know how to proceed.

#3 1 day ago

I opened a ticket to Stern support.

Following their answer, I performed the following tests :

1 : All the leds on the board 9a work.

2 : I unplugged CN3 connector on 9b (serial link between 9b and 9c), no result, 9b leds don’t work. Green leds from Death Star were off (normal...).

3 : I replace the serial cable from 9a to 9b by the one (that works) from 8b and 8c and it changed nothing, leds from 9b don’t work...

Promoted items from the Pinside Marketplace
$ 218.00
6,899
Machine - For Sale
West Des Moines, IA
$ 14.00
Playfield - Other
Space Coast Pinball
$ 25.00
Apparel - Men
Pinside Shop

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!