(Topic ID: 282209)

Star Trek Vengeance LED Out

By ebrad90

10 months ago



Topic Stats

  • 6 posts
  • 4 Pinsiders participating
  • Latest reply 10 months ago by ebrad90
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

914DA1D7-E938-4E04-B41C-8C38A9C050BB (resized).jpeg

#1 10 months ago

I was wondering if anyone knows where I can get a replacement blue LED and how would I go about relaxing/installing. See picture. Back right fin light is out. Thanks

914DA1D7-E938-4E04-B41C-8C38A9C050BB (resized).jpeg
#2 10 months ago

Its probably a broken wire

#3 10 months ago
Quoted from ebrad90:

I was wondering if anyone knows where I can get a replacement blue LED and how would I go about relaxing/installing. See picture. Back right fin light is out. Thanks
[quoted image]

Is it dimly lit? It looks like it in the picture. May just need solder reflowed or a partially broken wire fixed.

#4 10 months ago
Quoted from Pin_Guy:

Its probably a broken wire

Check the wiring, with the moving ship, it flexes the wiring harness and can break the wire.

#5 10 months ago

Thanks everyone I’ll try and see if it’s a broken wire and report back.

#6 10 months ago

Fixed it. A yellow wire underneath the ship was cut. Barely any slack to solder another piece of wire between the break. Thanks everyone

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside