(Topic ID: 65205)

Star Trek TNG gun launcher

By Waldo_

8 years ago



Topic Stats

  • 4 posts
  • 4 Pinsiders participating
  • Latest reply 8 years ago by PinKeeper
  • No one calls this topic a favorite

You

Linked Games

#1 8 years ago

Long time player but first time owner (and much to learn!)
My new Star Trek TNG is in pretty good condition, plays well but the launcher is... intermittent.
I was hoping someone could give me some advice on getting it working. I have had the machine open and everything seems to be connecting.
Are there connections I should be cleaning/tightening?

Thank you in advance. I'm sure I am going to have a lot more questions over the coming months.
Waldo

#2 8 years ago

When you pull the trigger a little post goes through the cabinet (just barely) and presses the arm of the switch inside the cabinet. This to me just sounds like you need to adjust that arm so that it activates the switch every time.

#3 8 years ago

Pull the gun/trigger apart and check the spring. If it has never been serviced it could be that the spring is shot. I picked mine up two months ago and that was the case. A simple fix (I bought the correct spring from Marco) and made all the difference.

#4 8 years ago

I had the same problem years ago with the first STTNG I owned.

The wire harnesses to the ball cannons are notorious for slowly going bad and causing intermittent problems. If they have never been replaced, then i'd take a closer look at them. They are inexpensive and easy to replace.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside