(Topic ID: 80557)

ST-TNG unusual reset problem


By PinPall007

5 years ago



Topic Stats

  • 19 posts
  • 9 Pinsiders participating
  • Latest reply 5 years ago by Big70
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 5 years ago

Greetings to all reading this thread. I have a reset problem which only occurs during the first 1-2 minutes after start-up. If I hit both flippers simultaneously the machine resets. Upon restarting, the left flipper button won't allow selection of a mission from the DMD. The right flipper won't select either, but launches the ball instead, while the launch trigger does nothing. After about a minute-and-a-half, the machine operates properly.

I've changed the varistor and thermistor. I have not replaced any bridges or caps. The power into the machine is rating well (the reset only happens at the beginning of play). All diodes are connected properly. The switch matrix shows all switches open, except optos. I pondered replacing the bride on the flipper board, however, if the bridge were bad, it would be resetting constantly. I can only feature the problem to be a bad solder joint or, possibly, an oxidized pin on one of the PCB connections. Whatever it is seems to be heat related, as in a continuity gap caused by contraction as the machine cools down. Once warmed up, the machine plays properly. Any suggestions before I begin chasing this ghost in my machine? Thank you very much to all who help.

#2 5 years ago

Reseat connectors J101 and J102 on the top right side of the driver board and J210 power connector to the MPU and see how that does. Notice if any of these have burnt pins or if they seem to plug in looser than the others.

#3 5 years ago

Thanks for the info. I gave it a shot to no avail. What perplexes me is that when this occurs the left flipper button won't allow selection of play mode. And if I try using the right flipper the ball is launched, when it should allow selection of game mode as well. I performed a continuity test between the EOS on both sides, combined with the spinner (orange ground wire). Continuity is solid between all points.

The clue is in the fact that the right flipper will launch the ball while the left flipper will not select game mode. However, both flippers function during game play. My suspicion is there must be some kind of grounding occurring between the right flipper and the launch switch, which subsides once the suspect terminal, trace or component has warmed up enough to close the suspect gap and allow normal play.

#4 5 years ago

The odd flipper button behavior is unrelated. I've seen that in various cases on working machines.

#5 5 years ago

I had a similar issue with mine and it ended up being the Z connector.

#6 5 years ago
Quoted from markmon:

The odd flipper button behavior is unrelated. I've seen that in various cases on working machines.

...And what was your conclusion as to the cause?

#7 5 years ago
Quoted from oopsallberrys:

I had a similar issue with mine and it ended up being the Z connector.

Was your right flipper button launching the ball when this occurred?

#8 5 years ago

Well, a reset issue is almost always either your power connector J101 (heat damage or bad solder joints on the male pins) or Bridge BR2 and cap C5. The bridge and cap are most often the problem. You can also get bad continuity between the bridge and cap too from cracked solder pads on each. If you change them, I'd suggest running a jumper on the back side of the board from the + of the bridge to the + of the cap and also from the - to - to ensure a good connection. At the minimum you'll need to test for good continuity with a meter from the + to + and - to -. You mentioned that you pondered replacing the bridge on the flipper board. The bridge on the flippertronics board has nothing to do with the 5v circuit, which is what runs the CPU. When it goes low, it causes resets. That's all on the driver board. A bad bridge and cap also won't cause a constant reset all the time if they are starting to fatigue and fail. As they begin to go bad, you'll sometimes get very sporadic resets and that will usually progress to a more constant reset and eventually can lead to the CPU just never booting at all.

The odd switch problems shouldn't be related to the reset issue. They are totally different circuits and voltages. The switch matrix gets it's 12v derived form the 18v lamp matrix. Sometimes a low 12v to the switch matrix can cause weird switch issues. Ribbon cables can as well. You might try reseating all of the ribbon cables to see if that clears up the switch issue.

I'd be curious though if all of the switches are working 100%, especially your optos. If you go into test mode switch edges and activate your switches by hand, do you get multiple switch closures on any switches, specifically the optos on row 2 especially since the fire button is on row 2? The optos are run by several LM339 chips on the 16 opto PCB under the playfield. When one or more of those chips goes bad, it can cause all kinds of wacky switch issues. I've had for example a game activate the correct switch, as well as a switch that isn't used because of a bad LM339. The right fire button (switch 12) is on the same row as the lower right opto (F2), which is the your flipper opto for the lower right flipper. Since that's the case, you probably should check that whole row out for a possible bad switch diode or multiple switch closures with the optos. Check the column 1 too for a broken switch diode. There are no optos in the column 1. Specifically I'd like to know if you hit the right flipper button in switch edge test mode, does the fire button also activate?

#9 5 years ago
Quoted from PinPall007:

...And what was your conclusion as to the cause?

It seems to be some software issue. I've seen it on every sttng I've ever worked on. It's somewhat intermittent. When its happening you just wait for the timer to select the launch mode you want. Also, if you hold start to reset a game you always get the same skill shot automatically.

Anyway, I only commented to keep you on track and make sure you don't think the two issues are related.

#10 5 years ago
Quoted from PinPall007:

Was your right flipper button launching the ball when this occurred?

Yes, same symptoms. Couldn't advance the skill shot selection with the left flipper button and pushing the right flipper button selected the skill shot and launched the ball.

#11 5 years ago

I know there is an adjustment in the service menu that allows this:

A.2 16 Flipper Plunger
Pressing the flipper button, as well as the trigger, can shoot the ball.

Setting: ON = Pressing the flipper button shoots the ball.
OFF = The plunger does not kick automatically.

#12 5 years ago

i've seen that same flipper/launcher behavior before as well after various errors. it's not related to your reset issues.

#13 5 years ago

it might be some kind of failsafe recovery feature, or just a glitch that results from an unexpected game state. more experienced pinsiders might know more.

#14 5 years ago

Big70, your information about the opto board points in the direction where I'm currently looking. I also agree that cap 5 and bridge 2 should, ultimately, be replaced, since they're the original ones in a machine that's 21 years old and has been routed back in the day. I'll also take your advice about bridging the posts between cap and bridge.

Floyd1977, your point about the trigger versus plunger adjustment at A.2 16 is also a good place to look, regarding the ball launch issue.

So I may have two issues which simultaneously occur. I've repaired a few minor, weird things on this machine in the past, so this shouldn't be much more difficult. It's a matter of locating the origin and following it from there, which on this machine can be a tricky proposition. Now it's time to get to work and see how this pans out. I thank all of you for your time and support. This is a great pinball community. I'll revisit this post once I've isolated the problem(s) so others with similar issues may use this as reference.

#15 5 years ago

Big70, I forgot to answer your last question. The answer is no, when pressing the right flipper button, the launch button does not show during testing and vice versa. All switches act properly during switch testing.

#16 5 years ago

I had a similar problem with mine and what I found was a loose fuse, the holder was not holding it in place and it would loose contact, I tighten the holder and have not had any more problems since, check all of your fuses and make sure they are all tight.

#17 5 years ago
Quoted from oopsallberrys:

I had a similar issue with mine and it ended up being the Z connector.

Same here

#18 5 years ago

Problem solved! I pulled the power board only to find that C5 and BR2 have been replaced, albeit rather sloppily. Great gobs of solder, rather "cold" looking, combined with clear silicon gooped over the joints held everything in place. There was a bridge wire connecting the pos. posts, however, there wasn't one for the min. posts, so I added one. I replaced the board, fired the pin up and hammered the flippers. No reset and no more problems with the right flipper launch issue.

I've been in this hobby for 2 years now and I'm still learning a lot. The lesson I got from this was the realization that whenever something like this happens it's important to examine the condition throughout the whole machine before making any decision. Once I pulled the power board it became evident where the problem was. Had I done that in the first place, I would've saved hours on contemplation and tinkering. Any routed machine is likely to have "mystery" hacks done on it, and this machine was no exception. It plays great now!

Floyd 1977, I checked the setting on A.2 16. For whatever reason, when the pin would reset it defaulted into that particular mode (how odd). Don't know why but it doesn't do it anymore. Thanks for the tip. And thanks to everyone for your help.

#19 5 years ago

Good job, glad we could help.

Promoted items from the Pinside Marketplace
4,600
Machine - For Sale
Marshville, NC
From: $ 175.00
Gameroom - Decorations
Pinball Photos
5,000
Machine - For Sale
Mount Olive Township, NJ

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside