(Topic ID: 18029)

SST flipper flutters


By theseadoomaster

7 years ago



Topic Stats

  • 4 posts
  • 2 Pinsiders participating
  • Latest reply 7 years ago by BloodyCactus
  • No one calls this topic a favorite

You

Linked Games

#1 7 years ago

I just picked up a SST and the right flipper flutters to the point i
cant hold a ball.
I've adjusted the eos switch and can now hold a ball but when holding
the flipper i can hear a slight buzzing,and the coil gets hot after a
game.
I did order new coil,eos switches and stops.My question is=is there a
trick to adjusting them?
Is something else causing the coil to get hot?

So far ive replaced the coils,stops and eos switches and i get the
same thing.
So i decided to take a voltage reading and the right flipper is not
going low when held.
Im thinking it may be the 20n10l transistor because there isnt much
else there,i checked the resistor and it checks out then the path goes
to u2 and im guessing thats ok.
Any thoughts?
This is only in the right flipper,the left goes low when held.

I checked the voltage to the flipper circuit from the bridge rectifier
and its almost 73 volts!
The book says 50 volts,is this ok ?
I replaced the rectifier and no change in the voltage.
I replaced the transistor and U2 and still no luck.
I know theres not much to the flipper system on these, im hoping its
something stupid that im overlooking.
If anyone has any thoughts i would really appreciate it.

#2 7 years ago

I just ordered 1 left + 2 right flipper rebuild kits. my left suddenly went sticky and would not spring back down after releasing the button, it was not gradual. working great one day, now its not.

did you measure the same spot on the left flipper as right for comparison? 23volts over sounds high.

#3 7 years ago

Yeah, its 73 volts to all flippers but the other 2 flippers work just fine and go low to 9 volts like they are supposed to.Im thinking of replacing u206 in the dedicated switch section of the cpu.

1 week later
#4 7 years ago

I could lol here.. my left flipper will now stay 'up' about every 1 in t5 to 1 in 10 shots.. I also now hear a buzzing from both main flippers but no probs with the two right ones. fuses good, coils good.
havnt tested the voltage since its a bit hard when the game is on.

did you replace u206? or fix your issues?

Promoted items from the Pinside Marketplace
2,700
Machine - For Sale
Algoma, WI
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 16.95
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 20.00
Various Other Swag
Project Pinball Charity
$ 15.00
Electronics
Third Coast Pinball
$ 115.00
Playfield - Other
Great American Pinball
$ 239.99
Lighting - Led
PinballBulbs
$ 7,199.00
Pinball Machine
Classic Game Rooms
$ 44.00
Playfield - Toys/Add-ons
Lermods
$ 8,999.00
Pinball Machine
Classic Game Rooms
$ 25.00
Playfield - Protection
Pinball Mod Co.
$ 18.00
Playfield - Toys/Add-ons
The MOD Couple
$ 28.00
Playfield - Other
Pin Monk
$ 89.00
$ 7,395.00
Pinball Machine
Classic Game Rooms
From: $ 22.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 194.99
Lighting - Led
PinballBulbs

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside