(Topic ID: 255995)

SS Tech: Gottlieb Excalibur Coils Acting Psycho

By fireball2

4 years ago



Topic Stats

  • 5 posts
  • 2 Pinsiders participating
  • Latest reply 4 years ago by fireball2
  • No one calls this topic a favorite

You

Linked Games

#1 4 years ago

I was having boot issues with my Swemmer sys80 board in my Excalibur (another issue, another thread), so I put the original board back in. There wasn't anything wrong with it; I was just trying to track an especially pesky issue when I bought the machine, and so I bought an mpu. It worked fine until a few weeks ago, and then refused to boot... anyway... I put the original back in and it boots just fine and goes into attract mode. I can credit it up. And then I start a game...

Boy Howdy! The reset coils for the drop banks and the coils for the two lock/kickout hole start firing in rhythm, kakakchunk, kakchunk, kakachunk, chunk chunk, over and over! It literally sounds like galloping horse. It keeps going until you hit the first scoring switch on the playfield. The the coils stop firing, and the game plays and scores normally, including sounds. But then! You shoot the ramp, and it begins again! Only this time the rhythm is different; it still sounds like a galloping horse (the insert lights are even synched to the rhythm of the coils firing--or more likely vice-versa), and then it stops when the ball lands in the lock/kickout hole.

It all starts over with ball 2. As i said, the game plays and score normally, including sounds. It's sorta, kinda kewl, but not really, and I can't make it stop!

WTF?

#2 4 years ago

See if it stops when you disconnect your J4 cable from your Driver Board.

#3 4 years ago

I will check that as soon as I get home from work. But let's assume that it does. What would be my next move?
Thanks!

#4 4 years ago

Not an SS guy (go figure), so best something else chimes in, but reading on something like what you are experiencing may have something to do with the driver board as that controls drop target reset banks on system 1 and 80 (maybe later systems as well?). Maybe a resistor? maybe ??? At least if the driver board is the issue it is isolated so you can pursue the repair, whatever that may be.

Sorry I'm not that helpful, now back I go to EM repair.........................

#5 4 years ago

LOL. BTW: Disconnecting j4 only made half of them stop. John, of John's Jukes in BC said to do sys80b self test and check the proms. PROM 1 gave a weird checksum... Mebbe U2/U3 is bad?

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.