(Topic ID: 233247)

Spring Break not booting


By pinball_ric

7 months ago



Topic Stats

  • 10 posts
  • 5 Pinsiders participating
  • Latest reply 7 months ago by NickBudlight
  • No one calls this topic a favorite

You

Linked Games

#1 7 months ago

I'm in the process of troubleshooting a spring break that isn't booting. I know the MPU is good as it worked on the bench just fine using marco's test rom, I've replaced the daughter board and made sure it's getting 5v in the game. Figured I'd check the rom to see if maybe it was bad since the window was covered with a white sticker rather than black electrical tape or something else that would sufficiently block light. However doing so is rather difficult since gottlieb roms are not available for download. I was able to find some checksums listed on a licensed resellers page but none of the checksums listed match mine. Mine is EC57. It also doesn't match any of the 3 freeplay roms I was able to find.

I'm currently erasing the chip to try one of the freeplay roms but does anyone know if the EC57 checksum is perhaps another version or was my rom image likely bad?

#2 7 months ago

Well the 27c16 eeprom didn't have the same checksum as I found online but after erasing it I can't program it. So i'm stuck for now until i can get another one of those.

#3 7 months ago

The big cap in the bottom of the cabinet by the transformer good?

#4 7 months ago

Make sure there is no cold solder on the ground pins on the small ground pcbs on the sides of the power brick in the lower cabinet. These can cause the game not to boot or lock up.

#5 7 months ago
Quoted from erak:

The big cap in the bottom of the cabinet by the transformer good?

I believe so but I do have replacement caps on order from GPE. The MPU is definitely getting 5v though from what I can tell and it seems to be stable. I didn't hook up a scope to it though.

Quoted from hassellcastle:

Make sure there is no cold solder on the ground pins on the small ground pcbs on the sides of the power brick in the lower cabinet. These can cause the game not to boot or lock up.

I did all the ground mods on both the transformer block as well as in the backbox. I also tried unplugging most of everything. I tried with only the display and switch matrix plugged in since it needs to see the slam tilt switch but that didn't work. Also tried with only the display to see if it would at least give the slam tilt switch error. Neither worked. I'm fairly certain the roms were damaged since they had a white sticker on them rather than something more opaque like electrical tape and there is a florescent light in the backbox. Can't troubleshoot more until i can get a 27C16 or something that would work in it's place that I can program since the one that came out of the machine refuses to write.

#6 7 months ago

Ok well i was actually able to program it by selecting a profile that used 25v to program. May have destroyed the chip for future writing but it wrote and verified. No change. There are some insert lights that do a chase animation so maybe the board is booting but not full or something? I'll have to get the scope out and figure out exactly what is going on.

#7 7 months ago

The chase lights are from a different board.
It's a "chaser" board or Auxiliary Lamp board, located under the playfield.
http://www.pinwiki.com/wiki/index.php?title=Gottlieb_System_80#Auxiliary_Lamp_Problems

In PinMame the rom checksum (in game test mode) gives EB3A.
If you need a rom copy or something else, just let me know via email or PM.

Peter
www.inkochnito.nl

1 week later
#8 7 months ago

So I got it booting and somewhat functional. The diode on TC1 was bad. Removing the connector from the TC1 socket got the game booting. The game will boot up now and sort of start a game. I say sort of because it kicks a ball into the shooter lane and shows a score of 00 for the player but that's it. Nothing else happens and no switches work from that point. Going into self test the solenoids seem to work. However if you start a game the Q relay doesn't close so the flippers, pop bumpers and possibly some other things don't work.

I'm using a freeplay rom and there were 3 to choose from. Maybe I chose poorly? Not sure what else would cause this.

#9 7 months ago

False alarm. So I'd checked all the fuses before and they were all good but I noticed earlier tonight one had blown. I'd tried starting a game previously with balls in the machine since I know some early games won't start a game unless there are balls in it. Apparently when I tried that this fuse had been blown so it would kick the ball into the shooter lane but the auto kicker wouldn't fire due to the fuse. I decided to put balls in it a few minutes ago to see what would happen and it came to life. Although I did sort of choose the wrong rom. I chose the original rom that was the multiball thing. I'll need to get a spare 2716 or 2732 to change to the other set since I'm not sure i can rewrite the 2716 that's in it after I last wrote it.

#10 7 months ago

Did you also do the ground mods for the system 80B ...
If not I Highly Recommend you do...
Gottliebs are known for there floating grounds..

Every Gottlieb I have or that comes into the shop for repair gets the total ground update...
Saves headaches later on down the road...

Promoted items from the Pinside Marketplace
€ 8.40
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 45.00
Playfield - Plastics
Vandelay Industries
$ 14.99
Electronics
PinballElectronics.com
$ 299.00
Displays
Boston Pinball Company
$ 5,799.00
Pinball Machine
Nitro Pinball Shop
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 19.99
£ 45.00
Lighting - Led
PinballToys
$ 6.00
Electronics
German-Pinball-Modular
$ 60.00
Playfield - Plastics
Vandelay Industries
$ 208.87
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 99.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 369.00
Cabinet - Decals
Mircoplayfields

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside