(Topic ID: 201577)

Spring Break Ball Launch

By zerorob

4 years ago


Topic Heartbeat

Topic Stats

  • 11 posts
  • 6 Pinsiders participating
  • Latest reply 3 years ago by Stubs24
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

7CD68561-FCA0-44F7-A9CE-D89E3554B0C8 (resized).jpeg
54277F36-2CAE-48A5-B349-77439B513535 (resized).jpeg
DC5644BA-E0C4-41ED-884B-C30A70A23C03 (resized).jpeg
12ED877C-4A6B-471A-996F-E342C5AEA5B6 (resized).jpeg
20180610_114338 (resized).jpg

#1 4 years ago

Ive been creeping the forms for awhile now, Doing as much research as possible before I asked this question,
My spring break wont launch the ball, from either location. It has on occasion worked for what ever reason, so I have tried to trace back loose connections ect but cant seem to find anything. Im new to pinball repair but have a lot of experience with arcades in general.

The game otherwise works perfect if you just put the ball on the play field manually, Ball will eject into launch shoot, but doesn't go further then that. Both coils are new, and I believe when I checked for voltage the coils did have voltage going to them. I cleaned up all the switch contacts, And checked the switch matrix, Ever switch operates how it should.

Any help or thoughts on where to go from here would be great.

#2 4 years ago

Do you know if your game has had the ground mods done? They can act weird before they’ve been upgraded.

Spring break has that auto multiball from the start, right? Could it be a menu option to turn that on or off?

#3 4 years ago

Grounding mods are a good idea.

I don't know what you mean by "both locations". Spring Break launches all balls from the shooter lane.

Does it fire balls from the outhole into the trough correctly?

You can try grounding a tab on the relevant transistor on the driver board. If this makes the shooter lane kicker fire, then there's a path from the driver board to the non-banded side of the diode on the shooter lane coil. If this doesn't work, there is a break in the wiring somewhere, and you might be able to find it with continuity checking and a multimeter.

You can also try grounding the non-banded side of the diode on the coil. If this works, you've got power, although it sounds like you've already tried that.

Having a manual, and knowing which transistors have step-up transistors in your game, is a big help!

#4 4 years ago

The ball does eject to the trough, What I meant by both locations is the second trough shooter in the top right corner by the second flipper. It wont shoot the ball either.

I don't believe it does have the ground mod done, Ill start with that, and see if I can't trace back the transistor and see if there is a problem with continuity. The both share the same fuse, so I assume they share the same transistor and maybe thats why neither work. Ill see what I can accomplish from here. Thanks for the direction.

7 months later
#5 3 years ago

zerorob Did you by chance figure out what the problem was? I restored my spring break before I moved and was working fine but is now having the same exact issue you are describing. I even swapped for a ni-wumpf driver board just to check and still the neither coils will work. I have all ground mods done, new caps, etc. This is now the last thing holding out to make this machine perfect.

#6 3 years ago

There is a driver board under the playfield that drives coils. There could be a ground problem there. On pinwiki it explains that Gottlieb repurposed some lamp outputs to drive under playfield transistors which drive the solenoids. I attached a pic of what they look like. I had a similar problem and it ended up being the driver under the playfield. My problem was the ball gate coil was not working. It would not release a ball to the shooter lane. Hopefully this helps.

20180610_114338 (resized).jpg
3 weeks later
#7 3 years ago

Ever resolve this?
If it is just the main launch and the "upper" pf kicker that aren't working.. check yo' fuses!
They are on the same fuse, and are the only two things on that fuse..

I know this because I one time tried to use a beefier solenoid on the launch kicker only to blow through a couple fuses.

7 months later
#8 3 years ago

Hey all,

My newborn is finally sleeping through the night, so back to the Spring Break! I actually got my new transistors in yesterday and soldered them up tonight. The fault lights are now off on the NiWumpf driver board. I Went ahead and replaced all 4 transistors since they all looked all and the wiring all looked like cold solder anyway. However, the damn thing still won’t shoot!

I can now see on the NiWumpf that both of the solinoids are trying to fire. They blink like they are trying to launch to ball but won’t. The only remaining light on the driver board to address looks to be E10, but I have no idea what they goes to.

I hate to resurect a zombie thread, but I also hate threads to problems that go unresolved. Any other suggestions?

12ED877C-4A6B-471A-996F-E342C5AEA5B6 (resized).jpegDC5644BA-E0C4-41ED-884B-C30A70A23C03 (resized).jpeg54277F36-2CAE-48A5-B349-77439B513535 (resized).jpeg7CD68561-FCA0-44F7-A9CE-D89E3554B0C8 (resized).jpeg
#9 3 years ago

I took a second look at the manual and figured I’d check the resistor banks next. Figured it’s a long shot, but what the hell. Almost all of the resistors had extreme cold solder joints and the resistors wiggled freely. I reflowed solder on all of them hoping this would do it. Sure enough, it did not. Still back to square 1.

Can anyone think of anything else in line that I would need to check?

After the new transistors it looks like the driver board is without error and working as designed. Resistors have been reflowed/set. Before I did the transistors I installed new solinoids and diodes on both of the shooter lanes. Not sure where to go from here.

#10 3 years ago

Here’s where I’m at now. I checked the fuses yet again to make sure I’m not crazy. I put a brand new 2A sloblo, started the game up, ball launched like it should! I was crazy excited then a gutter ball. Go to shoot ball 2, nothing happens.

Check under the table and the fuse is blown now. I checked everything out one last time, and tried again. Same thing, blew another fuse.

mr2xbass bbrian170 any words of wisdom? I feel like I’m near the end of the tunnel, but keep hitting setbacks.

#11 3 years ago

Ok, I’ve done it and the machine is working again. Here is what I have learned from this experience in case anyone else runs into this issue.

1) check the transistors under the playfield for the shooter solinoids. This was the first thing that fixed the issue for me and removed the error lights on my driver board.

2) my resistor board that held the resistors also used for these solinoids contained extremely cold/cracked solder joints. Reflow solder on these across the board.

3) I replaced both the solinoids and diodes for the shooter lanes, although this was not required and didn’t resolve my issue, still worth checking as they can burn out.

4) just get new fuses and make sure they are exactly the model/spec required by manual(this should be a given anyway). I ordered a pack of brand new 2A Slo Blo fuses which finally fixed everything.

I did swap new bridge rectifiers through this process but they didn’t do anything new other than look shiny.

Thank you everyone through this process, and I am glad to fonally close out this thread. I hope it helps others who run into this down the line too.

Promoted items from the Pinside Marketplace
2,800
Machine - For Sale
Lake Elsinore, CA
$ 83.00
Electronics
PinballReplacementParts
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 25.00
Cabinet Parts
Flashinstinct
$ 6.50
Electronics
Yorktown Arcade Supply
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!