(Topic ID: 262802)

Space Shuttle Multiball advances player

By GameVault

1 year ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by GameVault
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

DSC00206 (resized).JPG

#1 1 year ago

Example:
3 player game.
All three players get a chance and someone locks one ball.
It is now player one's turn again and the player hits up the multiball ramp to cause the locked ball to eject into a 2 ball mulitblall.
All good so far.
The player now losses one of the 2 multiballs and has one ball remaining to play, but the cpu advances to the next player(player 2 in this case) while there is still a ball in the playfield.
A ball ejects into the shooter lane.
If you drain the 2nd ball that you should have had in the mutiball, it just lands in trough and 2nd player is still on waiting to shoot the ball from the shooter.
All swithces in trough are new with new diodes.
I rebuilt power supply.
I swapped in another cpu. Hit up all headers with fresh solder.
Can't figure this out.

3 ball multiball same thing, I forget if you drain 1 or 2 ball to cause the player advancement but still it should not since you have a 3rd ball in playfield.

#2 1 year ago

Maybe the switches in the trough are not in there correct order. Eather mounted or wired incorrectly?

#3 1 year ago

Take all the balls out and run switch test and see if any of the trough switches are registering. Add one ball at a time and see if one ball triggers two switches. Sounds like a switch is stuck closed or gapped to close in the trough. If not that recheck wiring and that diodes are on correctly.

#4 1 year ago

I will check.
If anyone has a pic of the trough switchs so I can have a good double check.
Thanks

#5 1 year ago
Quoted from GameVault:

I will check.
If anyone has a pic of the trough switchs so I can have a good double check.
Thanks

I can get you one of mine tomorrow if you need.

#6 1 year ago

Maybe this will help.

LTG : )

DSC00206 (resized).JPG
#7 1 year ago

Well....
I realized I did not change all the switches in the trough. In process.
Also realized the playfield switch diagram in the manual is incorrect. In the diagram in manual switch 10 and 12 should be swapped.

#8 1 year ago
Quoted from grantopia:

I can get you one of mine tomorrow if you need.

I would like a pic of your Space Shuttle trough switches too for curiousity sake.
Thanks.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside