(Topic ID: 231902)

Space Shuttle Display Problem

By ChicagoPinReplay

3 years ago



Topic Stats

  • 1 post
  • 1 Pinsider participating
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

20181206_195945 (resized).jpg

#1 3 years ago

My Space Shuttle is having an issue with its 4th player display. When plugged in it causes the 3rd player and credit display to have missing segments. When unplugged the remaining displays function as normal. I have swapped ribbon cables, displays and positions on the board. Every other display, cable and board output test fine. The 4th player display is always missing segments causing the others to malfunction as well. My question is can anything be done to fix this issue with the display in question or am I looking at purchasing a new one? I reflowed the pins which did not address the issue. I have repaired bally 6 digit displays but it does not look like anything can be done to fix these. I'm guessing it's a issue with the glass. Thanks in advance.

20181206_195945 (resized).jpg
Promoted items from the Pinside Marketplace
2,500 (Firm)
Machine - For Sale
Lodi, CA
$ 17.00
From: $ 1.25
Playfield - Other
Rocket City Pinball
2,600 (OBO)
Machine - For Sale
Cleveland, OH
$ 129.00
Cabinet Parts
Bob's Pinball Stuff
$ 44.99
Cabinet - Shooter Rods
Pinball Shark
$ 18.95
Eproms
Pinballrom
From: $ 33.00
Gameroom - Decorations
Rocket City Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 27.95
Eproms
Pinballrom
Wanted
Machine - Wanted
Blackwood, NJ
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!