(Topic ID: 264547)

Space Invaders - Points for no reason


By nibre

4 months ago



Topic Stats

  • 4 posts
  • 4 Pinsiders participating
  • Latest reply 4 months ago by Tuukka
  • No one calls this topic a favorite

You

Linked Games

#1 4 months ago

My Space Invaders is not well. Points are added when they shouldn't be added.

1) Most often 10 points at a time
2) Most often without any sound (although other sounds not related to the point increase can be heard sometimes)
3) It can occur during play, but also immediately after the bonus points or between balls

Video 1: No ball on the playfield
Video 2: When I move the ball over the playfield (very odd)

My first thought was that a switch could be stuck somewhere but I have checked them all, and they aren't.

#2 4 months ago

I had the same issue on my SI, and it was the switches at the 'top' of the Bonus Accelerator (the switches facing the pop bumpers). The scoring would often be silently going up after the bonus count was awarded.

#3 4 months ago

Slide pieces of paper between the score switch leaves to isolate the problem switch.

#4 4 months ago

You might have a failing capacitor across some switch. Reset all drop targets, remove ball from outhole and start the switch test. If any switch shows as closed, cut capacitor on that switch (or switches, if there are many parallel). The game will work without the caps, but may miss some switch closures. Replace with 0.047 uF (47 nF) / 50 V.

Promoted items from the Pinside Marketplace
2,100 (OBO)
Machine - For Sale
Cleveland, OH
$ 10.00
1,550 (OBO)
Sale Pending!
Commack, NY
From: $ 155.00
Wanted
Machine - Wanted
Chippewa, PA

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside