(Topic ID: 175683)

Sorcerer wont start


By SkillshotExhibit

4 years ago



Topic Stats

  • 5 posts
  • 5 Pinsiders participating
  • Latest reply 59 days ago by amphicar4fun
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 4 years ago

Im having troubles with my Sorcerer. Pressing the start button does not start the game. The digital display on the main board reads at 0. The start button works in the diagnostics mode. The tilt light is not on. I checked all of the solder points on all of the switches that register the balls. The balls are not being forwarded to the launcher.

What should I try?

Thanks!!

#2 4 years ago

Drop a quarter through the slot and see if it will post a credit.

Set Max Credits to Zero...that should set it to free play.

#3 4 years ago

Are your trough switches registering in switch test? You can't start a game unless the game detects all balls

2 years later
#4 1 year ago

Had the exactly the same issue with mine and the solution eluded me for a while as all the switches were reporting when asserted in switch test but the game would not start.

Replaced the game roms and tried the start button and.....IT WORKED!

Rebooted it again and tried the start button, no go.

Put in in switch test again and investigated more closely the trough switches as this game will not start unless it sees 2 balls in the trough.
Asserted the trough switch closest to the shooter lane in switch test and wiggled the wiring to it....no change.
Wiggled the diode across this switch....IT CHANGED STATE.
Re-soldering a not so obvious cold solder joint at one end of the diode at switch lug was the fix.
Pressed out many games afterward to test: Start issue resolved

-David
pinballdoctor.com

1 year later
#5 59 days ago

Hello Guys. I just wanted to share the issue and a solution that happened to me. My Sorcerer won't enter in game play. Both switches before the ball launcher tested ok, but the game won't start. I ended finding that the second switch for the multiball (ball lock) was stuck, so the game was thinking that one ball was there, so even with both switches before the launcher closed, the game won't enter in play. As soon as I released the second switch for the ball lock, all got back to normal.

Jacques

Promoted items from the Pinside Marketplace
$ 689.00
Flipper Parts
Mircoplayfields
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 17.00
From: $ 18.00
Apparel - Men
Pinside Shop
Wanted
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 22.50
$ 369.00
Cabinet - Decals
Mircoplayfields
$ 259.99
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
$ 15.00
Cabinet - Decals
ModFather Pinball Mods
$ 60.00
Cabinet - Shooter Rods
Mods for your pinballs
From: $ 161.50
Playfield - Toys/Add-ons
Lermods
$ 20.00
Playfield - Decals
Pinball Haus

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside