(Topic ID: 288152)

Sonic prospector not scoring

By Brewster007

9 months ago



Topic Stats

  • 7 posts
  • 2 Pinsiders participating
  • Latest reply 9 months ago by Brewster007
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

IMG_20210218_142319 (resized).jpg

#1 9 months ago

Hi all, I have a sonic prospector pinny that I let a nephew play and later he said it's not working. It was not scoring or no lights up on backboard. I had a play with it and left it. This week I checked it again and it would not reset. I went to score reels and cleaned them and now it resets. I pulled out the jones plugs and cleaned them and got the lights to work .So I can play it ,makes all the sounds but score reels will not move. I tried 2 player but it won't move to 2 player because of no score. I do notice that once started and I run over a scoring function there are a couple of relays humming. I checked all the playfield switches and I am at a loss as to what's going on. Any of you clever guys got any idea?

#2 9 months ago
Quoted from Brewster007:

there are a couple of relays humming

Exactly what is humming?

#3 9 months ago
Quoted from HowardR:

Exactly what is humming?

Hi Howard. The lock coil on the base ( single switch on the right hand bank of coils ) And the 100 and 1000 coils on the back board

#4 9 months ago

The Lock relay holding is normal for most games.
Other relays will overheat and burn up their coils if left activated for more than a minute or two.
Do the 100 and 1000 Point relays lock on for all 4 players?

For any more than that, I'll need to see a high quality scan of the schematic from (for example) Staples ($2) or Kinkos ($6)

#5 9 months ago

Thanks for replying .I mean the 100 and 1000 coils that are separate from the score reels. they are in the top of the back box

IMG_20210218_142319 (resized).jpg
#6 9 months ago
Quoted from Brewster007:

Thanks for replying .I mean the 100 and 1000 coils that are separate from the score reels. they are in the top of the back box

You circled 2 relays as being locked on.

Quoted from HowardR:

Do the 100 and 1000 Point relays lock on for all 4 players?

#7 9 months ago

I played around with the bumpers and it started scoring but when it went into the middle score retrieval and eject the eject is not working. The coil tests ok so I will look into it further . I think it may need a big clean of contacts.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside