(Topic ID: 119331)

Shopping a Getaway HS2 - bulb issues


By Flake49

5 years ago



Topic Stats

  • 47 posts
  • 14 Pinsiders participating
  • Latest reply 5 years ago by Pinball_Nate
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 8 images uploaded to this topic. (View topic image gallery).

Column 8.JPG
lamp board.jpg
IMG_20150224_205647699.jpg
IMG_20150224_205643692.jpg
IMG_20150224_204314361.jpg
IMG_20150224_204305153.jpg
IMG_20150224_204257251.jpg
IMG_20150223_213119225.jpg

You're currently viewing posts by Pinsider erak.
Click here to go back to viewing the entire thread.

#26 5 years ago

Check the wires coming off the plug that goes to the lamp board going back in the cabinet.

My friend has a bunch of lights not working. And the stop light was out as well.
Turns out the wires were crushed under the playfield near the back.

Check both sides.

The wire for that and other lamps is real close to the side slide rails and can get crushed and broken from moving the playfield for service.

If all else looks good. I bet that the problem.

Promoted items from the Pinside Marketplace
$ 109.95
Electronics
PinSound
$ 22.50
Playfield - Decals
Pinball Haus
From: $ 113.00
Playfield - Toys/Add-ons
G-Money Mods
4,000 (Firm)
Machine - For Sale
Chester, VA

You're currently viewing posts by Pinsider erak.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside