(Topic ID: 154868)

SEGA/STERN Whitestar Switch Matrix Problem - Rows


By OHMI_Arcade

3 years ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 3 years ago by OHMI_Arcade
  • No one calls this topic a favorite

You

Linked Games

#1 3 years ago

My SST has two rows of switches that aren't working. I assume this means that I need to replace the LM339AN voltage comparators but I thought I'd ask first to see anyone has experience with Whitestar switch matrix problems. Are the voltage comparators usually the cause of a complete row of switches not registering?

Thanks so much!
Tim

#3 3 years ago

Thanks Chris, very helpful. It looks like it isn't in the board.

Promoted items from the Pinside Marketplace
From: $ 16.95
3,000
Machine - For Sale
Bossier City, LA
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
3,100
Machine - For Sale
Lake Elsinore, CA
$ 399.95
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 229.99
Lighting - Other
Lighted Pinball Mods
$ 20.00
Electronics
Yorktown Parts and Equip
$ 495.00
Cabinet - Armor And Blades
MI Pinball Refinery
$ 42.00
Playfield - Toys/Add-ons
The MOD Couple
$ 3.00
Playfield - Decals
Doc's Pinball Shop
$ 27.50
From: $ 5,799.00
Pinball Machine
Music City Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside