(Topic ID: 294854)

Segasa casino Royale

By Shadrack

7 days ago



Topic Stats

  • 3 posts
  • 3 Pinsiders participating
  • Latest reply 7 days ago by MarkG
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Casino Royale Outhole relay (resized).jpg

#1 7 days ago

Good day everyone, I'm busy fixing up a Casino Royale by Segasa, I've fixed all the issues that have come up but there is one problem left, When sinking the ball, the outhole kicks just fine, but then it keeps kicking repeatedly(Score motor keeps spinning, Outhole relay keeps locking, releasing and relocking, every turn of the score motor). I've checked contact spacing on the outhole relay and outhole eject relay, they're fine. The outhole eject relay isn't locking once the loop starts. So only moving parts when this occurs is outhole kicker, outhole relay and score motor. I don't see any contacts out of alignment or dirty (I've cleaned and adjusted them), bonus unit does reset down to 0 position

Any help or ideas would be appreciated.

#2 7 days ago

I'd check the bounus stepper including any switches. It may need to advance to the first position to stop the score motor.

#3 7 days ago

I think bonzo71 is right. Once the bonus has counted down and the ball has been kicked to the shooter lane the Bonus Unit should take one step out of the zero position.
Casino Royale Outhole relay (resized).jpg
While the Bonus Unit is in the zero position the Out Hole relay will keep firing and the Score Motor will keep running, trying to get the Bonus Unit to step to the next position. Check the Motor 6A and the Bonus Unit Zero Position switches in the path in red.

/Mark

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside