New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 190071)

SEGA Club


By AlexSMendes

3 years ago



Topic Stats

  • 407 posts
  • 113 Pinsiders participating
  • Latest reply 2 days ago by rwarren28806
  • Topic is favorited by 43 Pinsiders

You

Linked Games

Topic Gallery

There have been 197 images uploaded to this topic. (View topic image gallery).

Screenshot_20201012-231637_Samsung Internet (resized).jpg
Sega Modular Standup Targets (resized).jpeg
77CBECA6-E7AF-4858-B32B-CF486E43D666 (resized).jpeg
28C9E86D-18E5-4755-9862-19E46A8E1D43 (resized).jpeg
A1156851-2B39-4D0B-BEBF-B506A11C15EA (resized).jpeg
7C099748-14F5-479B-B964-05B59F148CC3 (resized).jpeg
B51027AB-2FDB-40C7-8FE0-FAB7F1051C48 (resized).jpeg
DCCE135D-9AFC-452B-ACA8-1CFC5F61C844 (resized).jpeg
3EC1E29F-DA7D-4213-A88E-FE5B639A479B (resized).jpeg
27AE866E-0E42-49AE-81EA-5B34471AFBD8 (resized).jpeg
435A252E-E673-4148-81F1-2469D0891D72 (resized).jpeg
214E69B5-7B11-4213-8D3F-5A79BACF2676 (resized).jpeg
3F188ED9-6FA1-4C56-A9DA-760D9ACCDB57 (resized).jpeg
21B4615B-6DCD-496E-A3D0-B38A99835337 (resized).jpeg
13E0B965-ABAE-4D01-A9E5-9BDD6FD95E4C (resized).jpeg
7B3B9893-C437-49E9-AF7E-7B1E330CE845 (resized).jpeg

There are 407 posts in this topic. You are on page 6 of 9.
#251 2 years ago

What do you guys think?

WhatsApp Image 2018-03-29 at 16.05.44 (resized).jpeg

WhatsApp Image 2018-03-29 at 16.05.52 (resized).jpeg

WhatsApp Image 2018-03-29 at 16.05.38 (resized).jpeg

#252 2 years ago

WhatsApp Image 2018-03-29 at 16.54.55 (resized).jpeg

#253 2 years ago

I’m looking for a DMD/Speaker panel for my Batman Forever pin. Any help in locating one would be greatly appreciated!

D87E64B5-061B-43A1-AA06-1E5C3AAEC0A3 (resized).png

#254 2 years ago

Space jam on fire powerblades i had for a acdc sold it took the blades looks badass

1 week later
#255 2 years ago

Hi all, I'm leaving the ID4 club (though I'm still a part of the SEGA club with my SWT and XFiles).... Anyway, I got a bunch of SEGA stuff I can part way with...

IMG_20180413_185417 (resized).jpg

IMG_20180413_183713 (resized).jpg

IMG_20180413_185303 (resized).jpg

IMG_20180413_185226 (resized).jpg

IMG_20180413_182921 (resized).jpg

IMG_20180413_181820 (resized).jpg

IMG_20180320_090622 (resized).jpg

#256 2 years ago

Any SST bugs?

#257 2 years ago

Nope, but I got a few other SEGA parts for sale...

IMG_20180415_110905 (resized).jpg

IMG_20180415_110910 (resized).jpg

IMG_20180415_110837 (resized).jpg

IMG_20180415_110842 (resized).jpg

IMG_20180415_110635 (resized).jpg

IMG_20180413_182242 (resized).jpg

IMG_20180413_182238 (resized).jpg

#258 2 years ago

does anyone have a POST FASTENER #8 X 1-1/2" WS 6-32 TOP. its my last remaining part for my south park. thanks so much in advance

1 week later
#259 2 years ago

Hi,

I have SEGA Goldeneye with Display ROM V1.0.

In my original post to the Goldeneye thread, I asked why I can't shoot Bond during his walk across the screen. Basically, I hit the trigger and only the initial score shows up; I simply can't shoot Bond, not matter what I do!

So, after some advice, I purchased V4.04 Game ROM but am unsure where this goes, and whether or not I remove the old V1.0 display ROM. I stupidly tried replacing the Display ROM with the Game ROM and promptly lost the display. I returned the V1.0 display ROM back to its original place and all is well, but where does the Game ROM go, please?

Newbie here, so be gentle.

#260 2 years ago
Quoted from cklweb:

Hi,
I have SEGA Goldeneye with Display ROM V1.0.
In my original post to the Goldeneye thread, I asked why I can't shoot Bond during his walk across the screen. Basically, I hit the trigger and only the initial score shows up; I simply can't shoot Bond, not matter what I do!
So, after some advice, I purchased V4.04 Game ROM but am unsure where this goes, and whether or not I remove the old V1.0 display ROM. I stupidly tried replacing the Display ROM with the Game ROM and promptly lost the display. I returned the V1.0 display ROM back to its original place and all is well, but where does the Game ROM go, please?
Newbie here, so be gentle.

Hi and welcome to this crazy hobby!!!

The best advice is to get the manual for every game you own, they have all sorts of info and schematics so you can fix almost anything on your game, along with help here!

Here is the manual
http://www.ipdb.org/files/3792/Sega_1996_Goldeneye_Manual.pdf

Page 3, in pdf, shows where the Roms go. Hope that helps! Also you may want to check and see if you have updated Roms for all yours, voice, cpu, display, etc

#261 2 years ago
Quoted from northvibe:

Hi and welcome to this crazy hobby!!!
The best advice is to get the manual for every game you own, they have all sorts of info and schematics so you can fix almost anything on your game, along with help here!
Here is the manual
http://www.ipdb.org/files/3792/Sega_1996_Goldeneye_Manual.pdf
Page 3, in pdf, shows where the Roms go. Hope that helps! Also you may want to check and see if you have updated Roms for all yours, voice, cpu, display, etc

Many thanks northvide!

#262 2 years ago
Quoted from cklweb:

Many thanks northvide!

You’re welcome! Always glad to help. Please keep us updated on how the fix goes

#263 2 years ago
Quoted from northvibe:

You’re welcome! Always glad to help. Please keep us updated on how the fix goes

It didn't go well!

I replaced the original V1 ROM with Version 4.04 and disaster soon followed. The game started, the Game ROM showed USA V4.04, but after hitting the free play button, only the zero score and number of players appeared in the display.... It gets worse!

The graphic of Bond moving across the screen simply doesn't appear at all. The fun didn't stop there, as the ball stayed firmly entrenched in its hidey hole, and didn't bother to come out and play.

Just to top off my first ROM change celebration, the problem remained even after I replaced the original ROM. So now I have two ROMS and no Goldeneye to play. haha I should be crying.... But hey it's just a pinball. I've called my go-to guy John to come over and try and fix my mess. I alss ordered the latest sound and display ROMs.

I'll let you know how I go then!

#264 2 years ago

After you replaced the ROM did you go into the menu and enable free play?

#265 2 years ago

Also, have your guy (if he has a rom burner), just burn you an up to date SET of roms. Sometimes upgrading only 1 will not be compatible and you need the full set updated.

#266 2 years ago
Quoted from Evilive69:

After you replaced the ROM did you go into the menu and enable free play?

Yes, I did. but same problems remained. But there's a happy ending - the pinball tech came over and got everything working again.

And yes, northvibe, he can burn them - I should have gone to him from the outset!

#267 2 years ago
Quoted from cklweb:

Yes, I did. but same problems remained. But there's a happy ending - the pinball tech came over and got everything working again.
And yes, northvibe, he can burn them - I should have gone to him from the outset!

What was the final fix to solve it?

So glad it’s working now!!! It’s sad when you have a broken pinball and can’t play it

#268 2 years ago

Good Salutations Sega Club Members~

Where would I be able to find a link to the Sega Service Bulletins? I'm specifically looking for #53.

Thanks in advance for the direction!

#269 2 years ago
Quoted from St0n3PiraT3:

Good Salutations Sega Club Members~
Where would I be able to find a link to the Sega Service Bulletins? I'm specifically looking for #53.
Thanks in advance for the direction!

Is this it?
http://arcarc.xmission.com/Pinball/Stern%20Service%20Bulletins/sb/sb53.pdf

They have many of the old DE/Sega/Stern service bulletins if anyone needs any others.
http://arcarc.xmission.com/Pinball/Stern%20Service%20Bulletins/sb/

#270 2 years ago

Hi,

does anyone have a pic or description of how the Shoot Ball button switch should be wired on an ID4?

TIA

#271 2 years ago
Quoted from DropTarget:

Hi,
does anyone have a pic or description of how the Shoot Ball button switch should be wired on an ID4?
TIA

Let me know if this helps

9131329C-EE49-43D0-8156-17EAC50207E3 (resized).jpeg

E1924E6F-E850-4B34-BE95-075F72E77E92 (resized).jpeg

#272 2 years ago

It does, sort of.

I think I figured it out by trial and error. Just to confirm though, I can't tell from your pics. where does the white/green wire go?

Thanks

#273 2 years ago
Quoted from DropTarget:

It does, sort of.
I think I figured it out by trial and error. Just to confirm though, I can't tell from your pics. where does the white/green wire go?
Thanks

White and green wire is soldered to a contact on the switch right behind the green and gray wire.

#274 2 years ago

Thank you

#275 2 years ago

HELLLLPPPPP!

ID4

So,

I changed the ball launch button and switch (although I need up using the old switch, as the crisp connectors fit better). But the lamp does not light. Any thoughts. I'm pretty sure that I have all of the wires connected as they were before. I do have a question about the diode that goes from the switch to a screw on the cabinet. The same does that same screw have the red wire attached to it? Which way does the diode go?

Also, my upper flipper has stopped working, both in play and diagnostics mode.

*EDIT* Flipper fuse blown.

And the ball shooter keeps partially firing, even when the ball is already launched. (it was doing that before changing the switch)

any thoughts?

Thanks.

#276 2 years ago
Quoted from DropTarget:

HELLLLPPPPP!
ID4
So,
I changed the ball launch button and switch (although I need up using the old switch, as the crisp connectors fit better). But the lamp does not light. Any thoughts. I'm pretty sure that I have all of the wires connected as they were before. I do have a question about the diode that goes from the switch to a screw on the cabinet. The same does that same screw have the red wire attached to it? Which way does the diode go?
Also, my upper flipper has stopped working, both in play and diagnostics mode.
*EDIT* Flipper fuse blown.
And the ball shooter keeps firing, even when the ball is already launched. (it was doing that before changing the switch)
any thoughts?
Thanks.

Ok, we should start one thing at a time. Also do you have the manual? The manual should show diode directions and wire colors on what connector/ends.

Have you tried replacing the bulb at the switch? did you check the lamp matrix and make sure no other lights in the row or column are out?

#277 2 years ago

Thanks Northvibe,

I have the manual, While, I haven't looked deeply into it yet, I didn't see the wiring for that particular switch.

I tried replacing the bulb. I haven't checked the matrix, but at first glance it appears that all of the other lamps work. I'll double check that later today, when I get back home and report back.

#278 2 years ago
Quoted from DropTarget:

And the ball shooter keeps partially firing, even when the ball is already launched. (it was doing that before changing the switch)
any thoughts?

Sounds like the trough opto boards are not aligned correctly, or they are loose. There is a test in the menu system to empty the ball trough. If it works successfully then the optos are working and its probably an alignment issue. It happened on mine and it turned out to be that the opto board connectors were a little loose which caused them to fire repeatedly.

#279 2 years ago
Quoted from Evilive69:

Sounds like the trough opto boards are not aligned correctly, or they are loose. There is a test in the menu system to empty the ball trough. If it works successfully then the optos are working and its probably an alignment issue. It happened on mine and it turned out to be that the opto board connectors were a little loose which caused them to fire repeatedly.

Good test! Also can go to switch test and see if the opto sees the balls and if you remove them, does it still see them? For sure the opto leds can be reflowed as this is a very common issue on stern/segas

Quoted from DropTarget:

Thanks Northvibe,
I have the manual, While, I haven't looked deeply into it yet, I didn't see the wiring for that particular switch.
I tried replacing the bulb. I haven't checked the matrix, but at first glance it appears that all of the other lamps work. I'll double check that later today, when I get back home and report back.

Sometimes the column/row lights out is hard to find! So for sure check those. In the beginning ish of the manual it should show how a diode is between switch/legs so check that. The switch matrix section should show you what wire goes where on the switch for the launch button.

#280 2 years ago

ok here is the launch button. should be Green/violet on one side and white/green on the other for wires.

Also go into switch test mode and see if pressing the launch shows up on the switch test. Maybe this button already works? and I'm reading your comment wrong. I'm not sure why a diode would go to a cabinet ground/red wire? does that look factory or a fix hack?

Screen Shot 2018-05-15 at 9.53.46 AM (resized).png

Also you'll see all the ball through switches are in a column, so if there is an issue there they could all be funky.

EDIT:

AHHHH i see the pic above with the red/violet wire to the cab nut. Okay. Here is the picture in the manual of the switch with a diode across. verify it is correct on your launch switch

Screen Shot 2018-05-15 at 9.57.57 AM (resized).png

Here are the wires for the launch button bulb

Screen Shot 2018-05-15 at 10.07.44 AM (resized).png

#281 2 years ago

Thank you all,

Indeed, the opto board needed alignment (still does a bit, very sensitive).

The Launch Button switch was working, the lamp was not. All the lamps in the associated rows/columns light up.

I removed that diode going to the cabinet, and soldered the red wire directly to the switch. It now works.

NOW on to the next issue, does anyone have the mirror that goes at the top of the pf?

#282 2 years ago
Quoted from AlexSMendes:

Hi all, I'm leaving the ID4 club (though I'm still a part of the SEGA club with my SWT and XFiles).... Anyway, I got a bunch of SEGA stuff I can part way with...

Quoted from AlexSMendes:

Nope, but I got a few other SEGA parts for sale...

Some items still available!

#283 2 years ago
Quoted from AlexSMendes:

Some items still available!

What do you have left?

#284 2 years ago

Just finished installing homemade stadium lights and a pinduino in my ID4. Here is the attract more I coded.

#285 2 years ago

That looks awesome!

1 month later
#286 2 years ago

I recently purchased my first sega pin Frankenstein and am loving it so far. The pin was in rough shape, and must have sat in a bar for some time since every part of it was covered in soot and beer stains. But it is tough and with a lot of cleaning and care it now plays great.

I have upgraded the lighting, and replaced the weak flipper coils with one's from GNR. The game is super fast and hitting the ramp is much easier. I even repainted Frankie since he looked a little too cartoonish. All I have left to do is install mirror blades.

The only issue I am having is when I turn on the machine, the voice gets cut off. It says "Franken...." and not the whole word.

20180625_103524 (resized).jpg20180626_121103 (resized).jpg20180628_142600 (resized).jpg20180630_184443 (resized).jpg
#287 2 years ago

I think they all do the half word thing, a lot of Data East's do as well

#288 2 years ago

The shortened Frankenstein word at power up is completely normal. My MSF did it and so did my DE Star Trek.

2 weeks later
#290 2 years ago

Having multiple issues with ID4 i posted in both the club and a seperate thread in repair section. Can anyone please help. I am at a stand still

#291 2 years ago

Anyone around. I have a week old thread without a single response depressing

#292 2 years ago

Hi guys,

Newbie here and first post, so be kind

I've gone in at the deep and and bought a pretty decent Star Wars Trilogy table. It's in pretty good cosmetic shape and plays really nicely. It has the odd quirk like resetting every so often which is annoying but not a biggie for me, but the main fault (which was fully disclosed when advertised) is the DMD. The DMD itself appears to be fully functioning and in good order, however, it only displays the version number "V.4.0" and no scores or in-play graphics. Obviously this is something I would very much like to fix. Any ideas at all? The ribbon cables to and from the DMD controller board have all been replaced. The 25mF radial cap has (a little messily) been replaced with an identically rated axial cap but I can't see that being the issue. I have had a good visual inspection of the DMDC board and there appears to be no cracks in the solder tracks but I can't be sure on a microscopic level. Could it be a faulty ROM not allowing it to fully boot?

Like I say, I'm a newbie at table ownership and will be doing a lot of reading over the coming days. Posting up here in the hope of a pointer as to where to start! Looks like an awesome forum and can't wait to get involved.

Thanks in advance from the UK

#293 2 years ago

Just found this club. I have a South Park and a Lost World. Like the Sega games as they are easy to work on. I really like their manuals. Loaded with information, detail and very complete.

#294 2 years ago
Quoted from thestreetzking:

Anyone around. I have a week old thread without a single response depressing

I don't have an ID4 but explain the issue and I might be able to help.

#296 2 years ago

I am looking for some help with an issue on my ID4. I recently moved it and it went from fully working with no issues to now it will restart soon into my first game. I tried unplugging and reseating all the ribbon cables and conectors but this did not help. The game starts up normal and will go in to attract mode but after a small amount of gameplay it will power off and then restart. There is nothing in particular that makes it restart but it never lasts long before it does. Any suggestions to help me trouble shoot are very appreciated. Thanks

#297 2 years ago

After reading all the posts, it sounds like a component on the board. I don't know how to test much on the boards but I have found that once something has electronically gone wrong, once you eliminate the obvious, it's a board component.

Sorry I couldn't be more help.

#298 2 years ago
Quoted from MifflinMutant:

I am looking for some help with an issue on my ID4. I recently moved it and it went from fully working with no issues to now it will restart soon into my first game. I tried unplugging and reseating all the ribbon cables and conectors but this did not help. The game starts up normal and will go in to attract mode but after a small amount of gameplay it will power off and then restart. There is nothing in particular that makes it restart but it never lasts long before it does. Any suggestions to help me trouble shoot are very appreciated. Thanks

Can you isolate it to one particular target or switch. I had that issue with a Lost World and it was a coil diode which blew fuses and then transistors.

#299 2 years ago
Quoted from MifflinMutant:

I am looking for some help with an issue on my ID4. I recently moved it and it went from fully working with no issues to now it will restart soon into my first game. I tried unplugging and reseating all the ribbon cables and conectors but this did not help. The game starts up normal and will go in to attract mode but after a small amount of gameplay it will power off and then restart. There is nothing in particular that makes it restart but it never lasts long before it does. Any suggestions to help me trouble shoot are very appreciated. Thanks

I swear that gen had some rectifiers? or something when it failed would cause reboots, my LWJP had it happen. I had eventually send it off for board work and that fixed it.

#300 2 years ago

I have not been able to isolate it to any single switch, or solenoid firing off. So far it had not caused any damage that I can detect or any blow fuses. Everything works fine when I fire it off when I go into the test mode. Thanks for the responses/help.

Promoted items from the Pinside Marketplace
From: $ 0.95
Playfield - Other
Rocket City Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 220.00
From: $ 9.99
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 64.00
Lighting - Under Cabinet
Lermods
$ 499.95
Lighting - Led
Pin Stadium Pinball Mods
5,000 (OBO)
Machine - For Sale
Spring, TX
$ 279.95
Lighting - Led
Pin Stadium Pinball Mods
From: $ 220.00
Playfield - Toys/Add-ons
CzTV Mods
From: $ 369.95
Boards
PinSound
$ 15.00
Playfield - Decals
Metal-Mods
$ 209.99
3,500 (Firm)
Machine - For Sale
Commack, NY
$ 48.00
Cabinet - Other
ModFather Pinball Mods
From: $ 149.00
Playfield - Toys/Add-ons
Sparky Pinball
$ 19.95
Playfield - Toys/Add-ons
ULEKstore
$ 209.99
Lighting - Led
PinballBulbs
Wanted
Machine - Wanted
Sun Valley, NV
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 10.00
Cabinet - Decals
Pinball Haus
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
£ 45.00
Lighting - Led
PinballToys
$ 16.50
Lighting - Led
Lermods
From: $ 0.80
Playfield - Other
Rocket City Pinball
$ 7,599.00
Pinball Machine
Classic Game Rooms
Wanted
Machine - Wanted
Peosta, IA
$ 20.00
Playfield - Decals
Metal-Mods
$ 25.00
Boards
nvram.weebly.com
$ 16.00
Great pinball charity
Pinball Edu
There are 407 posts in this topic. You are on page 6 of 9.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside