(Topic ID: 251158)

Sega Batman Forever Sound Issue


By PrettyBoyJack

9 days ago



Topic Stats

  • 2 posts
  • 1 Pinsider participating
  • Latest reply 7 days ago by PrettyBoyJack
  • No one calls this topic a favorite

You

Linked Games

#1 9 days ago

I recently bought a Batman Forever from another pinsider. The game will play the "lets flip for it" test sound over and over but nothing else. The sound will play regardless of if the ribbon cable is plugged into the CPU board or not. There is also a hum from the speakers (although I think this may be a separate grounding issue.)

I started diagnosing my issues by following this guide: http://techniek.flipperwinkel.nl/desega/index3.htm#sound (click on the sound problems link in the contents). I checked my voltages across the Molex CN2 connector coming from the power board and they are all good. I also checked my +5V and -5V across the C47 and C49 caps and they are good. I went ahead and reflowed the solder on all the connectors (minus the ribbon) of the soundboard. This did not fix my issues.

The guide suggests looking now to the U19 and U20 PAL chips. Does this sound like a good line of thinking? The guy I bought it from said that it could be a ROM issue but I find that a little unlikely that someone updated a CPU ROM and not a Display or Sound ROM. How would I find out what my Display/CPU/Sound Rom version is?

Promoted items from the Pinside Marketplace
3,200
Machine - For Sale
Romeoville, IL
€ 339.00
Displays
GermanGamingSupplies.com
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 40.00
Lighting - Interactive
Professor Pinball
3,400
Machine - For Sale
Havertown, PA
$ 24.00
Electronics
Yorktown Parts and Equip
$ 399.95
From: $ 9.99

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside