(Topic ID: 128539)

Scoring Issue


By TopMoose

3 years ago



Topic Stats

  • 12 posts
  • 6 Pinsiders participating
  • Latest reply 3 years ago by wayner
  • No one calls this topic a favorite

You

Linked Games

#1 3 years ago

I'm having a scoring issue with my Jet Spin and wanted to see if someone can help me troubleshoot this.

On Jet Spin, the left roto target value corresponds with a playfield standup on the left, the right roto value corresponds with a standup on the right and the center roto corresponds with a kick out hole near the top of the playfield.

All the values work fine except for the 100's (there are three on the roto wheel). When I hit a 100 roto target or its corresponding playfield feature:

1. The score motor spins
2. The left, right or center relay activates
3. the "HIT" light goes on
4. The kickout hole eject activates if it's a center shot

Here's what doesn't happen:

1. The score reels don't move
2. The chime doesn't chime

So far, I've cleaned off the contacts on the roto stepper and bonus stepper and made sure that the contact fingers are sitting right on top of the contacts with each click. I've cleaned the contacts on the 1000-point relay and I've also checked the connections on all these units with a multimeter and everything seems fine. Clearly, contact is being made and the signal is going somewhere - the fact that the problem occurs on the 100-value standups and kickout make me think that the answer lies somewhere other than the roto target.

Let me know if you have questions - Thanks in advance!

#2 3 years ago

TopMoose, sounds like a poor connection between the PF and back box. Try removing and cleaning the jones plugs.

#3 3 years ago

All clean (plugs and sockets) but still no 100 scoring.

#4 3 years ago

Ok. Do you have schematics for the title ?

#5 3 years ago
Quoted from TopMoose:

So far, I've cleaned off the contacts on the roto stepper and bonus stepper and made sure that the contact fingers are sitting right on top of the contacts with each click.

Double check that--those rotos can have a little play in them. It took me a few tries before I got mine lined up perfect and scoring correct(I had a broken target and took it off to send to PBR for repair). Cleaned rivets, applied a tiny bit of superlube and lined up perfect after roto actuates.

#6 3 years ago

It looks like the 100 targets runs thru motor switch 1A slate-red so I'd look at that next.

#7 3 years ago

Thanks, guys - I'm going to buy a wire barrel brush tonight and give the female plugs a better going-over. I do have a schematic, but I've always had trouble reading them - my score motor appears to be reversed from the diagram, so I'm not sure which switch bank is the #1 position.

There's another problem I've encountered that my be related - The top lanes and inlanes are supposed to add bonus as well as scoring. The D relay ("Add Bonus & Spin Roto") fires and points are added, but they the bonus doesn't get added. If I'm reading the schematic right, the 100 roto-target also runs through the D relay, so I'll plan on following that connection tonight.

Wickerman2 - I used a de-greasing cleaner to clean the contacts. Would you recommend steel wool?

#8 3 years ago

2 cent entry...
Getcha a dremmel tool, and a BRASS wheel brush.
works better than anything I have tried so far.
And brass does not ware down the contact surfaces.

#9 3 years ago

There should be a small yellow sticker with black numbering on the base of the score motor indicating what bank is 1, 2, 3, and 4. I've had some missing now and then, but have been able to determine which was which with the stickers that were left. If you want I can snap a picture of my motor later tonight or tomorrow when back home for reference.

The switch stack I referenced 1 is on the A level which is the bottom level closest to the relay board. It's also the outside switch, so easiest to get to.

Your are correct that both bottom lanes should add bonus and spin roto. Out lane 3, In lane 1. The top lanes are a little different as they light up via an alternating relay driven by the bonus unit. If you go down a lit one, then yes, you get 1 bonus and a roto spin. Unlit, no bonus no spin.

#10 3 years ago

BINGO!

Those yellow stickers are well-hidden, but I found #1, unscrewed the lowest stack of relays and found that the outermost leaf was bent out of shape. I plied it back into place, re-installed the stack, fired it up and played my first proper game of Jet Spin! The 100 targets work perfectly now and the bonuses are scoring just as they should!

Maybe I can ask just one more tech question. Occasionally - every few games - the right roto target or corresponding standup gets stuck and won't stop scoring until I drain or advance the bonus. With the glass off, I can pull the target away from the strike plate but it still keeps going. Any ideas where I should start looking?

#11 3 years ago

I figured it out - the right standup target was sticking. I'm in the EM repair zone - just a few more issues to work out and she'll be playing perfectly!

#12 3 years ago

Good input tuffano

Promoted items from the Pinside Marketplace
$ 399.95
€ 8.40
$ 55.00
Gameroom - Decorations
Pinball Photos
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 5,799.00
Pinball Machine
Gulf Coast Pinball, LLC
$ 79.95
Cabinet - Shooter Rods
Super Skill Shot Shop
€ 8.10
Flipper Parts
Buthamburg
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 159.99
Cabinet - Armor And Blades
Great American Pinball
From: $ 29.99
Playfield - Protection
Little Shop Of Games
$ 1,000.00
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 142.00
Playfield - Toys/Add-ons
The MOD Couple
$ 39.00
Playfield - Toys/Add-ons
The MOD Couple

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside