(Topic ID: 190575)

Royal Flush no scoring or chimes


By Boise_D

2 years ago



Topic Stats

  • 11 posts
  • 5 Pinsiders participating
  • Latest reply 2 years ago by Boise_D
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

0Royal-Flush-Work-06 (resized).jpg

You're currently viewing posts by Pinsider Boise_D.
Click here to go back to viewing the entire thread.

#1 2 years ago

I hope someone can help figure this out.
Game seems to start up correctly and put a ball in play.
Switches activate, like pop bumper and slings, but no scoring or chimes.
One exception, the joker hole scores 1000 with chime.
Bonus counts down, ball count moves correctly, even player count if more than one player. Game ends after ball 5 like it should.

I think Q relay and AX are both required for this to work. I think they are both working properly, as best as I can tell.
I also checked Z1 and Z2, both seem ok.
I can manually trigger 10 or 100 switch from backbox, or 500 from below playfield. All of these score and chime properly when I do.

I recently did the CFH recommended mod to the continuous hold relays Q and U. I think game startup and finish suggest those are good.

Any advice from the EM experts?

#5 2 years ago

Thank you for the replies. I will check the jones plugs this morning.

See the section "Modifying the continuos duty relays..." And picture of two burned up coils here:
http://www.pinrepair.com/em/index3.htm

#6 2 years ago

I cleaned every connector on the 4 jones plugs in the backbox, and also the two on the bottom panel. I followed CFH's advice for cleaning them, using a wrapped 400 grit. I also inspected them and saw no disconnected wires. Bummer, no difference in the symptoms.

A ball in play will not score any points or activate chimes no matter what it hits, with the one exception of the joker hole on the right side, which will score 1000 points and ring the chime. The pop bumper and slingshots activate, flippers too. The right side middle lane will award and open the shooter lane gate correctly (gate is right outlane).
The game is not tilted, but the tilt still works properly.

how I test:
Turn on (Q and U start holding)
Push start: reels reset, targets reset, motor spins and stops.
Playfield is up, so I manually activate the outhole switch from underneath, which pops the coil. Then I activate the switch under the apron to simulate the ball rolling over it on the way to the shooter lane. I think this completes the start sequence of putting a ball in play.
Push drop target or pop bumper to test. Coils fire, but no score or chime.

Any other advice? I tried to read the schematics to see what is required for 10 points & chime, or a drop target to score and chime, or slings. Pretty much everything it seems have the Q and AX relay in the circuit. Is there a way to bypass these to maybe confirm they are not faulty?

I can manually activate the 10's or 100 relay and it works correctly. Same for the 500 or 3000 relay on the bottom panel. So, what is upstream from those that makes them activate, other than a target?

thanks again for any help.

#10 2 years ago

Hi Rolf,
Thank you for this bypass testing suggestion.
I will try it as soon as possible. I will be at the pinball show in Tacoma this weekend.

1 week later
#11 2 years ago

I tested the L, M, N relays and they seem fine. I did a tone (continuity) test to the jones plug also. Interesting the that all 3 go to the same 2 jones plug wires.
Next I looked at the 3C motor switch, and one contact was never closing. Aha! I manually tested it first and it worked! I got both chimes and score. I adjusted the switch. I'm wondering if my cat somehow bumped this open. I don't think I have been near the motor switches.

Now, I have discovered a new problem. The out hole is not kicking the ball over to the shooter lane. This was working before. Anyway, I am very happy the score and chimes are working again, and I'm making progress. Thank you for the score motor switch suggestion fredsmythson .

Promoted items from the Pinside Marketplace
2,000 (OBO)
Machine - For Sale
Sarnia, ON
Wanted
Machine - Wanted
Birmingham, AL
$ 8.99
Lighting - Other
Pappy's Pinball Palace
$ 6.00
Electronics
German-Pinball-Modular
$ 104.00
Boards
nvram.weebly.com
$ 48.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 10.00
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 10.00
Electronics
Yorktown Parts and Equip
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 89.99
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 369.00
Cabinet - Decals
Mircoplayfields
$ 74.00
Cabinet - Armor And Blades
Id Rather Play Pinball
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 5,799.00
Pinball Machine
Little Shop Of Games
$ 45.99
$ 9.99
Eproms
Matt's Basement Arcade
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 6.00
Electronics
German-Pinball-Modular

You're currently viewing posts by Pinsider Boise_D.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside