(Topic ID: 282059)

[SOLVED] RottenDog DIS200 -- display problems


By grimholtz

62 days ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 58 days ago by grimholtz
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 4 images uploaded to this topic. (View topic image gallery).

IMG-5951 (resized).JPG
IMG-5953 (resized).JPG
IMG-5952 (resized).JPG
IMG-5954 (resized).JPG

You're currently viewing posts by Pinsider athens95.
Click here to go back to viewing the entire thread.

#2 62 days ago

The problem might be your CPU board. The signal and chips that send the signal to the display are all right around the batteries on the CPU.

Promoted items from the Pinside Marketplace
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 12.00
Electronics
Yorktown Arcade Supply
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
$ 36.99
Eproms
Matt's Basement Arcade
$ 44.95
$ 40.00
Gameroom - Decorations
ArcadeArts
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
Wanted
Machine - Wanted
Knoxville, TN
$ 11.95
Playfield - Toys/Add-ons
ULEKstore
$ 50.00
$ 18.99
Eproms
Matt's Basement Arcade

You're currently viewing posts by Pinsider athens95.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside