(Topic ID: 108521)

Rock, Rock, Rockin' Rollergames! (club)


By practicalsteve

5 years ago



Topic Stats

  • 889 posts
  • 141 Pinsiders participating
  • Latest reply 31 days ago by TheOnlyest
  • Topic is favorited by 54 Pinsiders

You

Linked Games

Topic Gallery

There have been 307 images uploaded to this topic. (View topic image gallery).

0B827BD3-DBB1-4101-AFF2-168FD77E91E3 (resized).jpeg
20191024_213600 (resized).jpg
20191024_211028 (resized).jpg
IMG_20191014_144413 (resized).jpg
49F20294-63A8-4A36-98B0-88C31835F579 (resized).jpeg
20191008_131532 (resized).jpg
DE132FD2-D38D-46D1-BCDC-9BB9DE4EADB0 (resized).jpeg
005 (resized).jpg
004 (resized).jpg
001 (resized).jpg
002 (resized).jpg
cab-01 (resized).jpg
IMG_20190917_133658.jpg
046 (resized).jpg
045 (resized).jpg
slings.jpg

There are 889 posts in this topic. You are on page 14 of 18.
#651 2 years ago

Anyone using the Pinsound card in their Rollergames?

Videos/clips etc? Personal thoughts to it?

I'm debating, that and a speaker upgrade.

#652 2 years ago

Pinsound will sound better but unfortunately it's only stock sounds till someone does some custom ones

1 week later
#653 2 years ago

Someone asked me, and I swear there is a setting for this, why on some machines the announcer has a ladies voice instead of the dude. Can anyone point us in the right direction?

#654 2 years ago

Like "Go for the wall!" or "Go for the Pit"? Mine is a woman's voice...Proto 2 ROMs.

#655 2 years ago
Quoted from Leeb18509:

Like "Go for the wall!" or "Go for the Pit"? Mine is a woman's voice...Proto 2 ROMs.

My "Go for the Wall" is a male voice, my "Go for the Pit" is a female voice. I don't recall a setting to change the voice, just a "Family" type setting to change the "Kick Butt" song, as apparently some people felt (at least back in 1990) that wasn't family friendly so gave the option to change the song (which I have never done since I don't have an issue with "Kick Butt").

#656 2 years ago
Quoted from Leeb18509:

Like "Go for the wall!" or "Go for the Pit"? Mine is a woman's voice...Proto 2 ROMs.

Ahhhh I see

1 week later
#657 2 years ago

Joining this club as my restoration is nearly complete. I will post the pics I take during my unveiling party tomorrow! Picked it up as a beat up garage piece of junk find and poured effort into it until it shined like new!

Re: recent sound conversation
My game also has Proto 2 sound chips, but I do not have a female voice in my game AND my main gameplay theme is different than the normal song. I posted a video of the alternate (Beta) song here:

I also have a virtual pinball cabinet I built, so I grabbed all the roms from IPDB and tried each one until I eventually found the European Prototype 1 rom which has the same sound my machine has. including no female voice, and the alternate music. I have since bought a chip programmer, and some blank eproms will arrive tomorrow (didn't want to ruin my only working chips in case I screw it up).

#658 2 years ago

I feel like I have the same music, looking forward to seeing restore pics

#659 2 years ago

All done!

Restoration photos:
http://imgur.com/gallery/46RMB
Before and After:
http://imgur.com/gallery/joSLT

IMG_0408 (resized).JPG

#660 2 years ago
Quoted from Leeb18509:

Like "Go for the wall!" or "Go for the Pit"? Mine is a woman's voice...Proto 2 ROMs.

I'm not sure I've heard Go for the Pit, is that the extra ball call-out maybe? My "Go for the wall!" is definitely a man's voice, and I'm pretty sure there are both male and female voices for "don't flip / flip".

#661 2 years ago
Quoted from Darkwing:

I'm not sure I've heard Go for the Pit, is that the extra ball call-out maybe? My "Go for the wall!" is definitely a man's voice, and I'm pretty sure there are both male and female voices for "don't flip / flip".

Go for the pit is for Williams bonus

#662 2 years ago

Can anyone tell me what this part is?

2017-06-05 18.08.14 (resized).jpg

2017-06-05 18.07.42 (resized).jpg

#663 2 years ago

It fits inside the cab. The arm that props the playfield up (when raised) rests on it.

#664 2 years ago

Ahhh excellent thank you. Which way should it be oriented?

#665 2 years ago

I'm having sound issues. It seems I only have about 80% of the sounds. For instance I get no sounds when going through the inlanes and some of the background music is missing. I swapped out all 3 sound roms and I'm still having the same problem. Here's a picture of the soundboard if anyone could point me to another direction.

IMG_2267 (resized).JPG

#666 2 years ago

I had battery leakage issues on my main board that affected the sound. How does it look under the battery holder?

#667 2 years ago

I had the batteries removed off the MPU but it doesn't look like there was any damage. Any other suggestions?

IMG_2268 (resized).JPG

#668 2 years ago

Yea no damage there. You said you swapped the sound roms. Did you also update your game roms? If you run new sound roms with old cpu roms you might get issues. LA-2 I believe is the cpu rom version you want (assuming the sound roms you used were the latest LA-3)

2 months later
#669 2 years ago

Just a shout out to Xenon75, My Pinside Account is unverified, so in the admin's wisdom I can't even reply to direct PM's! (but I can post in forums... -_-)

If you PM me your email addy I can respond.

Also, anyone want to verify me? LOL

#670 2 years ago

Finished up some work on a different machine. Usually play a couple of (bad) games before calling it quits. Today ... was something special.

71,711,740 after "ball 1". I scored about 6 extra balls. I lost count.

79,563,460 at "Game Over". I lost the last ball trying to get the pit bonus (2nd time in the game).

IMG_10681 (resized).JPG

IMG_10683 (resized).JPG

#671 2 years ago

Anyone with nice example for sale in the NJ area please PM me.

#672 2 years ago
Quoted from DumbAss:

Finished up some work on a different machine. Usually play a couple of (bad) games before calling it quits. Today ... was something special.
71,711,740 after "ball 1". I scored about 6 extra balls. I lost count.
79,563,460 at "Game Over". I lost the last ball trying to get the pit bonus (2nd time in the game).

Wow, great scores (at least compared to me)! I get excited when I break 20 million on my RG and at best have gotten about 50% of those scores. I can break 100 million on my T2, but on that machine 100 million is child's play.

#673 2 years ago

Hi all - just joined the club. Could someone with the backbox flashers installed, please take a picture of the wiring of those flashers? I would like to add them to my game as it has the holes already drilled out.

Thanks!

#674 2 years ago
Quoted from Xylog:

Just a shout out to Xenon75, My Pinside Account is unverified, so in the admin's wisdom I can't even reply to direct PM's! (but I can post in forums... -_-)
If you PM me your email addy I can respond.
Also, anyone want to verify me? LOL

Email sent! How does one verify you?

#675 2 years ago

OK, I'll play.
Clean(er) than a whistle inside, got it that way.

RG-Translite-newLEDs-c (resized).jpg

RG - cab bottom entry (resized).jpg
RG - cab - full btm (resized).jpg

RG-Dec2014-someLEDs (resized).jpg

#676 2 years ago

Hello to all! so I just bring home my first Rollergames! so excited but (as expected) the machine has some issues, maybe you guys can pitch in.

The machine is not giving any error on "self test" but the following coils are not firing nor during "coil test" or during game:

- Upper Kickback
- Lock Kickback
- Ramp Diverter
- Outlane Kickback

How can I know if the problem is the coil itself or a transistor at the board?

The machine also doesn't lit the backbox but I found a "fried" GI molex connector that I will replace.

Any input will be greatly appreaciated!

TIA!

~ja

#677 2 years ago

I thought some of the Rollergames club folks would enjoy this surprise I found while starting to rebuild my game. Police Force inside Rollergames! I've heard that cabinet makers would use blemished or leftover parts for future projects but the person who did this definitely took their time to get a great scene for this piece. The top edge is even date stamped the same as the rest of the cab.

IMG_0647[1] (resized).JPG

#678 2 years ago
Quoted from uncle_jose:

Hello to all! so I just bring home my first Rollergames! so excited but (as expected) the machine has some issues, maybe you guys can pitch in.
The machine is not giving any error on "self test" but the following coils are not firing nor during "coil test" or during game:
- Upper Kickback
- Lock Kickback
- Ramp Diverter
- Outlane Kickback
How can I know if the problem is the coil itself or a transistor at the board?
The machine also doesn't lit the backbox but I found a "fried" GI molex connector that I will replace.
Any input will be greatly appreaciated!
TIA!
~ja

Hey Uncle_Jose! Welcome to the club! The first place I would check is the fuse that is mounted under the playfield. It is a single fuse that is right around the center of the underside (centered both width and length) and its kinda hidden behind a bunch of wires. Pretty hard to see at first! That fuse protects the coils you are speaking of AND it was blown on mine. Changed the fuse and it worked 100% after that! If that doesn’t fix your issue then it’s likely a wire on that chain that has come loose or a connector on the interconnect board that is fried.

Good luck and let me know how you make out!
Eric

#679 2 years ago
Quoted from Jeelopy:

I thought some of the Rollergames club folks would enjoy this surprise I found while starting to rebuild my game. Police Force inside Rollergames! I've heard that cabinet makers would use blemished or leftover parts for future projects but the person who did this definitely took their time to get a great scene for this piece. The top edge is even date stamped the same as the rest of the cab.

That's kinda cool! Waste not, what not!

#680 2 years ago

Looking for an excellent example (Diamondplate preferred) with little to no magnet wear at Expo or within a few hours drive of Chicago. Please email with description, pictures and price. Thanks.

1 week later
#681 2 years ago
Quoted from erico201:

Hey Uncle_Jose! Welcome to the club! The first place I would check is the fuse that is mounted under the playfield. It is a single fuse that is right around the center of the underside (centered both width and length) and its kinda hidden behind a bunch of wires. Pretty hard to see at first! That fuse protects the coils you are speaking of AND it was blown on mine. Changed the fuse and it worked 100% after that! If that doesn’t fix your issue then it’s likely a wire on that chain that has come loose or a connector on the interconnect board that is fried.
Good luck and let me know how you make out!
Eric

You are the best...! it was that fuse, there's no way you can see that fuse behind all the mess of wires. Thank you very much!

Best,

~ja

#682 2 years ago

Finally got my hands on a Rollergames, it seems (after adjusting a few switches) to be fully working with a decent Diamond plate playfield. It will need totally stripping down but nice to own one at last

20171003_203116 (resized).jpg

2 weeks later
#683 2 years ago

Sometimes my pit launcher isn't strong enough to get the ball all the way over to the flipper and it rolls back down into the pit. This causes the magnet to time out and you miss it. Anyone know how to strengthen it? Do I need to replace the coil?

#684 2 years ago

New coil sleeve to start should help. Coils rarely go bad unless the sleeve is stuck or the coil has been overheated.

#685 2 years ago

Also check the alignment of the metal habitual over the pit. If it's off the ball hits it sometimes and goes back to the pit instead of to the flipper.

#686 2 years ago

It has a new coil sleeve. I'll check the alignment. Can someone take a top-down picture of how the wire ramp is supposed to line up? The screw legs on mine were broken when I got it and they were rewelded. That might be off.

#687 2 years ago
Quoted from McSquid:

It has a new coil sleeve. I'll check the alignment. Can someone take a top-down picture of how the wire ramp is supposed to line up? The screw legs on mine were broken when I got it and they were rewelded. That might be off.

I'll take a photo for you later today when I get back to my house.

#688 2 years ago

Hope these images help. Let me know if you want a different angle.

IMG_2600 (resized).JPG

IMG_2601 (resized).JPG

IMG_2602 (resized).JPG

#689 2 years ago

20171022_171525 (resized).jpg

#690 2 years ago

Thanks for the pics. Mine appears to be properly centered. The ball goes up into the wire-form and gets about half way to the flipper near where the wire-form bends a bit before running out of momentum and rolling backwards and falling back down. It doesn't appear to be hitting the wires on the way up. Maybe redoing the solder on the wires to the coil will help with the inconsistent strength.

#691 2 years ago

Joining the club picked up my Rollergames a month or so back. I have a question is anyone running the rottendog MPU in there game? I almost bought one for my JOKERZ but ended up finding a replacement Williams boardisplay so I have never tried a rottendog board just seeing if anyone has one in there rollergames and what they think about it?

Of ya and kick butt

#692 2 years ago

Could anyone tell me where this plastic goes (or post a picture) I found it in the bottom of the cab but can't place it!

20171023_150538_001 (resized).jpg

#693 2 years ago

I think it goes here. You can just make it out in this photo. Just behind and to the right of the drop targets.

3E181298-14DF-4883-9429-CF6D3FDA250E (resized).jpeg

#694 2 years ago
Quoted from matt_adams:

Could anyone tell me where this plastic goes (or post a picture) I found it in the bottom of the cab but can't place it!

Is that a custom translite for you rollergames? Can we see it.

#695 2 years ago
Quoted from nicknack66:

I think it goes here. You can just make it out in this photo. Just behind and to the right of the drop targets.

Thank you, that looks like it.

Quoted from PoBoyPinball:

Is that a custom translite for you rollergames? Can we see it.

Do you mean the Free Play card? It was on the game when I got it. I can scan and post it here if you like.

#696 2 years ago

Yep

Quoted from matt_adams:

Do you mean the Free Play card? It was on the game when I got it. I can scan and post it here if you like.

Yes please do

#697 2 years ago

Here you go, hope the quality is good enough!

img20171024_19012343 (resized).jpg

#698 2 years ago

Just following up, I redid the solder on the coil for the pit. The ball now sails easily to the end of the ramp and the flipper. The wires and solder did not appear damaged, but it definitely fixed it. Game is now 50% less frustrating. No more timing out sudden death waiting for 6 attempts to pop the ball over.

#699 2 years ago

Glad to hear you solved the issue! It’s a key part of the game so having it work is a definite plus! Enjoy.

#700 2 years ago

Hello to all!

My RG have developed an odd problem, maybe you guys can help me: playing on a simple game and when ball 1 gets lock, 2 balls are placed on the shooter lane, this condition will only happen when ball one is locked. I cannot replicate it under any other condition. Any idea?

Many many thanks!

~ja

Promoted items from the Pinside Marketplace
$ 50.00
$ 99.00
Gameroom - Decorations
Pinball Sales
From: $ 369.95
Boards
PinSound
2,400
Machine - For Sale
Balt, MD
From: $ 18.00
Apparel - Men
Pinside Shop
$ 12.00
Electronics
Yorktown Arcade Supply
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 19.99
Eproms
Matt's Basement Arcade
$ 14.50
Electronics
PinballElectronics.com
$ 239.00
Cabinet - Toppers
Tilttopper
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 30.00
Various Novelties
Game Room Info Shop
$ 27.99
Eproms
Matt's Basement Arcade
$ 62.95
Cabinet - Shooter Rods
Super Skill Shot Shop
There are 889 posts in this topic. You are on page 14 of 18.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside