(Topic ID: 174877)

Robo-War not working.

By Margaritaphil

5 years ago

Topic Stats

  • 8 posts
  • 5 Pinsiders participating
  • Latest reply 5 years ago by Hangman57
  • No one calls this topic a favorite


Linked Games

#1 5 years ago

Hello I just picked up a pretty nice Robo-War. It has been setting unplayed for at least 10 years according to the owner. Game lights up but that's about it. If you turn it off and on you can get different things. It may beep sometimes. It may run through some sounds sometimes and sometimes the displays come up but most of the time they don't. It is super clean all connections seem fine. Any suggestions on where to start to get this game up and running? Not familiar with Gottliebs so this should be fun. This is also for sale if anyone is looking for one. Thanks Phil

#2 5 years ago

Has the battery leaked on the MPU?

Another problem area is the daughter board on the MPU that holds the game ROM.


#3 5 years ago

If theres no battery damage make sure the reset board is plugged in (small circuit board next to mpu that has wires coming off the mpu to it) then while the machine is on push on the daughter card (small circuit board soldered to mpu) with your finger and see if that does anything. Sometimes you have to hold pressure with your finger for it to boot up sometimes you don't, if it boots up then there is cold solder joints on the underside of the daughter card.

#4 5 years ago

system 80B boards don't usually have a problem with the daughter boards. They have thru holes and solder pads on both sides of the socket, but no harm in trying what you said. If any of the RIOT chips are very hot, there bad. I've repaired many system 80B mpu's, they are not hard to troubleshoot, logic probe or scope is pretty much required. PM me if you have any questions.

#5 5 years ago

Thanks I will try all of your ideas. Pretty sure there is no acid leak. I'll let you know what I come up with. I appreciate all your help!!! I have only worked on one Gottlieb 80B spring break and it still doesn't work. So maybe I'll have better luck with this one.

3 months later
#6 5 years ago

I got the same issue now with my robo war just sort of started, gone thru the basics, re pin the connectors clean the fingers on the board, check power, nothing really jumps out and says it me I am broken, I am leaning toward s a chip on the mpu but I am not talented enough to know how to find it.


#7 5 years ago

please help kind at a stand still, heres a small up date, what has quit working is the # 3 drop target and the rh roll overs and the top 4 rollover. now the fun part when the game has been off all night I first turned it on it worked like a dream no problems for about a minute or so then it slowly started to fail but just the items noted above obviously heat related but where do you start.
thx gary

#8 5 years ago

ok great update I got it all working, turned out to be a connection issue on the j6 edge connector the fingers on the board needed to be retinned all is great or was. now I did a dumb thing I put one of the game proms in the wrong way and toasted it what a dummy I am, anyway where can I get a set of game proms for the robo war game. your help would be appreciated

Promoted items from the Pinside Marketplace
$ 83.00
From: $ 18.00
Apparel - Men
Pinside Shop
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 1.00
Playfield - Other
Rocket City Pinball
From: $ 1.25
Playfield - Other
Rocket City Pinball
5,500 (Firm)
Sale Pending! Machine - For Sale
Bowmanstown, PA
Great pinball charity
Pinball Edu


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!