(Topic ID: 130434)

Rob Zombie's Spook Show International


By Russell

4 years ago



Topic Stats

  • 10,478 posts
  • 599 Pinsiders participating
  • Latest reply 9 days ago by davijc02
  • Topic is favorited by 104 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,193 images uploaded to this topic. (View topic image gallery).

50EAF020-4CD8-4119-9427-F544C9EF38B0 (resized).jpeg
5DEFF28A-B529-4D16-A30F-1A4C5F68DDB9 (resized).jpeg
IMG_3858 (resized).jpg
IMG_3857 (resized).jpg
IMG_3856 (resized).jpg
20191005_213740 (resized).jpg
20191005_213729 (resized).jpg
20191005_221951 (resized).jpg
20191005_221631 (resized).jpg
20191005_221713 (resized).jpg
20191005_221535 (resized).jpg
20191004_231821 (resized).jpg
20191004_230221 (resized).jpg
20191004_225937 (resized).jpg
20191004_225047 (resized).jpg
20190926_165833 (resized).jpg

Topic index (key posts)

7 key posts have been marked in this topic (Show topic index)

There are 10478 posts in this topic. You are on page 183 of 210.
#9101 2 years ago
Quoted from robertmee:

I'm thinking it should be like that any way...It's "Ball" save, not "Balls" save. Usually when a ball save is activated, it goes away. Not active for subsequent balls.

When I first worked on ball save that's how I thought it should be.

#9102 2 years ago
Quoted from mnpinball:

Loving the new beta v21.
Been playing a lot lately.
I've had the random 2 ball kick outs with the beta.
One pet peeve is the game over music blaring before Sid gets a chance to complete his game over end quote. Let Sid complete his call out and then fade in the music after the match sequence.

I'll look at that while I'm still adding to v21

#9103 2 years ago
Quoted from robertmee:

I'm thinking it should be like that any way...It's "Ball" save, not "Balls" save. Usually when a ball save is activated, it goes away. Not active for subsequent balls.

Multiball is an exception, not only in RZSSI, but in other games. Often, you will have a short time where balls are continually saved during multiball. RZSSI adds another wrinkle with the CHOP save. With that Spooky will have to set the precedent, I think. I'm not aware of another game that has a similar feature. I guess a kickback is the closest I can think of.

#9104 2 years ago

I see your point on "ball save" vs "balls saved" it just different from all other machines I've played. Typically any drain happening while ball save is lit will be returned to the playfield during multiball

#9105 2 years ago
Quoted from davijc02:

I see your point on "ball save" vs "balls saved" it just different from all other machines I've played. Typically any drain happening while ball save is lit will be returned to the playfield during multiball

I believe it will at the beginning of the multiball, just like any other game. However, if the ball save starts flashing due to a chop save, then it will only return one ball, so if you drain 2 or more, you're just out of luck because you're not in the grace period.

I understand where you are coming from, but really think the chop should probably only return one ball. Personally I'd like to see the chop letters flash along with the ball save to show that the ball save came from a chop. That might help differentiate it from a grace period ball save at the beginning.

#9106 2 years ago

CHOP saves sould be called out with that distinct sound effect from Robert Palmer's 'Simply Irresistible'. You know the one.

#9107 2 years ago

Wondering if this is just an issue on my end or not - Some switches don't always register fast enough to detect the ball. The "O" in CHOP for example sometimes doesn't detect a hit when the ball rolls over. I've verified the switch is adjusted perfectly and can't figure it out unless it's just a flaky switch. When I go into switch test I can rapidly click most switches and they don't react as fast as I am clicking them. I already have the fast switch setting in the menu (forget what it's called). Wondering if this can be made to be set faster to detect very brief switch hits.

#9108 2 years ago
Quoted from snakesnsparklers:

Wondering if this is just an issue on my end or not - Some switches don't always register fast enough to detect the ball. The "O" in CHOP for example sometimes doesn't detect a hit when the ball rolls over. I've verified the switch is adjusted perfectly and can't figure it out unless it's just a flaky switch. When I go into switch test I can rapidly click most switches and they don't react as fast as I am clicking them. I already have the fast switch setting in the menu (forget what it's called). Wondering if this can be made to be set faster to detect very brief switch hits.

I'm beginning to wonder if some of the stock switches just suck. I was having issues with the loop under the playfield (1000C lock) not registering if fast, and hanging balls if slow. Removed the switch and put a WPC era switch in and it's been great.

My 'H' In CHOP doesn't register for the first several hits during the first game of an evening, but then starts working correctly. Same as you I've adjusted and checked in switch mode and seems fine. I don't think it's a bug as much as physically it isn't working until it is hit several times. I was going to try and replace it this weekend if I get a chance.

#9109 2 years ago
Quoted from SilverballNut:

My 'H' In CHOP doesn't register for the first several hits during the first game of an evening, but then starts working correctly. Same as you I've adjusted and checked in switch mode and seems fine. I don't think it's a bug as much as physically it isn't working until it is hit several times. I was going to try and replace it this weekend if I get a chance.

Happens with me too, except it's the O and the P. It's not a software issue as I can feel it not triggering. After a few rollovers it "unsticks" and works as it should.

#9110 2 years ago
Quoted from SilverballNut:

I'm beginning to wonder if some of the stock switches just suck. I was having issues with the loop under the playfield (1000C lock) not registering if fast, and hanging balls if slow. Removed the switch and put a WPC era switch in and it's been great.
My 'H' In CHOP doesn't register for the first several hits during the first game of an evening, but then starts working correctly. Same as you I've adjusted and checked in switch mode and seems fine. I don't think it's a bug as much as physically it isn't working until it is hit several times. I was going to try and replace it this weekend if I get a chance.

I have the same issue, but with my upper playfield. If I select 'What', it takes a few switch hits to even register a hit, otherwise it does nothing. The rest of the day, it works fine. Maybe replacing the switch is the best idea? Very odd.

#9111 2 years ago
Quoted from spandol:

I have the same issue, but with my upper playfield. If I select 'What', it takes a few switch hits to even register a hit, otherwise it does nothing. The rest of the day, it works fine. Maybe replacing the switch is the best idea? Very odd.

microswitches have a dielectric grease on the contacts. Maybe this had gone bad and is acting more like a glue. You could always open it up and clean the contacts. Re protect them with a thinner grease. Or liquid de-ox.

#9112 2 years ago

I need to figure out a standard switch that will work and just buy a bunch and replace them as I notice issues. Just realized my right loop was doing it last night. Talk about a switch you really need to work first time you hit it.

#9113 2 years ago

Normally you can just get the switch and reuse the arm and mount.

Anyone swap out the PS fan with a quiet one? What one did you get? Thanks.

#9114 2 years ago

Go to more RZ shows, I have way too much hearing loss to notice the PS fan. lol

#9115 2 years ago
Quoted from SilverballNut:

I need to figure out a standard switch that will work and just buy a bunch and replace them as I notice issues. Just realized my right loop was doing it last night. Talk about a switch you really need to work first time you hit it.

Is there a better option than the official replacements from PBL?

http://www.pinballlife.com/index.php?p=product&id=4347

#9116 2 years ago
Quoted from snakesnsparklers:

Is there a better option than the official replacements from PBL?
http://www.pinballlife.com/index.php?p=product&id=4347

Well since the originals have given me trouble I used a WPC switch (took off an old NBA fastbreak) and a metal switch bracket for the switch in he 1000C loop. It just performed much better.

I'll probably use the WPC metal switch brackets and get a WPC switch with a similar arm or swap the arm as mentioned above if needed. I'm not fond of the RZ stock switches. They shouldn't give any issues when the game is less than a year old and it seems a bunch of us are noticing problems.

#9117 2 years ago
Quoted from SilverballNut:

I'm beginning to wonder if some of the stock switches just suck. I was having issues with the loop under the playfield (1000C lock) not registering if fast, and hanging balls if slow. Removed the switch and put a WPC era switch in and it's been great.
My 'H' In CHOP doesn't register for the first several hits during the first game of an evening, but then starts working correctly. Same as you I've adjusted and checked in switch mode and seems fine. I don't think it's a bug as much as physically it isn't working until it is hit several times. I was going to try and replace it this weekend if I get a chance.

Do you think brand new switches would help? They work perfect in test but if the ball is too fast, it doesn't work. I get double ball kick out during MB as well. The lane switch seems fine too but I noticed the ball bounces off the back and the switch opens for a split second. Thought about new switches or changing the type of switch. Any news on this issue?

#9118 2 years ago
Quoted from spandol:

Do you think brand new switches would help? They work perfect in test but if the ball is too fast, it doesn't work. I get double ball kick out during MB as well. The lane switch seems fine too but I noticed the ball bounces off the back and the switch opens for a split second. Thought about new switches or changing the type of switch. Any news on this issue?

His latest code V21 lessens the double kick out, but I agree there needs to be some more work done there and he's working on that. Mine does it occasionally.

So as for the too fast symptom, the switch that I replaced under the 1000C loop registers every single time now. This makes me think it may be something physical with the stock switches (not engaging all the way, or bouncing internally on fast balls, or something else).

If it was a software issue, I would expect all switches to have issues, but I have never seen a standup not register even on fast powerful hits, only the playfield switches.

I didn't have enough time over the weekend to change my H switch and right loop switch out, but I'll probably try doing it this week or next weekend.

#9119 2 years ago
Quoted from SilverballNut:

His latest code V21 lessens the double kick out, but I agree there needs to be some more work done there and he's working on that. Mine does it occasionally.
So as for the too fast symptom, the switch that I replaced under the 1000C loop registers every single time now. This makes me think it may be something physical with the stock switches (not engaging all the way, or bouncing internally on fast balls, or something else).
If it was a software issue, I would expect all switches to have issues, but I have never seen a standup not register even on fast powerful hits, only the playfield switches.
I didn't have enough time over the weekend to change my H switch and right loop switch out, but I'll probably try doing it this week or next weekend.

Can you share a link to the switch you replaced it with?

#9120 2 years ago
Quoted from snakesnsparklers:

Can you share a link to the switch you replaced it with?

Pretty sure it was this switch (used in most all WPC games):
http://www.marcospecialties.com/pinball-parts/5647-12693-19

Then you need a metal bracket (forget which one):
http://www.marcospecialties.com/pinball-parts/01-12356-1

or

http://www.marcospecialties.com/pinball-parts/01-12356

I'm building a WPC machine, so had the switches and brackets lying around. It's the standard rollover switch.

#9121 2 years ago

I have started having the switch issue too, are we sure it isnt related to v20? It seems like it manifested a bunch all of a sudden. That said it could just be the batch of switches we have in our machines.

#9122 2 years ago
Quoted from rask4p:

I have started having the switch issue too, are we sure it isnt related to v20? It seems like it manifested a bunch all of a sudden. That said it could just be the batch of switches we have in our machines.

My switch issue is definitely mechanical as when it's not working I can't feel/hear the "click" when I trigger it by hand but once it's working I can.

#9123 2 years ago
Quoted from rask4p:

I have started having the switch issue too, are we sure it isnt related to v20? It seems like it manifested a bunch all of a sudden. That said it could just be the batch of switches we have in our machines.

I really feel it is a mechanical thing. I've ordered a few more switches and I'll try replacing my two inner lane switches, and the outer loop and see what happens. If it clears it up, I may just replace all the switches. There aren't that many and it annoys the crap out of me when a shot doesn't register.

I actually think this may be happening with my upkick to the mini playfield also. Sometimes the ball is sitting in there and the game doesn't see it, but it usually works just fine.

#9124 2 years ago
Quoted from SilverballNut:

I really feel it is a mechanical thing. I've ordered a few more switches and I'll try replacing my two inner lane switches, and the outer loop and see what happens. If it clears it up, I may just replace all the switches. There aren't that many and it annoys the crap out of me when a shot doesn't register.
I actually think this may be happening with my upkick to the mini playfield also. Sometimes the ball is sitting in there and the game doesn't see it, but it usually works just fine.

Sounds good! Keep us posted, I'll probably replace all of mine too if this is the issue.

#9125 2 years ago
Quoted from SilverballNut:

I really feel it is a mechanical thing. I've ordered a few more switches and I'll try replacing my two inner lane switches, and the outer loop and see what happens. If it clears it up, I may just replace all the switches. There aren't that many and it annoys the crap out of me when a shot doesn't register.
I actually think this may be happening with my upkick to the mini playfield also. Sometimes the ball is sitting in there and the game doesn't see it, but it usually works just fine.

Not discounting the possibility of a mechanical issue, but if it were, I would think more would fail at some point. Also, I would think we would have heard more reports of mechanical switch failures. I only replaced the "inner orbit" switch with a Stern rollover because a slow moving ball would get hung up there.
I'm going to keep an eye on switches not triggering. Not always easy in this game.

Question for owners: Do you adjust the flipper and/or sling strength at all? Just curious. I'm thinking about adjusting the upper flipper strength, but I don't want to make it "too easy" to complete the 'What!' mode.

#9126 2 years ago
Quoted from PersonX99:

Not discounting the possibility of a mechanical issue, but if it were, I would think more would fail at some point. Also, I would think we would have heard more reports of mechanical switch failures. I only replaced the "inner orbit" switch with a Stern rollover because a slow moving ball would get hung up there.
I'm going to keep an eye on switches not triggering. Not always easy in this game.
Question for owners: Do you adjust the flipper and/or sling strength at all? Just curious. I'm thinking about adjusting the upper flipper strength, but I don't want to make it "too easy" to complete the 'What!' mode.

i actually reduced my flipper strength to cut down on airballs

#9127 2 years ago
Quoted from PersonX99:

Not discounting the possibility of a mechanical issue, but if it were, I would think more would fail at some point. Also, I would think we would have heard more reports of mechanical switch failures. I only replaced the "inner orbit" switch with a Stern rollover because a slow moving ball would get hung up there.
I'm going to keep an eye on switches not triggering. Not always easy in this game.
Question for owners: Do you adjust the flipper and/or sling strength at all? Just curious. I'm thinking about adjusting the upper flipper strength, but I don't want to make it "too easy" to complete the 'What!' mode.

I have adjusted all of the switches on the slings to make them fire more easily, but solenoids are pretty much all stock power. I don't have a big airball problem and a 3x skill shot is possible. For the upper playfield, I don't find I've got a ton of ball speed when I complete the mode, so I wouldn't be able to reduce the power without causing problems.

#9128 2 years ago

My power are stock except the VUK. I agree my upper flipper wouldn't make it if it was lower. I'm considering making it a bit stronger but kind of like how it is working too.

#9129 2 years ago

With the HO1K switch, I have played with the stock switch and got it 95%.

But I think this switch is the way to go. I just don't have one on hand to try it out. This is the downside of living at the ass end of the planet.

http://www.pinballlife.com/index.php?p=product&id=535

This switch comes as either left or right mounted. I think the rounded top suits that Lane better as the ball can come from either end of the lane.

I have one on my "next order" list.

rd

#9130 2 years ago

That's a great idea. I just used what I had on hand.

#9131 2 years ago

Are there any custom score cards for RZ yet?

#9132 2 years ago

What's the status of the apron mod? I put my name on the interested list back near the beginning, but have never heard anything since.

#9133 2 years ago
Quoted from Cheeks:

What's the status of the apron mod? I put my name on the interested list back near the beginning, but have never heard anything since.

Its slow going with the people who print the apron. I got 9 back.. 1 broke when it was being laser cut (they are fragile till you get the display frame installed)

I am getting the last few together to be shipped out, then it's back to waiting on the printer again. I'm going to get a stock pile of the aprons before I make any other announcements on availability.

One owner had theirs installed pretty quickly, and the latest v21 beta includes fixes for What! mode on the mod.

Once I have aprons (beyond the preorders), I'll be going down the interest list.

#9134 2 years ago

I just got my apron mod in the mail, may be able to get it installed tonight. Depends on how much my other new toy sucks me in...

#9135 2 years ago
Quoted from SilverballNut:

I just got my apron mod in the mail, may be able to get it installed tonight. Depends on how much my other new toy sucks me in...

Make sure to get some good footage of it in action. I don't think we've seen any detailed film so far.

#9136 2 years ago

I got it installed last night and it looks awesome. It's great to have a fully interactive display in the apron. I haven't tried HO1K yet but I imagine it will be much easier to check progress at the apron than looking up at the main display.

#9137 2 years ago
Quoted from snakesnsparklers:

I got it installed last night and it looks awesome. It's great to have a fully interactive display in the apron. I haven't tried HO1K yet but I imagine it will be much easier to check progress at the apron than looking up at the main display.

i think a sound there would be helpful

100 corpses
200 corpses
300 corpses
etc...

I always ask my wife how many corpses i have because you cant look up

#9138 2 years ago
Quoted from xbmanx:

I always ask my wife how many corpses i have because you cant look up

I do the same thing.

#9139 2 years ago

Here is one of the attract screens, think of the possibilities

20170831_175108 (resized).jpg

#9140 2 years ago

Man I hope one of you guys can hook us up with some video soon. It would be awesome to see its functionality as of now which I'm sure will continue to improve over time

#9141 2 years ago

Forgive me if this has already been discussed. Has anyone had the robot stop moving and the associated pop bumper stop working? I have fairly low plays, just turned it on and noticed it wasn't working. Common issue? Quick fix?

#9142 2 years ago
Quoted from davijc02:

Man I hope one of you guys can hook us up with some video soon. It would be awesome to see its functionality as of now which I'm sure will continue to improve over time

Owner of one of the first 4 shipped is going to do an installation video. I'm sure he'll be doing game play as well.

And I have tons to do with this and a few tricks up my sleeves.

#9143 2 years ago

Can't wait to see the video. I've got a feeling i'll be getting one of these....

#9144 2 years ago

So I just finished getting my apron mod installed and played a few games. Pretty cool addition to RZ.

I did have the problem that my hanging bracket didn't quite fit (to narrow) but I managed to get it stuck on for now. I will probably just screw the mod into the backbox next time I'm in there. I hung it more to the left just for wire runs.

First turned the game on and the mod screen was all black. Then I remembered the small displays normally have a backlight switch and I tried turning it on and it all works.

I'd love to see the apron thicker. Never realized how thin the RZ plastic apron was but I got it in without breaking it so guess its thick enough. I'll probably find some black screws/bolts to replace the silver ones. Just cause.

Really cool attract mode that explains all the rules. Nice readouts during modes although you still can't stare at it for long.

I took some pics of the install and also a couple of it just working. I can't shoot a video and play but I'll get my son to hold the phone this weekend if no one else does.

IMG_3909 (resized).JPG

IMG_3911 (resized).JPG

IMG_3910 (resized).JPG

IMG_3912 (resized).JPG

IMG_3913 (resized).JPG

IMG_3914 (resized).JPG

IMG_3916 (resized).JPG

IMG_3919 (resized).JPG

#9145 2 years ago

Thanks for the pictures....Looks good except for the cheesy slotted screws. Needs to be mushroom head black bolts for that polished look.

#9146 2 years ago
Quoted from robertmee:

Thanks for the pictures....Looks good except for the cheesy slotted screws. Needs to be mushroom head black bolts for that polished look.

I agree, small black carriage bolts. I may just paint them black. I'm a little afraid to try taking it apart, the apron seems fragile.

#9147 2 years ago
Quoted from PersonX99:

Not discounting the possibility of a mechanical issue, but if it were, I would think more would fail at some point.

Last night while I was installing the apron I used a meter on my H switch. It is definitely a mechanical issue. I had no current flowing through it until I had depressed it about 10 times, then it started working and worked perfectly every time after and through the handful of games I played after. You can feel and hear a difference between it and the switch next to it. My C switch has a distinct click and mechanical feel, the H switch did not have a click and has a squishy feel. It may be as simple as there is to much grease in it, but it's a problem for sure.

When I get to swapping it out (have a few on order) then I'll check the others, but at this point I'm convinced these switches have a problem (At least some portion of them).

Plan is replace H and O so they match, replace the outer loop right side because it rarely gets hit and replace the VUK because it is critical (precaution). The others I'll check and after these are in a while then I may just replace them all.

#9148 2 years ago
Quoted from SilverballNut:

Last night while I was installing the apron I used a meter on my H switch. It is definitely a mechanical issue. I had no current flowing through it until I had depressed it about 10 times, then it started working and worked perfectly every time after and through the handful of games I played after. You can feel and hear a difference between it and the switch next to it. My C switch has a distinct click and mechanical feel, the H switch did not have a click and has a squishy feel. It may be as simple as there is to much grease in it, but it's a problem for sure.
When I get to swapping it out (have a few on order) then I'll check the others, but at this point I'm convinced these switches have a problem (At least some portion of them).
Plan is replace H and O so they match, replace the outer loop right side because it rarely gets hit and replace the VUK because it is critical (precaution). The others I'll check and after these are in a while then I may just replace them all.

There was some issue with switches at the Spooky factory. I remember my pickup date being delayed a few days due to some issue with switches. Maybe some of these were bad right away, and some of them just go bad after a while?

#9149 2 years ago
Quoted from SilverballNut:

Last night while I was installing the apron I used a meter on my H switch. It is definitely a mechanical issue. I had no current flowing through it until I had depressed it about 10 times, then it started working and worked perfectly every time after and through the handful of games I played after. You can feel and hear a difference between it and the switch next to it. My C switch has a distinct click and mechanical feel, the H switch did not have a click and has a squishy feel. It may be as simple as there is to much grease in it, but it's a problem for sure.
When I get to swapping it out (have a few on order) then I'll check the others, but at this point I'm convinced these switches have a problem (At least some portion of them).
Plan is replace H and O so they match, replace the outer loop right side because it rarely gets hit and replace the VUK because it is critical (precaution). The others I'll check and after these are in a while then I may just replace them all.

This is exactly what mine not he upper playfield is doing. Did you order the Pinball Life (Spooky) switches or are you sticking with the WPC switches and brackets?

#9150 2 years ago
Quoted from spandol:

This is exactly what mine not he upper playfield is doing. Did you order the Pinball Life (Spooky) switches or are you sticking with the WPC switches and brackets?

I'm sticking with WPC switches, but I also ordered some of the pinball life round wire Stern switches. I'm gun shy about ordering the exact type of switches that were in the game since I'm having issues with multiples of them. Switches should and do last 20-30 years, these just aren't...

I guess I could have contacted Spooky about the switches and got some new ones sent to me (honestly forgot I have a warranty ), but they just don't seem like very high quality switches so don't really want to put them back in if I'm going through the trouble to change them.

Promoted items from the Pinside Marketplace
$ 48.00
Cabinet - Other
ModFather Pinball Mods
4,500
Machine - For Sale
Bakersfield, CA
From: $ 34.99
Playfield - Toys/Add-ons
Medisinyl Mods
$ 146.66
Playfield - Toys/Add-ons
Medisinyl Mods
From: $ 18.00
Apparel - Men
Pinside Shop
There are 10478 posts in this topic. You are on page 183 of 210.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside