(Topic ID: 325848)

Road Show Ted Ball Swallow Sensor Not Working

By fuzzylugnuts

4 months ago

Topic Stats

  • 10 posts
  • 4 Pinsiders participating
  • Latest reply 82 days ago by Jmckune
  • No one calls this topic a favorite


Linked Games

#1 4 months ago

Looking for some advise on my Road Show. After locking two balls, dozer gate lifts and Ted opens his mouth. Sinking a ball should close his mouth and start the multi ball. The recent problem is sometimes it takes 3 or 4 times to have him gulp and close his mouth, the first couple of times the single ball ejects from Bob's shelter, no gulp, gate stays up and mouth open. It is as if there is a sensor that is not triggering. Anyone seen this problem? I have had the machine for 3 months and it has low plays. No error codes. Is there a proximity switch inside Ted's mouth like the one in front of the dozer that needs adjusting (instructions on Youtube)?

#2 4 months ago

There are two different eddy sensors that frequently need adjustment for Ted, but that isn't your problem.

Open the playfield lift it up, look where Ted's mouth is. There is a metal ramp, and on that metal ramp is a black microswitch. Something is wrong here, I suspect that there is trash in this area, keeping the switch from activating, but it could be a broken wire to the black microswitch.

Go to switch test, Switch Edges, lift the playfield. You'll probably want to use the yellow clippy thing on the interlock switch on the inside of the front door, but I'm not sure you HAVE to for this switch test.

Whenever you activate a switch you should hear a ding noise. From the bottom of the playfield, check to make sure you can pull the switch activator toward you and that the game responds with a ding sound. The activator could need adjustment so that a ball rolling on the wire inside the trough will cause the switch to reliably activate.

I would get a ball in my hand. On the front of the playfield, in front of the dozer, wave the ball (roll it) on the top of the playfield. With the playfield raised you can see an LED activate on the eddy sensor board. There is a small adjustment for a tiny screwdriver on these boards. The LED should be off, then activate when the ball gets close. These boards need frequent adjustment.

Now, there is a second eddy sensor, and the idea is that if a ball is trapped in front of Ted's mouth, but inside the bulldozer blade, this sensor will activate. Wave the ball (roll it) on the playfield inside the bulldozer area and the other eddy sensor board's LED should light. Adjust sensitivity with a small screwdriver if necessary.

That's where you'll need to look for this problem.

Good luck!

#3 4 months ago

There are two proximity switches in that area as I recall. The first one is for the dozer blade and has no effect on what you're seeing. The second is Ted's mouth and must register to start the multi-ball. Check underneath in the vicinity of Ted's mouth for the small circuit board. I believe you turn the pot until the led light comes on and then slowly back it off until the led just goes out. That is supposed to set the sensitivity correctly.

On my RS, I had to over-adjust the proximity switch such that the led always remained on. Otherwise, the switch wouldn't register. It worked fine by doing that so I never bothered to take it further. Put the game in switch test while adjusting and keep a ball handy to test the switch as you make the adjustment.

#4 4 months ago
Quoted from sbmania:

... and must register...

Interesting! I never knew this. I figured that the black microswitch underneath would be all that is necessary.

I've tweaked these sensor boards so often that I rarely open a Roadshow without adjusting the eddy sensor boards, so I guess I never had the 'behind the blade' sensor be the problem before.

Good advice!

#5 4 months ago

Thanks for the lead on the black micro-switch. I had believed this to be a Eddy Sensor proximity switch #48 (Ted Head)
which you explained as being a switch for balls within the dozer, but not in the mouth. Possibly debris as I just replaced the rubbers
as they ones at the mouth entrance broke and I may not have retrieved all pieces. This did not come to mind and makes sense.
Anyone have a photo of this black switch or is it very apparent once I lift the playfield and look at the metal ramp. Any harm in
using compressed to lightly blowing debris from mouth or how is this cleared (with finger, brush... etc.?)

#6 4 months ago

The IPDB is a great resource, they have a link to the manual, and frequently they have pretty good pictures:


If something were rattling around in this short metal ball ramp I wouldn't hesitate to use a 1/4 nut driver and remove the metal ramp from the bottom of the game. Couple of screws and you are done.

1 month later
#7 88 days ago

So, I agree htat there is a rollover micro switch on the metal ramp under Ted's head and that is likely the problem (two balls locked,
mputh opens but sinking a ball does not register for multiball). I removed the ramp, no obstructions. Switch seemed to click but I replaced
it with a NOS Williams microswitch off ebay (Gameroomguys), that did not solve the problem. There is a diode on the old switch which I transferred,
could this be the problem, do these ever go bad?

#8 87 days ago

Diodes can fail, but it seems that technicians other than I find a lot more failures than I do with diodes.

Make sure you have connected your wires right, and that the diode is pointing in the right direction. Any other black microswitch will show you which way the diode band should go, and which two terminals the different colored switch wires go to.

Does the switch register in test mode? It should make a 'ding' sound in switch edges.

Let us know!

#9 82 days ago

The diode is in the correct direction, wires are correct (took photos before removal). I do not get a switch failure. I am told diodes rarely go out, wondering if it can be checked with an ohm meter? A this point I am baffled and may be time to take it in to the shop. Tried all the rubber band mechanic solutions trying save a few $.

#10 82 days ago
Quoted from fuzzylugnuts:

The diode is in the correct direction, wires are correct (took photos before removal). I do not get a switch failure. I am told diodes rarely go out, wondering if it can be checked with an ohm meter? A this point I am baffled and may be time to take it in to the shop. Tried all the rubber band mechanic solutions trying save a few $.

Post a pic anyways. Just because you took a picture of it before does not mean it was correct. You said it wasn’t working then either

Promoted items from the Pinside Marketplace
From: $ 6.50
Playfield - Other
Rocket City Pinball
Machine - For Sale
Sussex, WI
From: $ 1.00
Slap Save Creations
$ 11.95
Playfield - Toys/Add-ons


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/road-show-ted-ball-swallow-sensor-not-working and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.