(Topic ID: 83745)

ROAD SHOW CLUB (Hard hats required on site)


By webdiddy

6 years ago



Topic Stats

  • 2,098 posts
  • 303 Pinsiders participating
  • Latest reply 7 hours ago by Axl
  • Topic is favorited by 119 Pinsiders

You

Linked Games

Topic Gallery

There have been 520 images uploaded to this topic. (View topic image gallery).

received_543832139875643 (resized).jpeg
79DEEDE5-29B7-45D2-9B81-9039480A42B6 (resized).jpeg
699F2580-E4D9-4052-9C39-7E668F9EEED1 (resized).jpeg
Screen Shot 2020-05-13 at 2.46.43 AM (resized).png
20200513_132402 (resized).jpg
Schermata 2020-05-03 alle 19.50.19 (resized).png
IMG_20200424_222854__01 (resized).jpg
IMG_20200426_131550__01 (resized).jpg
20200422_183322 (resized).jpg
20200422_170724 (resized).jpg
IMG_20200414_124447 (resized).jpg
RSFish (resized).jpg
20200411_182706 (resized).jpg
20200411_182720 (resized).jpg
97b34569b9746c043edf9571a128057ca89bfb21 (resized).jpg
C5F8254A-66CB-4A4E-A321-38A148960406 (resized).jpeg

You're currently viewing posts by Pinsider kechlesurf.
Click here to go back to viewing the entire thread.

#1417 2 years ago

I picked up Road Show on Sunday and am starting to figure the game out and it is a lot of fun. The game is in great condition but I do need to attempt to fix a few things.

For Red, her mouth does not open and need to look into what is wrong with it. I know it gets power so I assume it has something to do with the gears being old. Any recommendations or suggestions of what I should look at before finding parts to fix?

And for Ted, his mouth also does not open and the bulldozer front does not go up.

For both Red and Ted, the eyes work fine but plan on attempting to fix the above issues this weekend. I am going through the thread and have watched the PinballSupernova video rebuilding Ted bulldozer motor but any suggestions or advice would be very much appreciated.

Roadshow Pic (resized).JPG

#1420 2 years ago
Quoted from hlaj78:

Did you run a test from the menu?

Yes, ran a test on the bull dozer and it goes up and down. As for the mouths, I can hear the motors moving but nothing is happening. I will look at the gears later tonight when i have some time.

#1422 2 years ago

Since the bulldozer works during test, I am assuming it is the opto board, where can i find this part and make sure i order the correct part?

As for the motors for the mouths, I take back what i said. I DO NOT hear the motors running during test so i am assuming the motors are either bad or not functioning. The eyes in both Red and Ted work fine, open and shut and look from side to side. I found the motor (9-18VDC - Radioshack part #) but I am not able to find this motor anywhere. I am going to take apart the motors this weekend and clean them up and follow the walk through that was posted by PinballSupernova (https://pinballsupernova.wordpress.com/2018/03/25/pinball-repair-repairing-teds-bulldozer-front-on-williams-road-show-motor-rebuild-and-parts-replacement-video/).

I would prefer to replace the motors since they are relatively cheap but might as well take the motors apart and clean them since i am unable to find them. Any suggestions where I can find this motor? Or any suggestions for me to look at while I am trying to fix these issues?

#1426 2 years ago
Quoted from alexanr1:

Reading your posts and having a RS myself and having dealt with bulldozer, jaw and eye issues, I recommend you lift the playfield and run the various tests while watching what happens. You will unlikely be unable to diagnose the real problem from the top of the playfield. I had to take the head apart to diagnose eye issues.

I did that the other day and I know the motors for Red and Ted do not run. I am hoping one day this weekend to have a few hours to take the motors out and clean them up a little to see if that helps.

2 weeks later
#1432 2 years ago

Last night while i was playing Road Show, I noticed that the magnet that senses the ball that hits the bulldozer to advance to the next day stopped working (hoping the magnet is the issue). When I get home today, I will look under the playfield for the small green board right under where the ball would travel to see if it needs to be adjusted.

I am hoping that will fix it but if it doesn't, any other suggestions of what it could be?

1 week later
#1434 2 years ago
Quoted from razoraustralia:

I can recommend the Great Lakes Modular Opto Board for the blade; http://www.greatlakesmodular.com
The blade operates in the game via the ball travelling and being detected by the eddy boards on the underside of the play field, the original ones are known the deteriorate over time. They have a pot that allows them to be adjusted which would be worth a look at. Replacement ones of these can be purchased from Pinbits.

I am looking at the Great Lakes Modular Opto Board (RS-BOB Road Show Blade Interrupter Board) as I went under the playfield and adjusted mine until the red light came on and then backed it down a little so it went off and tested it. It did not recognize the pinball above it. Going to order one of these and swap it out and hopefully that fixes the issue.

#1436 2 years ago

After figuring out that adjusting the eddy board does not fix the issue, i guess the next step is trying to find another eddy board to replace it. I looked around and couldnt find one anywhere and there was a link earlier in this thread that had a link to the company that sells it but they were sold out.

What other options do i have to fix the eddy board? The game is still a lot of fun to play but definitely takes away from it when you cant get multiball, or smash taxis.

#1440 2 years ago
Quoted from purplemunkydishw:

Kechlesurf: You are confusing two boards and their purpose.
The Opto interupt board is the one on the bracket that also holds the blade lift motor. Its purpose is to read the slots on the black wheel and let the game know what position the blade is in, "Up" or "Down". The great lakes replacement board, RS-BOB is for this. The original board and the RS-bob don't have any adjustments on them. It wont help with your issue.
The eddy board is the one with the adjustment and the red LEDs, and that's the one that tells the game the ball is hitting the dozer blade. The adjustment on there is really touchy and since this game likes to shake itself to literal pieces at times, prone to broken solder connections.

You are correct, when i asked about the board the other day, i misunderstood what i was told. So not worried about the Opto interrupt board as the blade goes up and down during test.

I have adjusted the eddy board to turn the light on then slightly back to turn it back off. It did not stop working all at once but slowly got worse and worse over a couple week period to not working at all now. And the shaker motor does not work right now and that is what i will look into next (hoping that is an easy fix similar to Earthshaker). But i will look at the solder connections and redo them to make sure they are good and clean and hopefully that will fix it but will have to wait and see.

#1447 2 years ago
Quoted from tonyf1965:

Shaker motor can be turned off and on in the menu settings. Also low and high. On the adjustment for the sensors. I had to on mine. Crank the pot all the way up and down, many times. Over time the pot being set to same basic position. It gets slightly corroded. Pot not linear any more. This will clean the contacts. After that it will take a few tries in the test mode running ball past the Eddy sensor to get it dailed back in. You will need to tweak it back in. Reajust probably 3 times. Over a month.

Thanks for the response and info Tony. Can you elaborate more on what you mean by "pot"? Are you referring to the dial/screw that turns the light on and off?

#1449 2 years ago
Quoted from hlaj78:

Yes, he is referring to the dial/ screw. Pot is short for potentiometer.

Thanks for the clarification hlaj78. I plan on getting under the playfield this weekend to see what if I can get it working. Also going to go through the settings and hope the shaker is turned off and replace the gears for the bulldozer and Red's jaw. I am kind of learning as I go and doing a lot of reading so will see what happens.

1 week later
#1453 2 years ago

I was able to get the eddy board working well and have been able to get the bulldozer to work as well. The jaws on both Red and Ted still do not work but havent looked into them to much yet. I am working on getting the shaker motor working next and have been able to get it working but it is violent and seems like it is unbalanced or something.

I have my Road Show next to an Earthshaker and the Earthshaker motor is much smoother and vibrates the machine. The Road Show shaker is sporadic and sounds like beating a piece of metal almost. I tried to post a video of it but couldnt get the video to upload. Should I expect the shaker motor to be similar to Earthshaker or is Road Show shaker just a violent shaker?

#1455 2 years ago
Quoted from purplemunkydishw:

The shaker on this game is a lot more intense than other games, it is possible though, the channels the playfield glass slides into are a bit worn and you are getting rattle from the playfield glass. I added a strip of electrical tape to both edges of my glass to cut down the noise a bit.
Here is a clip from an old twitch stream I did, you can hear the motor firing off a bunch. ยป YouTube video

Thanks for the clip. The shaker sounds just like it does on my machine which surprises me. With Earthshaker, it is a much smoother vibration (but stronger vibration), Road Show just sounds unbalanced or off. But at least this confirms that my shaker motor works as it should (just like yours in the video) and I need to decide if i want it on or off. Thanks for the clip Purplemunkydishw

#1457 2 years ago
Quoted from TheOnlyest:

Mine was the same, my house is built on a slab, and I was worried that over time, the legs would jackhammer through the floor! I did 5 different things just to get mine to about the same intensity as my Earthshaker...
1. Removed one the 2 counterweights.
2. Put 2 star post rubbers on each of the bolts between the housing and cab.
3. Removed bracket that attaches the motor assembly to the side of the cab.
4. Added a 100 ohm ceramic resistor to lower motor voltage as much as possible without damaging the motor.
5. Put it on the lowest setting in the menu.
Eventually I will make 2 custom counterweights that will resolve the entire issue by itself, but its more complicated a project than it sounds.

Great suggestions. Is it possible to put an Earthshaker motor in Road Show? I am not sure if it is the settings of the machine to make it "shake" the way it does or if it is the motor itself but Earthshaker has a great shake to it, would be nice to emulate it on Road Show.

I will remove one of the counterweights tonight and get a couple of post rubbers on the bolts as well. The shake does not bother me but the way it shakes really sounds like something is off but oh well. Will try a few things to see if i can make the shake more enjoyable as i really enjoy the shaker motor on Earthshaker.

#1459 2 years ago
Quoted from BigLebowski:

have you tried adjusting the shaker via the settings menu (only possible with >v5)?

Yes, have made adjustments through it and it definitely lowers the violence of the motor, but it isnt a smooth shake like it is on other machines. It shakes as if it is off balance and just doesnt seem right, but looking and listening to videos, i guess that is how the motor is suppose to work

#1462 2 years ago
Quoted from purplemunkydishw:

I think the idea is the Shaker is supposed to approximate a bulldozer running, so its supposed to be a bit rough. I think its part of the charm.

Makes sense. Ill add the rubber post and do a couple of things to try to take the violence out of it. Dont get me wrong, I do like it, but when it really gets going, just sounds like something isnt working correctly but like you said, part of the charm.

1 month later
#1469 1 year ago

Picked up a ColorDMD over the weekend for my RoadShow. It seemed pretty easy to install and i followed the instructions on colordmd.com but can not get the firmware to load.

When I initiate the USB Download, I read the "Prog" will light up and take about 30 seconds or so and it is completed when the "Done" light turns on. My "Prog" button keeps blinking and the "INIT" light is lit.

For step 15, I push the far right button and get display options (contrast, brightness, etc) but i do not get the "mounting" menu and select "WPC". What am i doing wrong or any suggestions?

Color DMD (resized).JPGcolor dmd chip (resized).JPGcolor dmd chip 2 (resized).JPG
#1471 1 year ago
Quoted from Indusguys:

I have had a similar issue before, I would recommend trying a different thumb drive, and make sure the Colour DMD file is the only thing on the drive.

OK, the drive is empty other than the DMD file. I have other drives i can use, just have to find one. Will try that today.

#1474 1 year ago
Quoted from Capinball:

How big is your flash drive? I think I had an issue with using one before because it was over 8gb in capacity. That could be your issue.

I tried a 2GB and a 4GB. I have more at work that i will try when i get home

#1480 1 year ago

Fixed, one of my connectors was loose.

Roadshow1 (resized).jpgRoadshow2 (resized).jpg
4 weeks later
#1499 1 year ago

New problem popped up over the weekend but I am thinking it is an easy fix. During game play, the game resets. It happens at different time from when you plunge the ball to start the game, when it hits the blast zone, bulldozer blade, etc. Any ideas of where i should look first to diagnose the issue?

2 weeks later
#1502 1 year ago

Issue just popped up when i got home from work and turned on RS for a game. The game starts fine, and i hit the start button, and it starts up but the ball never comes out and neither of the flippers will fire. I checked around and didnt see anything loose, and did not have find any loose connections, any recommendations on what the issue is?

#1508 1 year ago
Quoted from mastercello:

Most probably a fuse in the coil section...have you checked them?

I checked fuses and they look fine as that was the first thing i checked. I was checking all the ribbon cables (machine is resetting when both flippers are pushed during game play) and making sure they were all seated correctly and when i went to test flippers during game play, that is when i discovered the issue.

Frustrating but hopefully i can figure it out and learn how to fix a simple issue like this.

#1511 1 year ago

Well, went through the machine to see if i could diagnose the flippers not working and and the ball never coming out. I had a blown fuse on the WPC Power Driver board, F107, S-B 5A 250v, and replaced it and it fixed issues. The game would play, flipper reset issue went away. But after 3 or 4 games, game reset during multiball and the start button stopped working .

Any suggestions where i should start looking next?

4 weeks later
#1524 1 year ago

Looks nice and doesn't seem to expensive. I would go with yellow. If you order, post some pics for everyone to see how it looks, I may be interested in adding this mod to my Road Show.

2 weeks later
#1528 1 year ago

I put on the Convolux plastics this weekend and was very impressed. The pictures do not do it justice(Im not a great photographer) but i was happy with the look of it. The only complaint i had is i wish there were more plastics. The RoadShow package only came with 5 pieces and only covers a few plastics on the lower playfield. Would be great if they would make plastics for all the playfield as they really make the color pop, especially in a dark room.

Roadshow1 (resized).PNGRoadshow2 (resized).PNGRoadshow3 (resized).PNGRoadshow4 (resized).PNG
1 month later
#1540 1 year ago
Quoted from mjenison:

I have some Roadshow parts available from a stripped cabinet project I picked up years ago if anyone needs some of the more obscure parts (no plastics).
http://www.darkstararcade.com/mars/parts/pinparts.html

I checked and didnt see any boards. Do you happen to have the board for the dozer blade? Mine is shot and only way to fix it is to replace.

#1542 1 year ago
Quoted from mjenison:

Got a picture of one? I'll check. I do have the Eddy sensor boards.

Ill have to take a picture when I get back to the house. The Opto Interrupter Board for the dozer was Great Lakes Modular and below is a pic from their site of the board.

As for the eddy board, I need the one near the dozer (but could take both just to have a back up). PM me with prices and lets work something out. My machine plays great other than the dozer blade not working and the jaws for both Red and Ted not working.

GLM Opto Interrupter Board (resized).png
1 month later
#1564 1 year ago

Does anyone have any old boards laying around, specifically the Opto Interrupter Board for the dozer (currently have the Great Lakes Modular but it stopped working) and the eddy board near the dozer?

2 months later
#1687 1 year ago

Definitely B

1 month later
-1
#1737 1 year ago
Quoted from gweempose:

I just installed Soren's patch and I couldn't be happier. This takes the main complaint that people have about the game and completely gets rid of it. Bravo, sir!!!
[quoted image]

I have not heard of this patch. What does it fix and where can I find this?

3 weeks later
#1778 12 months ago

I decided to swap out my colorDMD to my fish tales and when i put the dot matrix display back in Roadshow, connected everything, and turned it on, it turned on for about 3 seconds, vibrated, and went blank (no lights on playfield or sounds). I turned it off and back on and nothing happens, no lights come on on the playfield, display or any red lights on the boards.

What did i do wrong and how to a remedy this situation?

#1783 11 months ago

Swapped out my ColorDMD from Roadshow to Fish Tales the other day. But when I plugged the old display to Roadshow and turned it on, the machine's shaker went on for a second and shut off. Now nothing is happening when you turn the machine on. Figured I blew a fuse and will test them when I get home from work today, but wanted to see if there is anything else I should look at if the machine does not have a blown fuse.

#1790 11 months ago
Quoted from Lermods:

Did you plug all the cables in the correct way?

Yep, i checked that. Unplugged the display completely and plugged it back in. But after it turned on the first time for a few seconds, shook and shut off, it does not power on at all anymore

1 week later
#1802 11 months ago
Quoted from TOLLS:

Get some comet rings into those bumpers. They take this game to another level.

Comet rings? Please elaborate, I must be missing something.

1 month later
#1834 9 months ago
Quoted from purplemunkydishw:

You might get lucky and find the bolt is just undone on the right side. But you still need to pull the ramps to access it.

My bulldozer works during test but not during game play. Believe it is the board but can not find the board anywhere.

1 month later
#1864 8 months ago

I have had the same issue with my Road Show since I picked it up and hoping I can find some info to help fix it. Red's mouth stays open all the time and during game play, the dozer blade does not work (go up and down). Red's mouth is always open and does not close during test though the dozer blade works during test mode.

I have done research and believe it is a board issue. Does anyone know which board I will need to look at, can it be fixed or is there any replacement boards out there?

The game plays great and I have lived with the dozer and Red's mouth not working for a while now, but really want to get this issue fixed. Any advice/guidance is very much appreciated.

3 months later
#1937 4 months ago
Quoted from ClarkKent:

I know that but no idea where to get a burned ROM replacement

Agree, where can these be found as i am interested in giving it a try

Promoted items from the Pinside Marketplace
$ 11.00

You're currently viewing posts by Pinsider kechlesurf.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside