New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 220321)

RFM: HELP! "Coin Door Open" error - bad interlock switch or....?


By quinntopia

2 years ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by quinntopia
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

Interlock (resized).jpg
IMG_7151 (resized).JPG

You're currently viewing posts by Pinsider quinntopia.
Click here to go back to viewing the entire thread.

#1 2 years ago

Hi Everyone!

Hoping someone can give me some good insights into my Revenge From Mars. I just got the machine a week ago (yep! Super-thrilled!), played at previous owners and it worked/booted up just fine. But when I got home and had it all re-assembled, I get the "Coin Door Open" error with all 50v parts disabled, etc....

Wah-wah....the thrill of playing is on hold! Argh!

I found that one of the leads from the Coin Door Interlock to the 'tabs' on the back of the switch had come loose. I tightened it up and replaced, but that still made no difference. Still 'Coin Door Open' error.

I have done a couple of the basic checks (e.g. backbox ground braid attached), but one of the first tests I've done seems to be a major clue, so looking for some guidance from anyone here who help!

When I tried a continuity test on the leads (spade connector tabs?) on the back of the interlock with the door closed (as shown in photo below) I do NOT get a continuity signal. I'm not an electrician, but it seems to me with the switch closed, there SHOULD be continuity, right?

As confirmation that this might be the problem, with RFM powered up and the multimeter leads applied to the spade/connector tabs on the back of the machine, the 'Coin Door Open" error message goes away and all the LEDS light up - looking like the error was solved.

This seems to tell me that my coin door interlock switch is bad. Does that sound right to any one with an RFM or more knowledge about these Bally/Williams pins?

I assume I can probably get a new one, but before I do that, I wanted to know what the consensus is on the fault and my discovery of no continuity and proper boot up when the tabs are 'shorted'? There are some less obvious tests or checks that I can investigate, but I feel like I found the issue right away, but what do I know!?

Thanks in advance for any advice!

IMG_7151 (resized).JPG
#3 2 years ago
Quoted from ForceFlow:

You can pull out the stopper while the coin door is open as a test. Also try pushing it in with your hand, rather than closing the coin door.
It's possible that the bracket on the coin door isn't quite pushing in the switch far enough. On my RFM, the operator who owned it ducked taped a few layers of cardboard to the bracket.

Thanks Forceflow! Yeah, that was one of the first things I tried when I got the message after I replaced the lead on the back. I've attempted moving the stopper in/out as far as it would go either direction, with no change in the error message. So this had me thinking that the problems might be back in the PDB or the ground braid, but my continuity test seems to indicate the problems in the interlock.

I may remove it and shake it up to see if there's any debris or loose stuff in the interlock

#4 2 years ago

I removed the interlock, messed with it a bit, and decided to just order a new one. I jumpered the two leads that go to the back in the interim to start playing, and it seems to work fine!

2 weeks later
#6 2 years ago
Quoted from toddtuckey:

You have the tabs on the wrong terminals...it ONLY uses one side of the switch--the way you have it, the electrical contact could never happen......pick either side of three...and slide wires on the outside and the third terminal...leaving the middle terminal empty and problem solved! Todd

Thank you Todd! I was out of answers when my brand new interlock didn't work! Much appreciated!

1 week later
#8 2 years ago

Thanks again Todd and GPE.

It’s pretty hilarious now in retrospect, but my dumb mistake was because of my lack of experience with an interlock type switch like this.

Now that I think about it, I should have looked more closely at the switch after I noticed all those six “extra” connectors on the back and I might have seen the “NC” and “NO” markings.

Or Google how they work!

Anyway, following your advice I was able to properly connect it and it works now!

Thanks again!

Promoted items from the Pinside Marketplace
$ 50.00
3,500 (OBO)
Machine - For Sale
Discovery Bay, CA
$ 86.95
Cabinet - Shooter Rods
Super Skill Shot Shop
3,600 (OBO)
Sale Pending!
Jersey City, NJ
From: $ 18.00
Apparel - Men
Pinside Shop

You're currently viewing posts by Pinsider quinntopia.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside