(Topic ID: 175162)

RFM Boot Issue - Not Solved, Back Again - Motherboard


By maffewl

3 years ago



Topic Stats

  • 96 posts
  • 14 Pinsiders participating
  • Latest reply 3 years ago by RoyF
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 27 images uploaded to this topic. (View topic image gallery).

IMG_7677 (resized).JPG
IMG_7676 (resized).JPG
IMG_7675 (resized).JPG
RFMmemory (resized).jpg
RFMmonitorCable (resized).jpg
pin2kGXMAV (resized).jpg
pin2k586GXm (resized).jpg
IMG_7228 (resized).JPG
IMG_7226 (resized).JPG
IMG_7227 (resized).JPG
IMG_7225 (resized).JPG
P2K - cga cable (resized).jpg
RFMvideomaybe (resized).jpg
CGA (resized).JPG
IMG_3830 (resized).JPG
IMG_7218 (resized).JPG

You're currently viewing posts by Pinsider maffewl.
Click here to go back to viewing the entire thread.

#1 3 years ago

Edit: I thought I had solved the issue, but apparently not. It's back again. Video and pics posted in Post #30

Edit: I purchased the machine and would appreciate any help.

Hey everyone. I'm looking to purchase a Revenge from Mars that has a boot issue. The owner says it will eventually boot up and work fine but it takes several tries. He said that it will usually load up to the RAM and then freeze, and you have to turn it off, and back on, several times until it works. He said that he tried replacing the power supply with another from an arcade machine that produces the same specs and had some luck in that it didn't do it as frequently, but still did it. Like I mentioned, I'm interested in purchasing this machine and am curious what I may be getting into in terms of repair/costs/etc. Any guidance would be appreciated.

#2 3 years ago

Bump, any thoughts?

#6 3 years ago

I purchased the RFM and don't have the keys to the back of it, so I will have to drill the locks, but here is where it freezes and either resets and reboots itself, or just freezes. From what I saw, a majority of the time it froze at the Black/Grid "Please Wait" screen, then re-booted itself. Sometimes it would get to the White "Please Wait" screen, then freeze on the first Blue text line. As I mentioned, I wasn't able to get into the head of the machine to check the computer/fans/etc, but am curious what kind of issue this sounds like. Does it sound like a fan issue, a CPU capacitor type issue, or...? Any help is appreciated.

IMG_6674 (resized).JPG

IMG_6673 (1) (resized).JPG

#8 3 years ago

Thank you for the comments j_m_, knockerlover, and dgoett. I'll drill the locks, get into the computer, and try out your suggestions.

Edit: j_m_, the .pdf document link isn't working. Nevermind, I saw that I had to delete the portion before the http.

#10 3 years ago

K... I was able to get to the computer and check a few things out. First, it appears someone at some point has changed the CPU fan as it is from Radio Shack, and also, that fan does not work. Also, it sounds like the PSU fan is struggling. So I believe a new PSU and CPU cooling fan is in order. The caps look good from what I can tell (pics attached), and only 1 of the main 5 is green (none are blue). The others are black. I don't know if that means they were replaced at sometime or...? I tried re-seating the Prism card, as well as the RAM (there was only one module), and the game still froze. This time it froze at the end of the white "Please Update" screen at something about "Updating Game".

I'd like to go ahead an purchase a new PSU, CPU fan, and the recommended higher amount of RAM. Can someone recommend a product for each so that I can make sure to get the right thing? I do wonder though, how any of these could be causing the game to freeze, and is it more likely to be something else?

IMG_6702 (resized).JPG

IMG_6704 (resized).JPG

#13 3 years ago

Awesome, thanks for the replies. I've ordered a PSU, CPU fan, and RAM. Don't know that this will help the boot freeze issue, but these are items that needed replacing regardless.

#14 3 years ago

Great news! Revenge from Mars is running like a champ! If anyone else is running into an issue, here's what I did. I completely disassembled the computer, cleaned all components, replaced the 5 capacitors commonly recommended, cleaned and re-thermal-pasted the CPU to heatsink, replaced the motherboard battery, replaced the CPU fan, and replaced the PSU. Thanks for all the help from everyone!

#16 3 years ago

Well, there goes that. I was hoping my RFM was fixed and bulletproof, it thought otherwise. The boot issue is back again. It freezes at the last blue line on the white screen, something about "Starting Update Game Rom" or similar. Sometimes it just freezes, and sometimes it re-boots itself. In a couple rare instances it will start the game, then boot itself.

As mentioned before, I've replaced the PSU, CPU fan, and the 5 common problem capacitors. My friend has a SWEP1 and let me use his computer to narrow down the issue, and I've narrowed it down to the motherboard. I've altered and replaced everything else. Any thoughts on what to check on the motherboard?

#18 3 years ago

Thanks for the comment markmon. Is there a way to check/fix that?

#20 3 years ago

So I've been reading all I can, and apparently replacing the batteries without the computer being turned on can cause BIOS issues. Of course, this is what I did. When I had the motherboard removed to replace the caps, I went ahead and replaced the battery as well.

Sorry to sound like a total noob, but when I removed the computer last night to try to get to boot outside of the machine, my lcd monitor said no signal. It wouldn't show anything (eventhough when the computer is in the machine, it boots to the last line of the white screen then freezes). Do I have to use an older monitor, or? Also, I'm not sure how to connect a keyboard to this. Again, sorry, but some of this older computer stuff I'm not familiar with. Any help is appreciated.

#22 3 years ago

Thanks YeOldPinPlayer, I'll take a look around lunch. I'll also try to take/post a video of the freeze issue.

#25 3 years ago

j_m_, I replaced the motherboard battery. I haven't replaced the Prism Card battery yet (waiting on shipping). Also, do you know where the non-volatile section of RAM is located? This may be something to check.

Brtlkat, so is there no way for me to connect a monitor? Otherwise, what is the recommended way to get to the BIOS?

#30 3 years ago

Thanks for the comments everyone. I was able to take a video at lunch and it cooperated by showing every issue that I'm having with it. It has it all, the full boot, boot then press a button and reset, and freeze. I've added times for each in the information of the video if you don't want to watch it all.

Any help would be greatly appreciated!

Also, here are some pics of the board in the case, and hooked up right before the video. I'm also included the magnified areas that I soldered (though someone had soldered there before me as well) showing that the traces around should be good.

IMG_7213 (resized).JPG

IMG_7212 (resized).JPG

IMG_7214 (resized).JPG

IMG_7216 (resized).JPG

IMG_7219 (resized).JPG

IMG_7218 (resized).JPG

#32 3 years ago
Quoted from sparkup:

Did you run your friends computer in your machine? Or just swap parts around?

I did. I changed everything with everything, down to processors and cables. I've narrowed the issue down to the mainboard. I can run either person's game fine with his mainboard (regarless of processer/cables/etc). However, any combination of elements with my mainboard leads to re-boot & freeze issues.

#34 3 years ago
Quoted from sparkup:

Have you tried swapping ISA slots for the prism?
Have you swapped out the CPU? Pins straight? Socket cleaned?
Motherboard not shorting out on the case standoffs?

Yes to all the above. I do appreciate the comments though. Keep them coming.

#37 3 years ago
Quoted from YeOldPinPlayer:

http://www.pinwiki.com/wiki/index.php?title=Pinball_2000_Repair#Motherboard_Issues
Clay mentions five specific caps in the above section of the Pinwiki, as well as testing by connecting to an external monitor without the prism card installed. Pay attention to his notes on multi-layer PCB soldering procedures.

I replaced these (as well as the ones on my friend's board). I didn't have much issue in the process, and the solder joints appear good.

As for removing the computer to test, I tried with and without the Prism Card. The computer monitor said "No signal".

#43 3 years ago

My friend's SWEP1 that is seen in the video has the CRT replaced with an LCD monitor. Can I just connect that to the computer (with Prism card removed & keyboard attached)? If not, from j_m_'s comment, it sounds like he should have a converter board that I could borrow for pulling the computer and testing outside the machine. Again, I very much appreciate the help everyone.

#58 3 years ago

Hey everyone, thanks for the discussion and help so far. I was occupied this evening so I wasn't able to do anything with the machine, but please keep the thoughts coming as I will be back at it tomorrow/this weekend.

#60 3 years ago

K... it turns out that my friends machine does not have any converter from the computer to the lcd. It's plugged straight in. That said, I was able to test his machine without the Prism card. His booted right up to the BIOS. When I attempted to do the same with mine, the screen simply said "No Signal" as if it wasn't connected at all. I then switched our video adapters (the part that the monitor plugs into), and same result. His boots, mine shows "No Signal". The computer does sound like it is doing some "thinking" though, even though nothing is shown on the screen. Any ideas? Is it shot?

#62 3 years ago
Quoted from YeOldPinPlayer:

Were you using your LCD monitor to test your friend's computer? Something doesn't add up if your computer is connected exactly the same way to the same monitor and says no signal.

Exact same setup. I plugged the power into his computer, plugged in the monitor, and turned it on. It booted BIOS. I took his computer out. Put my computer in. Plugged in the power, plugged in the monitor, and turned on. It showed "No Signal". Just to triple confirm, I'm going to replace his RAM, CPU, and PSU, one at a time with mine, and report back. This will 100% confirm that it is the mainboard that is the issue. But the "No Signal" has me a bit baffled as to what to look for.

#64 3 years ago

I appreciate the comments. I would be happy to photograph or video anything I need to, but his setup is the exact same as mine. Same mainboard, CPU, components, everything. The two systems are identical. And in the cabinet the cord clearly goes from computer to LCD without any converter. I'll take a pic of each of our systems and post.

That said, I just tried switching the CPU, RAM, and tested both PSU's. No dice. This leads me to believe it's an issue on the mainboard.

#66 3 years ago

Photos as mentioned. My computer. My friends computer. And the LCD connection.

IMG_7225 (resized).JPG

IMG_7227 (resized).JPG

IMG_7226 (resized).JPG

#68 3 years ago

yeoldpinplayer, this is what I have done. I am not using multiple LCD's. I am only using his cabinet for testing. I.e., I'm putting my computer in and turning on with only the power and monitor attached. I get "No Signal". I unplug mine, put his in, and only plug in the power and monitor, and his boots to BIOS. Then I went through this process (place my computer in, test, then place his computer in, test) for each item - CPU, RAM, and PSU. All resulted the same, when I use my computer (and my mainboard), I get "No Signal", and when I put his computer in (and his mainboard), it boots to BIOS. Again, I very much appreciate all of you sticking with me and helping.

#70 3 years ago
Quoted from Brtlkat:

Looks to be a tri sync lcd monitor would need the model # to verify.

Tovis L1751VN3LB

IMG_7228 (resized).JPG

#73 3 years ago
Quoted from Brtlkat:

Sounds like the mobo then. But FWIW if it is a true pinball 2000 setup this will only generate a CGA signal.

Any thoughts on what to maybe check on the mainboard? What's weird to me is that when the Prism card is in it puts signal out, but when just trying to boot BIOS there's "No Signal". And as shown in the video in the first post, sometimes it will even boot to the game, and act "normal" when the Prism card is in. Any thoughts or am I SOL?

#77 3 years ago

I just checked. With only the power and monitor connected, and no Prism card, I get "No Signal". If I install the Prism card (again, only having the power and monitor connected), I at least get the "Please Wait" screens.

Even more weird, once I connected the parallel port, it booted up all the way and let me play a game. I even reset it one time and it let me play another one. Then it started its reboot/freeze issues on the subsequent reset attempts. I'm gathering that when it's "cold", it seems to boot up, but maybe when it warms up, it starts having issues.

This still doesn't answer why I'm getting "No Signal" and my friend's computer boots BIOS.

I'm sure this is a crazy simple stupid problem, but tracking it down is mind-boggling.

#80 3 years ago
Quoted from YeOldPinPlayer:

OP, has your problem progressed to the point that you never get video now? The video you posted showed the machine partially working but from your subsequent posts now you get no signal every time?

No, the situation is still the same as in the video. I only get "No Signal" when I try to boot the game to the BIOS. I.e., remove the Prism card, and only connect the power and a monitor.

#83 3 years ago

I just did the same tests in my RFM as I did with my friend's SWE1. Note that my RFM has the playfield currently removed and on a rotisserie for tear down, so I didn't connect anything beyond power and monitor.

That said, I placed my computer - no Prism card, into the RFM cabinet, connected the monitor (mine has the original CRT), connected the power, and nothing showed on the screen. Did the same with my friend's computer, and his showed activity.

I haven't been able to try Prism card in slash keyboard method as I don't have a keyboard with a PS2 connector. I'm trying to get a hold of one of these so that I can test.

#86 3 years ago

I appreciate the continued support and help. I just made 3 videos showing how my friend's computer boots, and how mine boots - with no Prism card installed.

What's weird is that mine boots to BIOS the same as my friend's sometimes on first try, and acts normal (you can hear the shock in my voice in Video 2 of 3). I.e., it's been sitting out unplugged all night. I've noticed that on the first attempt that it typically does this, and seems to run fine. However, if I let it warm up and reset, it shows as "No Signal" (again, no Prism card installed). This situation of it booting up normal when "cold" can be seen in the second video. However, I have tried letting the computer sit for a while, and then turn on, and this doesn't always work either. So I don't think the issue is temperature related. The third video shows the more common "No Signal" issue.

Also, I realize about halfway through the 2nd video that I can just show the monitor and it wont be flipped. Sorry.

Video 1 of 3 - my friend's SWEp1 computer booting normal:

Video 2 of 3 - my RFM computer booting normal for some reason (doesn't normally do this):

Video 3 of 3 - my RFM computer not providing signal:

#88 3 years ago

j_m_ thanks for the comment. However, just for giggles, I just went outside and tried the computer again and it gave the "No Signal", so it may not be a cold boot issue after all. It's definitely had time to cool down and still didn't boot.

#91 3 years ago

Hey YeOldPinPlayer. I didn't purchase any new memory, and there is only one stick of memory in each computer (two total, one in mine and one in my friend's). In the pic you posted, there is no RAM in the arrowed slot, it may look like there is in the picture, but there isn't. Each computer has one stick placed in the other slot. I've also tried switching only the memory stick from my friend's computer to mine, and that didn't solve the no signal issue. I also did the same with just the processor, and that didn't solve it either. I'll take everything apart and clean it again to see if that helps. I also just went out there to turn it on and see if it booted, and it didn't. It still gave no signal. So I don't believe it's a cold boot issue. I'm wondering if it's something like capacitors that need to bleed out first or something. I've also ordered a PS2 adapter that should be here tomorrow/Wed. and will definitely enter my friend's BIOS and see what his settings are to compare to mine (if I can get into mine). Thanks again for sticking with me and helping.

#92 3 years ago

I just went out and took the computer apart and cleaned/air sprayed the computer and parts. I also changed the motherboard battery out as I figured at this point it couldn't hurt. Then I put only put the Processor, RAM, and video adapter back in (no parallel port, PS2 port, etc.). And tested.

At first it still did no signal. However, then I kept turning off/and back on, until it did something. It finally did on the 3rd or 4th reset, and stayed on the screen in the attached image (the image with CMOS battery failure).

I then took the computer back out and reinstalled all of the other adapters, such as the parallel port, etc. When I tried it again, it at first did the no signal. Then I turned off/ and back on several times until it did something. Again when it did, it stayed on the attached image (CMOS Checksum error - defaults loaded). Then after a little bit, it changed to the screen with lines (also attached).

IMG_7675 (resized).JPG
IMG_7676 (resized).JPG
IMG_7677 (resized).JPG

#94 3 years ago
Quoted from YeOldPinPlayer:

I wonder if the video header or ribbon cable is bad on your computer? Have you been swapping those too?

I have tried swapping the video adapter (card?) and attached cable from my friends computer to mine. I have not messed with the header on the board.

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
€ 159.00
Cabinet - Toppers
FlipperLED
Wanted
Machine - Wanted
Harpers Ferry, WV
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 22.00
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs

You're currently viewing posts by Pinsider maffewl.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside