(Topic ID: 139279)

Revenge from Mars fuse and diverter help needed


By BestShot31

4 years ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 4 years ago by BestShot31
  • No one calls this topic a favorite

You

Linked Games

#1 4 years ago

I have two separate errors or problems with my Revenge from Mars that I cannot figure out.

1. "Fuse F109 is blown T4.0 250v": this seems to happen a lot and despite replacing it with the proper T4amp fast blow fuse many times, it keeps blowing out. It believe it's associated with a flashers near the center of the PF, and I have taken the bulb out. The flasher connector wires look okay, and tracing them out did not detect anything. Any ideas would be appreciated?

2. "Lock diverter remains open": The solenoid test is silent on "38. Lock Diverter Hold"; F106, J112-6. The metal diverter is a single blade version. I read a previous thread which stated that it's either the wrong metal diverter blade or a spring in the coil assembly.

#2 4 years ago

Those fuses are all slow-blow.

#3 4 years ago

Actually, the T4 fuses in RFM are time delayed. Which is what I have in them, not the fast blow as I originally stated.

Promoted items from the Pinside Marketplace
€ 159.00
Cabinet - Toppers
FlipperLED
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 35.00
Boards
PCB Emporium
$ 11.95
Playfield - Toys/Add-ons
ULEKstore
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside