New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 123214)

Restoring a Nine Ball


By aKa

5 years ago



Topic Stats

  • 293 posts
  • 18 Pinsiders participating
  • Latest reply 5 years ago by Classic_Stern
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

There have been 43 images uploaded to this topic. (View topic image gallery).

stn-a382-1.jpg
Big_coil.jpg
Test_switch.png
Coin_door_block.png
Multimeter.jpg
Right flipper assembly.jpg
Left flipper assembly.jpg
fuse_breaker.jpg
Flipper assemblies placement.jpg
Right slingshot switches.jpg
Left slingshot switches.jpg
Flippers assemblies wiring.jpg
Side_rails_pressure.jpg
stn_assembly.jpg
277715-i.jpg
Left_flipper_in_up_position.jpg

There are 293 posts in this topic. You are on page 1 of 6.
#1 5 years ago

Hello Pinsiders,

I just acquired my first pinball, a Nine Ball (Stern, 1980).

It needs some love, and I hope you'll help me give it to her (him, it ?).

For starter, a fuse question : the fuse under the playfield burned. It says 2,5A 250V on the fuse, and under the playfield a sticker says "Warning, use only a 1 1/4 Amp Slo-Blo Fuse". I don't know if it makes any difference, but the pinball works on 220V (like anything else in France). What Fuse should I put in ?

#2 5 years ago

Put the correct one in as the label indicates. if it's on a playfield, it's more than likely a DC voltage, and is coming off the power supply. This should be the same in any location. The only place where a fuse might be a different value is where the power comes into the game, depending what your line voltage and transformer jumpered settings are. I'm going to assume (because I don't have a complete manual handy) that this is for a solenoid (or several). Something caused that fuse to blow. You need to find out what it's connected to it.

#3 5 years ago

It seems to be indeed connected to the solenoids on the playfield, as it is located between the two flippers, but there's too many cables to tell where it's going. I noticed that one of the cables on the left flipper assembly is unsoldered. Could it be the cause of the blowing ?

I guess an image is worth a thousand words ...
Fuse.jpg

I had high hopes I wouldn't have to solder anything. That would be a first for me, even though I know how to do it.

Final word on the fuse values (amps and voltage) ...

#4 5 years ago

You now own a pinball machine - get ready to solder

The wire is hanging off the flipper coil which that fuse doesn't "cover". Replace the fuse and see if it blows. If it does then you have a locked coil somewhere on the playfield.

#5 5 years ago

I would measure resistance across the coil lugs on all coils first (except flippers as Noah stated). Be sure to measure the coil for each drop target on the big bank of targets too. They should all read at least 10 ohms, anything less is a bad coil.

Once that checks out, put in the fuse and power up. If you hear any coils energize immediately, then turn the game off and start checking for shorted transistors on the solenoid driver board.

Interesting that it has a Gottlieb flipper mech on it. You may want to buy the original style from Pinball Life.

#6 5 years ago

I was wrong about the flipper coil wire - looks like it's hanging off the EOS switch.

Definitely get a Stern flipper setup in there if you can spring for it - http://www.pinballlife.com/index.php?p=product&id=2411

#7 5 years ago

I wasn't feeling like soldering, but I feel even less about changing the flipper assembly. I'll probably do it at a later time, but given I'm quite a novice regarding pinball surgery, I won't break things that work for now.

Don't worry, I have plenty of other issues I'll share with you over the next days and weeks. I'll just take my sweet time, won't sweat and tackle one thing at a time.

Thanks you all for your advices, keep them coming !

#8 5 years ago

So, I checked the resistance of all the coils under the playfield (except the flippers ones, I don't know exactly how), including those inside the big drop targets bank (they were a bit of a pain to get to) and they all check out fine.

Before I put a new fuse in, I found a couple of things for you experts to give an opinion about :

- a loose wire on one of the leaf switch on the big drop targets bank. Could it make the fuse blow ? I don't think so but what do I know ?

- a couple of leaf switches with things cut or removed :

This is the switch of the passive bumper with a round thingy partialy cut
Leaf Switch 1.jpg

This is the switch of the upper mini-orbit gate with something that has been removed (possibly the same round thingy)
Leaf Switch 2.jpg

#9 5 years ago

The round discs are capacitors, designed to make a fast switch closure last longer so the MPU sees it. You'll want to replace them. Without them the ball may hit targets or bumpers and never register the points.

As far as the loose wire is concerned, if it was near a coil it could be your problem, otherwise probably not.

#10 5 years ago

I guess they are not essential for now, but I'll keep that in mind. Funny that they were deliberately cut ...

#11 5 years ago

when those caps go bad, they can short ON causing a stuck switch, which can create all sorts of problems. In the mind of an op . . . "cut cap - problem solved! The switch still registers sometimes!"

#12 5 years ago
Quoted from aKa:

I guess they are not essential for now, but I'll keep that in mind. Funny that they were deliberately cut ...

They were cut for an "instant fix", but should have been replaced as soon as possible.

Just like if your car is low on radiator coolant, you will put in water to get the car back on the road; but as soon as possible, you replace the water with proper fluid.

Without the caps properly installed, your switch will not register every time the ball hits it.

#13 5 years ago

Can I find these capacitors in any hardware store, or do they have weird old ss pinball values ?

I guess I have to desolder the other wire that is on the same lug and make a clean new soldering. It may seem like nothing, but have some apprehension before doing such a task. As Noah said, these are skills I will have to master now that I own a pinball. Damn hobby !

#14 5 years ago

On another subject, I put the new fuse in (a quarter amp, slow blow), started the machine, and it didn't blow, but I still can't start a new game. I still haven't fixed the two loose wires, but I understand they should not prevent the game from starting or blow the fuse. How long does a fuse takes to blow if it has to ?

The machine goes through it's usual routine, makes the right number of bips, and goes to attract mode.
No weird numbers on the displays, but a knocking sound each time before attract mode, somewhere in the rear half of the playfield.

A button has been added in front of the machine, left of the coin door (not on the coin door itself), but once again too many wires swirling all around to tell where it's going. It's clearly a later addition. I haven't seen this button on pictures of other Nine Balls. The previous owner told me it's what he used to start a game. In fact I wonder how a game is started on other Nine Balls.

#15 5 years ago

That's for credits. Added for home use. When you push that "added" button do you get credits? If not can you drop a coin through to get credits or manually move the wire that a coin would fall over to get credits?

#16 5 years ago

The issue I have is that the credits are already maxed (40), and since I can't start a new game, it won't go down. Can I flush those credits ? The credit button (the one ON the coin door, not the added one on the wood left of the door that I talked about) does nothing.

#17 5 years ago

You can't add more once you hit 40 but it should start a game and go to 39. The one on the left is the "start button" and should start a game.

#18 5 years ago

Friend of mine had an issue recently where the wire at the inside hinge of the coin door broke off, and no buttons in the door were working. Can't start a game, can't add credits. If pressing the start button does nothing then maybe shoot a picture of inside the coin door.

#19 5 years ago

Unfortunately it won't start a game, and I don't see any loose wire. I'll take some pictures (and stop editing my posts all the time).

I know it won't change anything for me, but where is the start button located on other Nine Balls ? I can't see it on any pictures.

#20 5 years ago

I can't seem to make any telling pictures, but the wiring behind the door seems fine.

The self test button doesn't seem to do anything either, which would go with the assumption that no button on the door work. Oh how I'd love to reset those credits to try to add new ones with the mechanism behind the coin chute !

#21 5 years ago
Quoted from aKa:

where is the start button located on other Nine Balls

The start button is the white one in the coin door above the key in this picture:
http://ipdb.org/showpic.pl?id=1678&picno=31379&zoom=1

#22 5 years ago

Oh, the "credit button" then. I guess the orange button on mine is a "add a credit + start a game all in one button" then. Neither of them seem to do anything. Where's the "flush all the credits down the toilets" button ?

An orgy of buttons.jpg

#23 5 years ago

Orgy? Hmm. Okay the button the left is not stock. That was added to give credits without coins. The white one "should" start a game. I don't think there is a reason to flush credits. If you are saying you can't start a game using the white button, maybe check and see if one of the slam/tilt switches is closed. I see you don't have legs on there, maybe the tilt plumb or ball tilt are activated or even the slam tilt in the door???

#24 5 years ago

Yeah, I guess two buttons (let's not count the rusty rod) is a bit short for an orgy.

I already though about the tilt and checked the 3 tilt mechanisms. They are not in tilt position.

#25 5 years ago

What's the history on this thing? Was it working when you bought it or was it dead when you bought it? Is it possible you didn't get a connector plugged into the boards when you brought it home and put the head back on?

Can you take a pic inside the head behind the glass?

#26 5 years ago
Quoted from aKa:

Oh, the "credit button" then. I guess the orange button on mine is a "add a credit + start a game all in one button" then. Neither of them seem to do anything. Where's the "flush all the credits down the toilets" button ?

There should be two buttons inside the door. One is the self-test button and the other clears memory registers. You can clear scores, credits, total plays and other audits with the second button. The caveat is you need to be in self-test mode to do it.

Next question is, are all the balls in the game? I'm not sure it will even try to start a game if they aren't. But it sounds like you have bigger issues if the self-test button isn't working.

#27 5 years ago

My Galaxy starts without balls, so I am assuming this will as well, but it would be good to see if you can get into the test modes. If not my guess is the wiring harness for the coin door isn't connected to the MPU.

#28 5 years ago

Galaxy is single ball, Nine Ball is multi. I seem to remember having troubles with my Nine Ball not seeing all balls in the trough the first time I set it up.

#29 5 years ago

Well, I did forget to put the balls back in since I was in the process of stripping the playfield.
Put them back in, no change.

This machine as been really neglected by the previous owner. He was trying to sell it for quite some time, and it worked when he posted the ad. Obviously, he had not played it since then and it didn't work when I bought it (well it almost works to be honest )

There's one ribbon cable that links the sound card to the other card (the one on the back, upper left) that has a few pins loose, but I put it back on the boards and it seems to works (I think it only carries the sound). It's the one on the left on the sound card (the one on the left side of the box, if I'm not mistaken).

Some pics :

Backbox 1.jpg
Backbox 2.jpg
Backbox 3.jpg

#30 5 years ago

Well, sorry, there's just no other way. You're going to have to fly me out to take a look

Seriously, though, thanks for the pics. In Backbox2 can you lift up the two gray ribbon cables and show that connector? Just want to make sure it's plugged in and looking good.

Also can you snap a pic of the coin door open? Want to look for anything oddball about the wiring.

So did you try to press the test switches while it's in attract mode to see what happens?

#31 5 years ago
Quoted from aKa:

Can I find these capacitors in any hardware store, or do they have weird old ss pinball values ?

Super common electronic part

.047uf 50v

#32 5 years ago

Curbfeeler, no need to bring you here when I can ask the local operator who cut the capacitors or the one who put the gottlieb flippers to have a look ...

The test switch while in attract mode does the same thing it does when the power cord is unplugged, which is nothing.

Some more pics for your viewing pleasure guys and girls :

Inside the beast 1.jpg
Inside the beast 2.jpg
Inside the beast 3.jpg
Inside the beast 4.jpg
Inside the beast 5.jpg

Yes I know it's dirty and rusty. Shame on the previous owner !

#33 5 years ago

Okay, a few things to check. That credits switch that they "added" make sure the two black wires aren't accidentally touching all the time. Same with the blades. That switch should be open until you press it. Can't tell in the pic, but the soldered ends look very close together.

Next, the tilt plumb looks like it's "made" to me. Wrap a paper towel or something so it can't touch the sides for now, just in case (or just remove the plumb bob). the Rolling ball tilt looks fine, but the slam switch, I can't recall if that should be normally open or normally closed. Try starting a game both ways.

Is there a slam switch in the door? Try the same, both ways. A slam switch under the playfield? Etc. Make sure balls are in when you try these, but a game should start up...

Were you able to try the test/diagnostics button yet to see if there's any luck with that?

Sorry I don't have the schematics in front of me to see if the tilts are NO or NC.

#34 5 years ago

The black wires don't touch themselves, the blades are close but they do not touch themselves. I disconnected the button to make sure it wasn't the cause of the mystery. No change.

I removed the tilt bob, but it wasn't touching anyway. No change.

I tried the slam switches open and close. Isn't one enough Stern ? No change. I didn't find a third one under the playfield, thank God !

The test button is still sulking in his corner.

#35 5 years ago

Check the square molex connectors in the head (like the one on the left wall just inside the coin door) and make sure they are all connected and the wire colors match. Some of these are the same size which allows the wires to be cross connected.

#36 5 years ago

Well I'll be damned ! There was a connector unplugged in the head. You can see it (a bit) hanging on "Backbox 3" picture. The game now starts.

That's all folks for tonight (it's getting late here in France). Thank you all for your help and let's do it again tomorrow for another bunch of issues !

#37 5 years ago

A question about rubbers :

The manual indicates 1,75 ; 2,25 and 2,75 inches rubbers but it seems those sizes are not commonly available nowadays (didn't find it anywhere). Should I go for tighter or looser ones ?

#38 5 years ago
Quoted from aKa:

Curbfeeler, no need to bring you here when I can ask the local operator who cut the capacitors or the one who put the gottlieb flippers to have a look ...
The test switch while in attract mode does the same thing it does when the power cord is unplugged, which is nothing.
Some more pics for your viewing pleasure guys and girls :
Inside the beast 1.jpg (Click image to enlarge)
Inside the beast 2.jpg (Click image to enlarge)
Inside the beast 3.jpg (Click image to enlarge)
Inside the beast 4.jpg (Click image to enlarge)
Inside the beast 5.jpg (Click image to enlarge)
Yes I know it's dirty and rusty. Shame on the previous owner !

That is a cute hack to use a single 2764 eprom.

#39 5 years ago
Quoted from barakandl:

That is a cute hack to use a single 2764 eprom.

If only I knew what you're talking about ...
Well, if the hack works and poses no problem, I can continue to blissfully ignore it.

#40 5 years ago

The diag button ground return is on the driver board. The input side is on cabinet switch plug on the mpu.

Check that the ground return side of the diag button is actually at ground and not floating. Can try grounding the input pin right at the MPU and see if it enters test mode.

Andrew

#41 5 years ago

Barakandl, what I was trying to tell you is that what you are saying is gibberish to me.

I'm pretty ignorant on the electronics side of pinball or any other devices in general. I can plug things, and have already built computers because, well, it's basically just plugging things.

Unless you post pretty pictures with arrows on it, I'll never get what you're talking about.

#42 5 years ago

take an alligator clip. Clip it on any grounded metal. Coin door, lock bar, whatever. The other side touch both solder lugs of the diag button and see if it goes into audit / test mode.

Basically i am getting at the connector plugs on the circuit boards may have a bad connection.

#43 5 years ago

I have no problem going into test mode, whether it is by pressing the test mode button or by making a connection between the two lugs. Is it what you're getting at ?

Speaking of things being grounded, I noticed the mpu is not screwed to the back of the box. In my post #29, Backbox 2 picture, you can see there are no screws in the top right and lower left of the board. Is it normal ? Can it be troublesome ? There's a big warning in that box about boards needing to be grounded for "proper game operation".

#44 5 years ago

There was some confusion earlier. He could not get to test mode b/c the coir door connector in the head wasnt connected. He can start a game now and has other less severe issues here and there.

Op, that metal braided cable from the playfield and cabinet and head all need to meet and be screwed tight in the bottom of the inside of the head. This grounds the three to each other -- cab,head,playfield.

You are correct those machine screws should be replaced in the boards but for the time being one screw is doing the job.

#45 5 years ago

Oh also op, next time you buy one better to wait on tearing down the playfild until you verify everything electronic works 100%. Saves many hours of diagnosics later if there is an issue.

#46 5 years ago

Oh yeah I understand about the braided metal cable. It just seems to me that the mpu board is only held in place by plastic pegs. I can't see any metal screw or any metallic contact between the board and the back.

I did strip the playfield, but left everything that was connected so that I could keep testing the table.

#47 5 years ago

I'll keep posting my questions and hope the previous one (the grounded mpu thing) will get some feedback.

After browsing the forums, it seems I should go for smaller rubbers if the original size is not available. File closed.

Now, about the loop drop target. Mine is not the original one and maybe some Nine Ball owners can chime in. It does a loud clanking sound when dropping and the under playfield mechanism seems odd :

Loop target Topside.jpg

This one is a bit blurry but I'm sure you can see the bent bracket.
Loop Target Underside.jpg

The bottom of the target's support hits the bracket loudly. I'm pretty sure it shouldn't do that.

#48 5 years ago

Nine Ball needs all three balls to be loaded for a game to start. FYI...

Mac

#49 5 years ago

A bit late to the party, Mac.
Yeah I know, others speculated about, and I can confirm it loud and clear. Thanks mate.

Maybe you have an opinion on the metal-screwless board ? I think I'll just had those screws and be done with it ...

A forum-related question for you guys : Should I start another thread in the restoration sub-forum for all the non-guts (of the machine) related questions ?

#50 5 years ago

MPU has its own ground connection on J4, but its good to get a solid ground by screwing It down.

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 22.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 12.00
Electronics
Third Coast Pinball
From: $ 10.00
From: $ 25.00
Boards
nvram.weebly.com
There are 293 posts in this topic. You are on page 1 of 6.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside