(Topic ID: 200835)

rescue 911 bad smell, now no lights or flippers


By Brimacs

2 years ago



Topic Stats

  • 9 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by V_piscopo
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

Aaargh, feel like smashing this machine. first helicopter motor rewind, fault finding as a column of switches had intermittent fault. Fixed that and game was amazing. Got my highest score and the very next game there was a bad electric smell and turned of machine. had a look everywhere and could not see anything burned. looked at all boards and no smell in there, all looked good. Started game, no sound, no flashing lights( just a few solid lights like under bumpers etc working and no flippers. I cannot go into test mode with flippers not working. I pulled all fuses and they look fine. Please help

#2 2 years ago

Sounds like GI lights are ok.

Did you remove any boards?

Did you disconnect any wire connectors?

Bump for you. Good luck.

#3 2 years ago

Just because fuses look good does not mean they are. Test each fuse with DMM. Check to see if there is a fuse under your playfield near your flippers as well. Also reseat all your connectors and while they are unplugged make sure none of them are burnt. Lastly double check the last area you were working in to make sure you didn't ground a light or switch.

#4 2 years ago

Hi Thanks for the advice. I did check all fuses with a DMM. They all tested fine. I disconnected all plugs from board and switches. Top right flipper felt a bit tight to move. I gave it a good workout by hand and now it moves easy. when I restarted the game it came up with coin return. pulled all plugs I could find in the door area and restarted game. It all seems to work ATM. Must have been a loose plug somewhere or maybe the top right flipper coil. I really appreciate the advice. Thank you

#6 2 years ago

Maybe a partial meltdown of the top right flipper coil. The coil sleeve might have been burned causing the smell. Did the top right flipper lock on at any point?

#7 2 years ago

top right flipper was very slow. Do you think that this is my problem. It seems ok now. Maybe I should change that coil in case. I am sure something would be melted as the smell was bad.
Thanks

#8 2 years ago
Quoted from Brimacs:

top right flipper was very slow. Do you think that this is my problem. It seems ok now. Maybe I should change that coil in case. I am sure something would be melted as the smell was bad.
Thanks

Yes, replace the coil and sleeve. They're very cheap.

#9 2 years ago

Post a pic of the coil. Also post a pic of your coin lockout coils on the backside of your coin door.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
$ 249.00
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 42.00
$ 58.00
Playfield - Toys/Add-ons
Lermods
$ 12.00
Electronics
Yorktown Arcade Supply
$ 209.99
Lighting - Led
PinballBulbs
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
From: $ 175.00
Gameroom - Decorations
Pinball Photos
$ 10.95
$ 36.99
Eproms
Matt's Basement Arcade
$ 29.25
Cabinet - Armor And Blades
The MOD Couple
$ 9.95
$ 18.99
Eproms
Matt's Basement Arcade

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside