New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 179619)

Rebuilding sound for DataEast & WPC using a pi


By steve45

3 years ago



Topic Stats

  • 1,123 posts
  • 72 Pinsiders participating
  • Latest reply 4 days ago by Magiske
  • Topic is favorited by 109 Pinsiders

You

Linked Games

Topic Gallery

There have been 98 images uploaded to this topic. (View topic image gallery).

tiltaudio_pcb (resized).jpg
Screenshot_20200930-201337_Gallery (resized).jpg
20200721_212621 (resized).jpg
Screenshot from 2020-06-27 15-16-49 (resized).png
942D17A9-F104-4176-8B0D-D968E1BFBD4B (resized).jpeg
photo_8301142032747779218 (resized).jpg
ta-2.5f-fix (resized).png
ta-2.5e-fix (resized).png
ta-2.5e-fix.geaendert (resized).png
ta-2.5f-fix.geaendert (resized).png
ta-2.5-layout-error.geaendert (resized).png
e (resized).jpg
f (resized).jpg
15653680252735480358201579305895 (resized).jpg
15653679958703417177809815257059 (resized).jpg
Tilt audio assembled (resized).jpg

You're currently viewing posts by Pinsider BENETNATH.
Click here to go back to viewing the entire thread.

#44 2 years ago

Hi,
Some question :

- Any luck for stern, as they basically are updated DE ? My LOTR would be happy!
- Pi zero or Pi3, any difference at the end ?
- Booting time wise, what's the best setup and Linux distrib ? What is the current timing to have sound on cold boot ?
- did you explain somewhere the relay for a shaker ? I would like to have my tommy linked not only to propellers, but also to some sounds.
- Would it be possible to add 3 channels for additional toy triggering, like the shaker? That we could call based on sound ? A chimebox in the tommy would be easy that way.

Thanks

#49 2 years ago

Thanks, i'll follow the dev progression

1 month later
#59 2 years ago

Hi, there is a sound bank for LAH : https://www.pinsound.org/fr/pinballs/data-east-r3/last-action-hero/
So you can purchase a full kit and use one of these sound pack

#60 2 years ago

Any news on whitestar support ??

#68 2 years ago

Ok so basically, if i buy the whitestar adapter for pinsound and your board, it should be ok.
Would you think of a discount on your board as a betatester ?

6 months later
#250 2 years ago

Hello,

i agree that this project is great,
and i agree that documentation is really not great at the moment

So, i've bought a 1.9b version of the kit. would anyone be so kind to upload a photo of how the board is supposed to fit with the raspberry??

In addition, how do you connect the WPC-DCS to the shield, the ribbon on my indiana jones WMS is larger than the connector on the shield, is it supposed to be the case?

thanks

#252 2 years ago

I've the WPC version 1.9, no DE connector.
EDIT : ok nevermind, was a bit tired yesterday

So i managed to get IJ working, but a lot of sample are played when quick things are happening, like bumpers and so on.

Is there anyone using a Raspisound with indiana jones and the endprodukte sound pack??
Just to confirm that it works without a gltich ?

Thanks

#256 2 years ago

I fully agree and i am at the same stage.
It's currently a nice POC but it can't replace the sound board at the moment ..
That's sad, as i would love to have it fully working and add a shaker to IJ
The missing sounds, music loops or long silence are killing the experience. But when it works, it's great !!

Steve, how can we help ? Is there something we can do to reach a 100% working level ?

#258 2 years ago

Hi, you mean the sd card, right?
I shared with Steve that i thought it might be the bottleneck, and i purchased a new one, can you give me the ref you are using ?

thanks

#266 2 years ago

A wrong descramble file is also a possibility, i dunno how they are produced

#272 2 years ago

Going on holidays but i'll give a try
I just received the pinsound whitestar support
Just give me your instructions
I have a 1.5 DE shield, so that would be great !

#290 2 years ago

That' s great, so we will be able to have a 'confirmed working' sound set with visua pinball. But how do we generate the raspisound config file?

#291 2 years ago

Steve, can you describe the relay part?

#303 1 year ago

Thanks, i'll give a try !
Steve, how can we switch from one sound set to the other, if i want to try multiple ones ?
will you generate descramble for all sound set, is it possible to generate it automatically ?

thanks

#311 1 year ago
Quoted from steve45:

Sorry didn't get it? Do you mean how to generate the mapping in general? If yes I tried to explain it at least once this thread, just read through to older posts.

nope, sorry, i screwed the quote, i was speaking about the relay for the shaker.
I've shown a picture but a detailed explanation would be great for the wiring and stuff.

I've flashed the 1.14 again, you are speaking about a 1.15 update but did not find it.

I want to test on LOTR whitestar, so i'll wait for your instructions

#331 1 year ago

Does last update.zip work with 1.14 or shall I burn a 1.17rc then update?

#336 1 year ago

So, I had some time today.
I had a 1.5 shield and a pi2 to give a try on my LOTR.
I've used the last 1.17 img and the LOTR OST sound pack.
I've plugged the pinsound whitestar adapter plugged onto the CPU.

And bingo! It worked really well. At least during the trial period.
Sadly, I had nothing more once I've pasted my pi2 licence(purchased by mistake)

I have no pi3 to give a try. I can confirm that it was working mostly well, as I had sound from the pinball and the pi2

#340 1 year ago
Quoted from steve45:

You need one of these "arduino relay boards" & one pwm dc motor speed controller. And of course some 12V power supply that actually can stand the shaker motor. But if you turn speed down it doesn't draw that much current.

Thanks ! I'll do a feedback once i get it working

#343 1 year ago

Which software are you using to burn?
2 Kingston SD failed for flashing due to missing sectors while SanDisk SD worked well

#347 1 year ago

i'm using win32 too,was just looking for a reason why it would be so difficult for fly ...strange

#368 1 year ago

Hello, i finally managed to get it working by.. switching the shield to another one.
Steve sent me a Data East 1.5 and 1.3 shield. I had 1.5 shield working once but never again.
I decided to give a try today with the 1.3 shield and here is the result :

Videos : https://photos.app.goo.gl/xXPRYjXLR9GjMDSp8

log file : https://www.dropbox.com/sh/plzn6urncor2ocw/AACendNcjj3nw877x89NtAeba?dl=0

It's still not perfect, i have to play with the music reduction, as SFX are really low compared to music. and some sounds are missing in the log file

#370 1 year ago

no, never

#375 1 year ago
Quoted from steve45:

This can be configured by giving sfx an individual gain. Or by using "ducking" which reduces volume of music while sfx is playing

Yes, I've done that and it's better. Still some issue but might be related to pi2 being underpowered.

Steve, the log shows missing files, how to handle that??

#378 1 year ago

I'm speaking about all 'missing' mentions through the log

Eg :

2018-10-24 22:06:29.702 ERROR [handleSoundByType] [sdl_sound.c:883] sample for id '54484' not found

#386 1 year ago
Quoted from steve45:

54484 or in Hex 0xD4D4 isn't a sound command for data east. Data East early generation use single byte commands or 2 byte commands of the form 0x7Dxx.
Later generation (also Whitestar) use 2 byte commands like 0xFDxx or 0xFExx. But 0xD4D4 doesn't match either or, so I guess there's another problem

Look at the log, a lot of errors of this kind with different codes. I don't know how to help you.

#389 1 year ago

Steve, i've added in the dropbox folder a log from my IJ, running v1.14 on a WPC 1.9 board

Look at the log, there are also a lot of ERRORS:

- missing sound:
2018-08-14 20:15:56.387 ERROR [scan] [sound_util.c:281] Found sound directory, but no sound file: /boot/data/sound/1/sfx/2110891867-fanfare_end_of_ball_1

- same issue as LOTR :
2018-08-14 20:16:18.700 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '19789' not found
2018-08-14 20:16:18.791 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '39064' not found
Line 8671: 2018-08-14 20:34:36.387 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '333' not found
Line 8680: 2018-08-14 20:34:38.596 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '93' not found
Line 8714: 2018-08-14 20:34:40.740 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '193' not found
Line 8724: 2018-08-14 20:34:43.474 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '93' not found
Line 8729: 2018-08-14 20:34:43.539 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '275' not found
Line 8744: 2018-08-14 20:34:47.952 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '93' not found
Line 8771: 2018-08-14 20:34:55.049 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '93' not found
Line 8785: 2018-08-14 20:34:59.876 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '278' not found
Line 8810: 2018-08-14 20:35:01.851 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '95' not found
Line 8825: 2018-08-14 20:35:03.415 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '95' not found
Line 8845: 2018-08-14 20:35:07.939 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '324' not found
Line 8945: 2018-08-14 20:35:18.312 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '93' not found
Line 9043: 2018-08-14 20:35:35.347 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '325' not found
Line 9068: 2018-08-14 20:35:42.349 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '276' not found
Line 9088: 2018-08-14 20:35:45.123 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '273' not found
Line 9106: 2018-08-14 20:35:49.622 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '278' not found
Line 9131: 2018-08-14 20:35:51.605 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '95' not found
Line 9146: 2018-08-14 20:35:53.114 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '95' not found
Line 9166: 2018-08-14 20:35:57.706 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '340' not found
Line 9170: 2018-08-14 20:35:57.708 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '513' not found
Line 9180: 2018-08-14 20:35:58.559 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '514' not found
Line 9185: 2018-08-14 20:35:58.894 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '512' not found
Line 9190: 2018-08-14 20:36:00.535 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '324' not found
Line 9267: 2018-08-14 20:36:11.948 ERROR [handleSoundByType] [sdl_sound.c:842] sample for id '333' not found

and plenty of others.

so the issue seems to be existing in WPC running 1.14 and Whitestar running 1.17

#396 1 year ago
Quoted from steve45:

So this is how I did the shaker wiring:
[quoted image]
You need one of these "arduino relay boards" & one pwm dc motor speed controller. And of course some 12V power supply that actually can stand the shaker motor. But if you turn speed down it doesn't draw that much current.

Steve, are 1.3 and 1.9 boards able to activate a shaker?
I have only 3 pins : TX, RX and the middle one
Sorry for my noobitude but the picture is not that clear

#400 1 year ago
Quoted from steve45:

Yes they are, the fourth is just to have +5V additionally for convenience. Shaker up to 1.17 is always controlled via TX. This will maybe configurable in the future.

Steve45 : can you confirm this wiring ? I have a 5V relay board for arduino, a 12V shaker and a 5V DC power unit. The shaker is well driven by the power unit so i would give a try. I am not familiar with these boards.

shaker (resized).jpg

We would really need a place to set up a documentation, would you open a wiki on the pinball-mods page or something like that ? A lot of people are interested but we are relying a lot on your replies. Keep it up !!

#409 1 year ago

Hello Guys,

i took some time today to put this relay board and the raspinsound together.
The result is in video in the folder : https://photos.app.goo.gl/xXPRYjXLR9GjMDSp8 (5min38 video, my blanket survived !)

For non-video people, the bottom line is that it works perfectly.
I had to put the invert function of the shaker, and connect it to the NC plot, to avoid shaker activation during the pi booting.
i pasted a shaker.txt file in the sfx subfolder activated when launching the ball, and it worked every time the sfx got played.

That's really great !

shaker (resized).jpg

Beware of the wiring, that's feasible like this only because i'm using a 5V power unit

Now, i need to add a LOT of shaking effects

But we need also to have some improvement on reliability of the sound played, especially for background music.
On Ball 1, i never have background music
No attract music too, just sounds when pushing buttons.

So that's nearly good but not perfect !

#411 1 year ago
#413 1 year ago

OK, I will give a try.
Any idea about issues in background music?

#416 1 year ago

What's your config file?
Do you hear the version number?
How do you output sound?

#418 1 year ago

Are you able to connect via ssh on ethernet?
I can't login with pi/pi or root/root

Do you have the pinsound Whitestar adapter blinking when sounds are playing?

#420 1 year ago

You can play sound through console.
Pinsound adapter working.
So either a bad ribbon, a bad connection (try to invert cable) or bad raspinsound board..

#424 1 year ago

steve45 : Steve, is there a cache folder ? When i'm changing from LORD OST to thewool ; it's the same descramble file, but it seems that doesn't change anything..
And there is still a big issue with music loops in background, either not starting or not ending..

#427 1 year ago
Quoted from steve45:

No there is no caching. You should of course restart when changing files.
And I cannot help if you not at least provide some logfile or something. I cannot simply guess what's going wrong based your description

I totally get that Steve.
What would be your need ? log verbose at 4 and running some games ?
In the video linked for shaker demo (https://photos.app.goo.gl/ecqccxpFGBjCLDNT6) you can see that background music never starts on ball 1.

I've ordered a Pi3B to replace Pi2, and i will do a test and send you logfiles. Raspberry Pi 2 might just be too slow to handle everything.

#430 1 year ago

steve45 : Steve, can you check about the difference between 1.14 and 1.17 related to background music ? it seems that multiple users get the same feeling.
I'm getting my two new Pi3 soon and i'll do a proper test on whitestar.

Quick poll :
- how many did tests on whitestar with 1.17 ?
- how many did test WPC with 1.17 and getting issues on music which were not present in 1.14
- how many have a working setup on WPC or Data east ?

1 week later
#432 1 year ago

Hello,

i finally had some time to give a try.
I have a Pi 3 model B, i have 2 soundset folder.
Initially, folder "1" was containing thewool mix ; i renamed it as "2"
I then downloaded the "lord_of_the_rings_original" soundset and put it in a folder "1" as i wanted to get the original sounds to compare. I added the raspinsound config to this folder.
I cleared the log file and here is the result:
https://drive.google.com/drive/folders/15zvU-iqDkVZI-azTAPpfo01kqPTJfcHY?usp=sharing

There is a video (sorry for the sms notifications ) and the logfile.

First weird thing, you will see that the soundset used is the folder "2"

Secondly, the sounds are mostly ok from what i eared

Main issue is the music not initializing at the first ball. I don't know why but it's consistent. Works well for ball 2 and 3 but never on ball 1

steve45 : what do you need in addition ?

#434 1 year ago

So basically, it seems errors are mostly on start/stop of musics. but sfx and other are ok, right ?

1 week later
#437 1 year ago

Hi steve45, I bet that you are really busy but could we know if you are still working on this project and how we can help you?

#439 1 year ago

Thanks Lucky, I'm not complaining or anything, that's really to know how things are going.
I have 3 pin2DMD to build at the moment, so using my spare time is no concern.
By the way, keep it up with your projects, that's a pleasure to see such things evolving well

3 weeks later
#441 1 year ago

Hi, I did not get the latest replies on the German board. What's the status??

1 week later
#444 1 year ago

Great!
Will test on Whitestar too!

#446 1 year ago

my two cards are not working (for indiana jones WMS et LOTR whitestar)
update.zip is now update-done.zip

log says :
"2018-11-05 20:17:15.785 INFO [main] [despi.c:565] RasPinSound starting, version 1.17, serial: xxxx
2018-11-05 20:17:15.786 INFO [main] [despi.c:570] loading settings from .pisound2
2018-11-05 20:17:15.806 ERROR [main] [despi.c:573] license verify error"

removing key file doesn't solve the issue, no trial mode.
I don't have the .pisound2 file ..

#450 1 year ago

I had also some issue with one SD card. Steve, you can indeed shrink it a bit?

#453 1 year ago

We will be there for feedback

#457 1 year ago

Hi,

did a quick test on 1.19 with :
WPC-DCS : indiana jones WMS : here is the log and video
log : https://drive.google.com/open?id=15v9DOWgp4yhD88syBI7lapMX25RoWENY
video: https://photos.app.goo.gl/Y78ip3QgcWbTRheY6

my feedback is that it's really better. all musics seems ok now.
There is still a feeling of an issue with gfx. either not playing, not stopping well or a mess when too much sounds are played closely. like when multiple bumpers are hit in a second.

That's really getting better !!

i've test on LOTR whitestar, no change. still no music at first ball.

#467 1 year ago
Quoted from lucky1:

The video is showing a LOTR and not a Indi. Logfile of the LOTR with the current version would be interesting I think.

Sorry, here is the 1.19 video of ij

https://photos.app.goo.gl/UJsRoVGNqkFo2NAS8

#468 1 year ago
Quoted from lucky1:

The video is showing a LOTR and not a Indi. Logfile of the LOTR with the current version would be interesting I think.

sorry. Video of LOTR is from 1.17 but it's mostly the same as 1.19.
I've added to the same folder the log for 1.19 LOTR

#476 1 year ago

I have no time for testing atm, but i agree that GFX ending is still not working as it should. I had on 1.19 on IJ a lot of gfx not ending properly. like the ending sound still playing during the lottery.

#484 1 year ago

I'm interested by this debug too!
No time to test now but reading!

#487 1 year ago

Argh, me wants to test..

#492 1 year ago
Quoted from Phantasize:

What’s keeping you from doing it then?

Spare time at the moment. And this weekend.. has no end...
I'll try to give a try and update to 1.22

#495 1 year ago

some feedback of latest build : raspisound-update-v1.23-144862146.zip
1) IJ WMS DCS : no sound is played after the preloading announce. i've got the version 1.23 mentioned, the preloading, then nothing more

2) LOTR Whitestar : same things.

i've put logs in the drive : https://drive.google.com/drive/folders/15zvU-iqDkVZI-azTAPpfo01kqPTJfcHY?usp=sharing

EDIT : i'll give a try to 1.22 official now

#496 1 year ago

1.22 officiel tested
I've got sounds !
On IJ WP-DCS : it's really nice, except that sound are still overlapping when bumpers are triggered.
Shall i put on true the "suppress_repeated" option ?

On whitestar, i don't see any difference, as the main bug is still there. No music at ball 1 and no music restart when starting a new game (attract music is still played)

logs are in the same folder as 1.23
https://drive.google.com/drive/folders/15zvU-iqDkVZI-azTAPpfo01kqPTJfcHY?usp=sharing

#499 1 year ago

Yes, I'm also confident.
Keep it up!!

#504 1 year ago

I confirm that 1.23 from mega provides sounds again.

logfiles are in my shared folder :
https://drive.google.com/open?id=1gMj5IDo_ZZRInH1y8xPPWhk3qEmvN0di

I would say that it's nearly perfect on my IJ, but there is still one annoying glitch ; when multiple hits are done on bumpers, a lot of sounds are played and cutting the previous one
What's your advice Steve , shall i put a suppress_repeated = 1 in the ini ?

EDIT : i got some spare time to give a try with suppress_repeated. did not change anything.
Video here : https://photos.app.goo.gl/T4bozV1YudjmWiV89
log added in the same drive folder above

#507 1 year ago

Nice idea Steve,
How do we set up the wifi?

#508 1 year ago

steve45 Steve, can you double check the way the descrambling is done. Indeed, when you compare the sounds played at bumper hit, and the endprodukte video, that's not the same.
Endprodukte :

#512 1 year ago

Thanks you 2
If I update from 1.12 I'm not on dietpi, so both are right
I'd prefer to put wifi ssid and key directly in a config file, to avoid wiring but that's ok

#516 1 year ago

It's an ongoing effort but I lack time as usual.
I'll give a try anyway..

#518 1 year ago

OK, I won't have any time to do this trial

1 week later
#523 1 year ago

thanks steve, any technical improvement or just the Webui (with reducing the interest of this part). Shall we expect changes in sound/music handling in some vendor ?

#532 1 year ago

i have an error writing to actual 1.24 full image, anyone else?
will redownload and try again..
agree that shrinking the img a bit would help as i only have one 16GB sd handling it, my other 16GB seem too small ? (windisk32 imager)

#534 1 year ago

Ré-downloading fixed my burning issue.
I've got all files, put my wifi and put the SD card back in my pi3. Sadly, nothing happens.
No device on my lan
No sound coming out from the pi.

Will try to debug

#535 1 year ago

ok, plugging on my ethernet helped to get an access.
I've also found the ssh credentials, which are not written anywhere..
for your sake : pi / raspberry

then you can do :

sudo systemctl enable pinsound

it will fix the autoboot issue and you should be able to move forward !

port for the webUI : 31008

EDIT : i had to plug my ethernet, and run by ssh the dietpi-config to enable the wifi

#537 1 year ago

Great reactivity steve!

#539 1 year ago

Phantasize, did you try to plug the pi to your lan by ethernet and check your router if you see a dietpi device

#541 1 year ago

Did you config dietpi and dietpi-wifi in boot partition?

#543 1 year ago

OK, if you don't see partitions, then it won't work for sure..
Shrinking the larger img should be feasible ut I have no time to do so..

#547 1 year ago

And the best option is that you can now switch soundset live, directly from the webui.

So cool!!!

#549 1 year ago

Steve45
I know it may sound less fun, but accuracy of the sound playing seem (at least to me) the first goal to reach.
For 5.1, I don't know but at least a good 2.1 with the bass separated might be great

#553 1 year ago
Quoted from steve45:

Of course I will first look into the mapping problems of Benetnath IJ

About IJ, it might be too late, there is a german guy coming tomorrow. IJ might leave to another home !
But don't worry, there is also the whitestar support for LOTR which is nearly good, and requires your magic

1 week later
#578 1 year ago

Big changes are coming ..

#582 1 year ago

Yes, Steve is just handling some troubles with other creators
Thanks to compatriots

2 weeks later
#600 1 year ago

so sorry about that..

#611 1 year ago

Pinsound (French product) Versus Raspinsound (steve's one)

2 weeks later
#618 1 year ago

it works with old board.

great work Steve and welcome tilt audio !!

#629 1 year ago

quite easy in fact.
- download the IMG file
- use a card flashing tool ( I'm using etcher or win32disk imager) to burn the IMG on a 16/32 GB microsd. some card appear too small, so go for a 32 if you can to avoid this issue
- once flashed, you should have 2 partitions in the file browser. in data, you will have to put the licence key, the sound folder and edit the raspinsound config file. check out go-dmd website for this part. you also need to add WiFi credential in the dedicated file at the sdcard root (dietpi-wifi if I remember well)
- plug the pi to the pinball with the shield and launch.

the pi should connect to the WiFi and appear in your router interface , you should be able to connect through your internet browser at IP:31008

#635 1 year ago

agree,
just keep in mind, as stated everywhere that this is a dyi project. you need to put some efforts in it, no plug n play

#638 1 year ago

and you will have answers

#656 1 year ago

even with correct config, I had to connect via ssh and launch dietpi-config to enable WiFi.

#670 1 year ago

the webui is really useful as you can change the sound set, change settings, grab log file..

but at the end, if everything works well, no need to use WiFi or the webui.

#675 1 year ago

ssh is a protocol to connect to the pi when it's running
you can install putty that allows to enter the ip on port 22 with pi as login and raspberry as password

it can work through Ethernet or WiFi, you just need to know the IP (maybe on your router interface)

#699 1 year ago

use etcher instead of win32d

#711 1 year ago

create a folder named update at root
place the zip file renamed as update.zip

boot

1 month later
#794 1 year ago

Steve, any progress on white star support ?
Thanks

2 weeks later
#817 1 year ago

Hello,

I've flashed and setup WiFi without issue, using the big image.
But i've got only rootfs partition mounting under windows.
How can I add the data folder ??

#818 1 year ago
Quoted from BENETNATH:

Hello,
I've flashed and setup WiFi without issue, using the big image.
But i've got only rootfs partition mounting under windows.
How can I add the data folder ??

Solved, I've used scp

#820 1 year ago

You can connect to the raspberry using a scp software, like winscp on windows.
It's a way to use the ssh port as a ftp.
Install winscp and create a connection on the IP of the tiltaudio system, on port 22
Username is : pi
Password is : raspberry
You might be stuck with user rights, as boot/data seems not writable for pi user .
I've pushed the data to /media folder and moved it through a terminal ssh connection, using a sudo command.

Seems a bit cryptic for non-linux and not sure if it's the best way..
Maybe dietpi user has ssh access but not sure of the credentials.
Steve, can you comment ??

By the way, I redid a test on my LOTR.
it behaves like old version.
Everything works, except the first music that should start on ball1.
The initialization of the game seems not detected, as the lottery or attract music is still played. On ball2 and 3, it works well.

#822 1 year ago

yep, a sudo su might work too.

the easiest would be that data partition would be mounted on windows system.. or that I use ubuntu on my laptop too

#824 1 year ago

Hi Steve,
I've used the latest big file shared here on a 16GB.
Etcher under win10 64bit was used

i wanted to put my whole data folder with key and config, so i needed a folder upload, not just soundset.

3 weeks later
#832 1 year ago

I did a try on the previous version on lord of the ring and still have on issue : no music on ball 1. Everything out of that is 100% perfect.

Did anyone give a try on another white star ??

#842 1 year ago

Geteos did you try to create an update folder and put the zip in it ?

4 months later
#1002 10 months ago

Steve, any chance to make some progress on whitestar issues?
My LOTR would deserve a better sound, but I dunno how to help about that..

1 week later
#1003 10 months ago

steve45
Steve, I have a 1.3 data east for my LOTR.
I wanted to know how to connect it to the speakers as there are no amplifiers on the board.

Are you still on this project?

#1005 10 months ago

I have the pinsound interface and done a lot of debugging with LOTR yet.
But I've always used the jack and external speakers

#1009 10 months ago

Thanks lucky1

3 weeks later
#1019 9 months ago
Quoted from Rdoyle1978:

This is just a hobby thing - you do have to do a lot of your own research. Part of the deal. If you’re looking for an all-in-one solution, buy the Pinball Thieves Pinsound. $400 and the documentation is better.. but not much

Calling them thieves seems a bit.. rude.
They developed a high quality product with a brand. I'd say that Steve was also playing a bit when calling his product.

Anyway, everybody can do his choice.
Pinsound is a wonderful device, for pinball fans. It's plug and play and HQ.
Tilt audio is a DIY cheap solution, fun to setup but personally, I did not manage to have any working setup, whatever the config (wms, whitestar). I reached each time a "nearly good level" but not sufficient to remove the original sound card.
My 2 cents

#1022 9 months ago
Quoted from Rdoyle1978:

I don’t feel it’s incorrect. Nothing to do with Steve, although I don’t appreciate how they throw their weight around with him.
See here:
https://pinside.com/pinball/forum/topic/pinsound-no-more-reset-and-rob-kahr-s-board?hl=rdoyle1978#post-5347188

Was not aware of that.. this hobby is always creating such drama..

#1026 9 months ago
Quoted from Marv:

What part did you stumble at? I have a fully working one in Frankenstein.

No stumble, the system was not fully behaving as the original sound card.
Like repeated samples, missing ball1 music.. It was nearly good, not perfect

2 weeks later
#1042 8 months ago

amen to this.
a wonderful DIY initiative but one man only can't handle that at 100%. I've spent quite a lot of time on different setups with differents boards and I'd be really happy to have this running on my LOTR..

#1052 8 months ago

For me,
LOTR : no music on game start, at all. music was starting only on ball2, and no event captured on the log
IJ WMS : mixed sounds and sounds repeated all over, and log files didn't help to solve

#1054 8 months ago

LOTR : On all games, not only the first
IJ : Steve and I have worked on the soundset and we failed at finding a solution

#1057 8 months ago

Agree, a good tool and tutorial would be really great.

1 week later
#1060 8 months ago

Agree, the lack of support is one thing understandable, for a diy project
But the selling should be stopped in this case or with warnings of unknown delays

2 months later
#1073 5 months ago

Sadly sounds right..

Promoted items from the Pinside Marketplace
$ 19.99
$ 15.00
$ 96.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 28.00
Lighting - Other
Rock Custom Pinball
$ 5.00
Cabinet - Other
UpKick Pinball
$ 79.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 15.00
Playfield - Toys/Add-ons
G-Money Mods
$ 15.00
$ 10.00
Cabinet - Sound/Speakers
UpKick Pinball
$ 9.90
Playfields
The Super Fasteners
From: $ 9.99
$ 29.95
Playfield - Toys/Add-ons
ULEKstore
$ 109.99
$ 399.99
Cabinet - Toppers
Top-Notch Target Shields
Trade
Machine - For Trade
Massapequa, NY
$ 209.99
$ 24.99
Lighting - Led
Lee's Parts
$ 369.00
Cabinet - Decals
Mircoplayfields
From: $ 149.00
Playfield - Toys/Add-ons
Sparky Pinball
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 9.99
Eproms
Matt's Basement Arcade
$ 69.50
Boards
Pinball Haus
3,195
Machine - For Sale
Rockford, IL
$ 175.00
Lighting - Interactive
Professor Pinball
$ 18.95
$ 25.00
Playfield - Toys/Add-ons
G-Money Mods
6,000 (OBO)
Machine - For Sale
Johnson City, TN
$ 48.00
Cabinet - Other
ModFather Pinball Mods
Wanted
Machine - Wanted
University Place, WA
Hey modders!
Your shop name here

You're currently viewing posts by Pinsider BENETNATH.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside