Rebuilding sound for DataEast & WPC using a pi

(Topic ID: 179619)

Rebuilding sound for DataEast & WPC using a pi


By steve45

1 year ago



Topic Stats

  • 519 posts
  • 35 Pinsiders participating
  • Latest reply 2 days ago by Rdoyle1978
  • Topic is favorited by 78 Pinsiders

You

Linked Games

Topic Gallery

There have been 45 images uploaded to this topic. (View topic image gallery).

shaker (resized).jpg
shaker (resized).jpg
20181101_112208 (resized).jpg
ras (resized).jpg
shaker-sketch (resized).png
Bez tytu?u (resized).jpg
Img_5240 2 (resized).jpg
AF129ED1-B6DB-4353-BDEC-FB2F78C6595D (resized).jpeg
8A054A6E-2E1B-4F47-A1CA-E62FB28A97F7 (resized).jpeg
E2C555B1-1FD6-4B7D-8715-88381365BD3B (resized).jpeg
B80F9FE5-C8F2-4EDF-9BEC-83CA9D37BC1D (resized).jpeg
3FA00633-F17E-4680-8BD8-DDE882F0323A (resized).jpeg
8493D70F-0FD2-4F84-B617-C5F15100FD35 (resized).jpeg
99708950-200A-4B17-9A09-63EBBAADB58B (resized).jpeg
D420BF1E-8D49-4A8A-9F97-2938EB384DE1 (resized).jpeg
34BE3AAD-8EAD-41D6-8D04-5734DF6B6B27 (resized).jpeg

There are 519 posts in this topic. You are on page 10 of 11.
#451 16 days ago
Quoted from BENETNATH:

update.zip is now update-done.zip
log says :
"2018-11-05 20:17:15.785 INFO [main] [despi.c:565] RasPinSound starting, version 1.17, serial: xxxx
2018-11-05 20:17:15.786 INFO [main] [despi.c:570] loading settings from .pisound2
2018-11-05 20:17:15.806 ERROR [main] [despi.c:573] license verify error"
removing key file doesn't solve the issue, no trial mode.
I don't have the .pisound2 file ..

I have the exact same issue. I tried upgrading from 1.14 as 1.17 was never working on my STTNG, and the update file is now renamed to update-done, however the log still says that it is version 1.14, and i get the same license verify error as BENEATH:

2018-06-14 17:07:52.472 INFO [main] [despi.c:488] RasPinSound starting, version 1.14, serial: 323XXXX435
2018-06-14 17:07:52.473 INFO [main] [despi.c:493] loading settings from .pisound2
2018-06-14 17:07:52.520 ERROR [main] [despi.c:496] license verify error

steve45 it seems there is an error regarding license file that keeps us from testing the 1.18 build?

#452 16 days ago

I will double check. Maybe releasing Saturday night was not a good idea

Unfortunately I can get it / test it now, but latest tomorrow I will update the package.

#453 15 days ago

We will be there for feedback

#454 15 days ago

Sorry the 1.18 update package was broken. Mad bad. Here is a new 1.19 one: https://mega.nz/#!AkAglIDa!SnK8nRZTr-yBWpkQCQwsRPz4HhINX0WNai1rAD18v0c

Br Steve

#455 15 days ago

Did a quick test with the 1.19 release this morning

Good news is that i now have sound on my STTNG again.

Bad news is that the problems i encountered earlier are still the same.

Most noticeable is that when ever i start a mode, the correct mode music starts playing, but after about 1 second, the "default game music" plays instead. Or likewise if you get the "command decision" where you can select a mode, the "command decision" music plays correctly, and when selecting a mode, the correct mode music plays for 1-2 seconds and then the "command decision" jingle/music is played again.

So as before, the biggest thing is that i have not got the correct mode music.

I tested with the original STTNG sound set.

#456 15 days ago

This is a video of a test in a STTNG. Please check wether the problem is there also

Quoted from Phantasize:

Did a quick test with the 1.19 release this morning
Good news is that i now have sound on my STTNG again.
Bad news is that the problems i encountered earlier are still the same.
Most noticeable is that when ever i start a mode, the correct mode music starts playing, but after about 1 second, the "default game music" plays instead. Or likewise if you get the "command decision" where you can select a mode, the "command decision" music plays correctly, and when selecting a mode, the correct mode music plays for 1-2 seconds and then the "command decision" jingle/music is played again.
So as before, the biggest thing is that i have not got the correct mode music.
I tested with the original STTNG sound set.

This is a video of a test in a STTNG. Please check wether the problem is there also

#457 15 days ago

Hi,

did a quick test on 1.19 with :
WPC-DCS : indiana jones WMS : here is the log and video
log : https://drive.google.com/open?id=15v9DOWgp4yhD88syBI7lapMX25RoWENY
video: https://photos.app.goo.gl/Y78ip3QgcWbTRheY6

my feedback is that it's really better. all musics seems ok now.
There is still a feeling of an issue with gfx. either not playing, not stopping well or a mess when too much sounds are played closely. like when multiple bumpers are hit in a second.

That's really getting better !!

i've test on LOTR whitestar, no change. still no music at first ball.

#458 15 days ago
Quoted from BENETNATH:

Hi,
did a quick test on 1.19 with :
WPC-DCS : indiana jones WMS : here is the log and video
log : https://drive.google.com/open?id=15v9DOWgp4yhD88syBI7lapMX25RoWENY
video: https://photos.app.goo.gl/Y78ip3QgcWbTRheY6
my feedback is that it's really better. all musics seems ok now.
There is still a feeling of an issue with gfx. either not playing, not stopping well or a mess when too much sounds are played closely. like when multiple bumpers are hit in a second.
That's really getting better !!
i've test on LOTR whitestar, no change. still no music at first ball.

The video is showing a LOTR and not a Indi. Logfile of the LOTR with the current version would be interesting I think.

#459 15 days ago
Quoted from lucky1:

This is a video of a test in a STTNG. Please check wether the problem is there also

Yes i actually think the problem is shown in your own video too.

In the video when the command decision is given, the correct comman decision jingle/music is running. Then "Search the galaxy" game mode is selected. But the music for "Search the galaxy" isn't played, but instead the command decision jingle/music keeps playing. This is just like i described in my previous post.

However i could be wrong as i am not 100% familiar with the soundset you are using. But if you can make a longer video with different game modes started i could better see it. And even if you could use the original soundset instead.

steve45 you mentioned you had built in support for stop commands, but i forgot the syntax / usage of it. Could you provide a link to some info, or perhaps sum it up here? Thanks I would like to see if it makes any difference, or makes the sound test menu behave more like the original.

Btw really nice to see this project moving forward again Love what both of you guys are doing for the community!

#460 15 days ago

As far as I can see from the pinmame source the stop commands are:

WPCS, WPC95 and WPC95DCS 0x03e3
DE 0x0018 or 0x0023.

Quoted from steve45:

So in raspisound.ini you can add a line like:

stop_cmds=0xFD 0xFC

In your case
stop_cmds=0x03 0xe3
should do the trick

#461 15 days ago

I think the Search the Galaxy music is the same as the command decision select jingle no?

#462 15 days ago
Quoted from holminone:

I think the Search the Galaxy music is the same as the command decision select jingle no?

Thats why it would be nice if the video had shown more modes started, and also modes started directly from normal play

But i'll try the stop command now and see if it makes any difference.

#463 15 days ago

Unfortunately the stop commands didn't help. Test mode still doesn't stop the music before moving on to voices, and gameplay still wont keep playing the mode specific music, but always reverts back to the main game music after 1 second.

At the very beginning the "Rescue mode" should play, but it only does for about 1 second. After that i start "Meteor" and the initial meteor music should play, but it only does for about 1 second before going back to the main game music.

Log from the filmed attempt: https://pastebin.com/4tzQiJzM

Video from the attempt:

#464 15 days ago

Cool project. That is beyond my pay grade!

#465 15 days ago

Just did another test with the Ultimate by Pinballshark sound set, and this also had a lot of errors. Sometimes the mode music would not start at all, and other times it actually played just fine. But overall you can hear sounds stopping when they should not, and once in a while it is as if you hear just a short glimpse of a sound that should not have been played. So it is always that feeling of something just being "off" and not triggered correctly. And i am pretty sure the mapping is correct, as every sound in sound test is the correct one.

However i dont quite know how to help from here on? I can make videos of more games and paste the log, but i have a feeling the amount of data from that approach is way too overwhelming. So perhaps it would be a good idea to see if we could get the orgiginal sound set working first, as per my previous post.

#466 15 days ago
Quoted from holminone:

I think the Search the Galaxy music is the same as the command decision select jingle no?

You actually might be right that that specific mode and command decision uses the same music.

#467 15 days ago
Quoted from lucky1:

The video is showing a LOTR and not a Indi. Logfile of the LOTR with the current version would be interesting I think.

Sorry, here is the 1.19 video of ij

https://photos.app.goo.gl/UJsRoVGNqkFo2NAS8

#468 15 days ago
Quoted from lucky1:

The video is showing a LOTR and not a Indi. Logfile of the LOTR with the current version would be interesting I think.

sorry. Video of LOTR is from 1.17 but it's mostly the same as 1.19.
I've added to the same folder the log for 1.19 LOTR

#469 15 days ago
Quoted from lucky1:

As far as I can see from the pinmame source the stop commands are:
WPCS, WPC95 and WPC95DCS 0x03e3
DE 0x0018 or 0x0023.

In your case
stop_cmds=0x03 0xe3
should do the trick

No that's no correct as it is a 16 bit command it must be stop_cmds=0x03e3.

#470 14 days ago

There's a new update 1.20 for RasPiSound https://mega.nz/#!gsoQ2YSb!sbS9ZzCSEXKCTDf7eVrGnJCBbIK9DoPHEhqs_EZ4wrk
It has some improvements for logging and now full usb stick support.

To use usb support you need to reimage your card completely. The new image with version 1.20 already installed, can be found here https://mega.nz/#!ptIUGQYb!FerQO-tpXDSqLIBeUE9buES0pmdWV17pZlWBJclYDws

To simply upgrade to 1.20 reimage isn't required, but w/o usb stick support will not work.

Usb stick support removes the need of changes to the sd card completely. All custom files are store on the usb stick including license file. Just format the usb stick with fat32 and use the same directory structure as on sd:

- data/sound/raspisound.ini
- data/sound/<sound mixes>
- data/sound/<sound mix A>/<sound specific config>

License file on usb stick must be placed to data/sound/<serial>.key. Logfiles will be stored to usb stick as well, so no more writes to sd card, which will improve sd card lifetime.

The new image is based on dietpi a very small and fast linux, with close to zero writes to sd card. This results in faster startup time and the download size is also reduced.

Also the expanded image is slightly smaller than 16GB so it should fit on every 16GB card even if some have less capacity.

Br Steve

#471 14 days ago

Just throw in my 2 cents in.
I really think everyone should use the stock sound package while we are trying to “fix”things. That way we are all on the same page. Also, if you have an original sound board and can hook it up so it works on the machine at the same time Raspisound is playing on an external speaker that helps to hear problems live as they happen in real time. I explain how I did that earlier in this thread.

Just some thoughts.

#472 14 days ago

Tried correcting the stop command to stop_cmds=0x03e3, but still no luck...

And updating to 1.20 did not make any difference either.

Log from a short test run with the 1.20 update: https://pastebin.com/mnZnHdnH

In the test i tried the sound test menu where music did not stop as it should, and in game i started 2 modes, both had the main theme music playing after 0,5 - 1 second of mode music.

Also, if you turn on the raspisound and have it preloaded and ready BEFORE the pinball machine, when the machine is turned on it starts playing the multiball music for a while, until it is interrupted by the error sounds because of the soundboard interface error. And if you listen REALLY carefully when starting a game and launching the ball, the same multiball music starts playing for about 2/10 of a second. It is barely noticeable, but it is there. And the log shows it as well. Really strange...

All tests done with the original mix for STTNG

#473 12 days ago

I tested the new version 1.20, and nothing has changed, it still works bad, sounds overlap, do not end when they should, etc

https://drive.google.com/file/d/1xsRVQ7pxqBiQ34ot4TgzXHBj0lT_vToM/view?usp=sharing

#474 12 days ago
Quoted from fly:

I tested the new version 2.0, and nothing has changed, it still works bad, sounds overlap, do not end when they should, etc
https://drive.google.com/file/d/1xsRVQ7pxqBiQ34ot4TgzXHBj0lT_vToM/view?usp=sharing

It's helpful to post which game, which mix, which platform... also is it 1.20 that you installed? there is no 2.0

#475 12 days ago
Quoted from Rdoyle1978:

It's helpful to post which game, which mix, which platform... also is it 1.20 that you installed? there is no 2.0

Of course 1.20, my mistake

Road Show, roadshowJC

#476 12 days ago

I have no time for testing atm, but i agree that GFX ending is still not working as it should. I had on 1.19 on IJ a lot of gfx not ending properly. like the ending sound still playing during the lottery.

#477 12 days ago
Quoted from Phantasize:

Tried correcting the stop command to stop_cmds=0x03e3, but still no luck...

I need to look into the logs with more time this evening, but indeed there's a bug still in version 1.20, that completely ignores 0x3E? commands. So this cmds also isn't recognized as stop cmd. This will be fixed in the 1.21.

Br Steve

#478 11 days ago

Working on the next hardware revision for RasPiSound which will include a hifi DAC like the famous hifiberry shield. This will improve sound quality even more as the DAC features a very good SNR & dynamic range (112db) and sampling rates up to 384kHz.

It uses the i2s sound interface, which requires to adjust the pinout of RasPiSound. Firmware is already running, but the shield also need some changes.
Because of integrated i2s sound and amps the setup will be even simpler.

Latest firmware is already running in my test setup:

Cheers Steve

#479 11 days ago

If we get reliable sound reproduction, I will definitely want some more So I am exited to hear the sound quality will be improved.

However, until I get it working in my STTNG I will hold back on any further purchases.

But I really hope to see improvements with the new firmware versions that are coming.

#480 11 days ago

The 1.21 is out. Find it here: https://mega.nz/#!c9JE0CqK!yMRwld4GgWI_njnh-9XEFcXqnt9rI-BIVoKnEiY23h4

It fixes the bug with the stop commands, has improved logging and support for the new pinout (even if there is no shield so far).

/Steve

#481 11 days ago

1.21 is better but still some issues:

Sound test menu: Stop commands is definately better. Working on my STTNG up until it cycles from the last number back to number 1. When doing that, the engine/ship ambiance sound continues playing at the same time as the tune in the number 1 spot. So perhaps there is more stop commands i need to add to the config?

Gameplay: No apparent changes. Still same issues when starting a game mode. The correct music starts and plays for about 0.5 - 1 second, and then the main gameplay tune kicks in again. All other sounds seem to be ok.

And also the multiball tune still plays when starting the machine

Tested on STTNG with the original mix.

Log from the video: https://pastebin.com/SYZ787vs

Video:

#482 10 days ago
Quoted from Phantasize:

1. When doing that, the engine/ship ambiance sound continues playing at the same time as the tune in the number 1 spot. So perhaps there is more stop commands i need to add to the config?

Stop Cmds are working according to the logfile, but they only stop background music not sfx, voice or jingles. You sure that this is relevant? sfx, voice and (s)jingle or the short ones, that normally don't require any stopping just because they are short.

#483 10 days ago
Quoted from Phantasize:

Gameplay: No apparent changes. Still same issues when starting a game mode. The correct music starts and plays for about 0.5 - 1 second, and then the main gameplay tune kicks in again.

at what timestamp in the video is this? btw. we can do our debug sessions w/o the whole pinside audience. not sure if this is of any interest for somebody other than you and me

#484 10 days ago

I'm interested by this debug too!
No time to test now but reading!

#485 10 days ago

I think I spotted the problem with the mission start. Its the sequence of having a jingle "mission_start" while main theme still playing, then starting theme music e.g. "asteroid_threat" and then resume from the jingle.

In this case the "resume" switched back to the music that was played before, which was main_theme. But if another music was requested in the mean time, it should continue playing the new one. Found and fixed: new version 1.22 https://mega.nz/#!U1ZSmSzY!8iAbDO0dg0NXTgkVRLeQ46oABPv89SnMABXyqtZT7ZM

phantasize : Thanks for the great debugging support. Br Steve

#486 10 days ago

Glad to help, and really awesome to hear. I have a feeling this could be one of the more important fixes (for me anyways)

Unfortunately the missus just went to sleep, and the machine is right next to the bedroom so I won’t be able to test until tomorrow.

And btw, regarding the sound not stopping in sound test, I agree that it is probably not an issue during normal gameplay. I just thought that I would mention it if we were shooting for 100% emulation, and it was just about adding an extra stop command value to the config file.

I will test as soon as I can tomorrow.

#487 10 days ago

Argh, me wants to test..

#488 10 days ago
Quoted from BENETNATH:

Argh, me wants to test..

What’s keeping you from doing it then?

#489 10 days ago

I test on roadshowJC, and unfortunately I do not see any changes, Red's and Ted's voice is not heard, eg the sound from the "New York - Smash a Cab" mission does not end, only after losing the ball it turns off. e.t.c

#490 10 days ago

Hmm, i have a roadshow. Perhaps i should test on that too. But my STTNG have been my primary concern, as I really want to use the ultimate mix by pinballshark. At one time I had a Pinsound board installed in STTNG and really enjoyed that mix.

For me the biggest wish is getting it to run perfectly for STTNG, IJ and TZ as those have some really cool sound sets available.

#491 10 days ago
Quoted from fly:

I test on roadshowJC, and unfortunately I do not see any changes, Red's and Ted's voice is not heard, eg the sound from the "New York - Smash a Cab" mission does not end, only after losing the ball it turns off. e.t.c

if you would provide more meaningful data like Phantasize like a video and a logfile uploaded to pastebin I'm quite sure I will see what's going wrong and give some advice or produce a bugfix. But ...

#492 10 days ago
Quoted from Phantasize:

What’s keeping you from doing it then?

Spare time at the moment. And this weekend.. has no end...
I'll try to give a try and update to 1.22

#493 10 days ago

Looks like mega is not working for all of you, so I just wanted to point out the "official" repo for RasPiSound is here https://bintray.com/sker65/RasPiSound.

There you find all nightly builds along with the official releases.

#494 10 days ago

Mega worked for me after restarting my browser, and there are some real nice improvements in 1.22 for me in my STTNG. It is really really close to being 100% accurate now when using the original mix.

I will try another mix as well before long to see how that goes.

#495 10 days ago

some feedback of latest build : raspisound-update-v1.23-144862146.zip
1) IJ WMS DCS : no sound is played after the preloading announce. i've got the version 1.23 mentioned, the preloading, then nothing more

2) LOTR Whitestar : same things.

i've put logs in the drive : https://drive.google.com/drive/folders/15zvU-iqDkVZI-azTAPpfo01kqPTJfcHY?usp=sharing

EDIT : i'll give a try to 1.22 official now

#496 10 days ago

1.22 officiel tested
I've got sounds !
On IJ WP-DCS : it's really nice, except that sound are still overlapping when bumpers are triggered.
Shall i put on true the "suppress_repeated" option ?

On whitestar, i don't see any difference, as the main bug is still there. No music at ball 1 and no music restart when starting a new game (attract music is still played)

logs are in the same folder as 1.23
https://drive.google.com/drive/folders/15zvU-iqDkVZI-azTAPpfo01kqPTJfcHY?usp=sharing

#497 10 days ago
Quoted from Phantasize:

Mega worked for me after restarting my browser, and there are some real nice improvements in 1.22 for me in my STTNG. It is really really close to being 100% accurate now when using the original mix.
I will try another mix as well before long to see how that goes.

The remaining problems with starting Multiball sound in the beginning should be fixed with v1.23. you can find it on bintray already.

#498 10 days ago
Quoted from BENETNATH:

1.22 officiel tested
I've got sounds !
On IJ WP-DCS : it's really nice, except that sound are still overlapping when bumpers are triggered.
Shall i put on true the "suppress_repeated" option ?
On whitestar, i don't see any difference, as the main bug is still there. No music at ball 1 and no music restart when starting a new game (attract music is still played)
logs are in the same folder as 1.23
https://drive.google.com/drive/folders/15zvU-iqDkVZI-azTAPpfo01kqPTJfcHY?usp=sharing

I need to take some time to look into that, but I'm confident we will make progress here as well.

#499 10 days ago

Yes, I'm also confident.
Keep it up!!

Promoted items from the Pinside Marketplace
3,000
Machine - For Sale
Torrance, CA
$ 229.99
Lighting - Other
Lighted Pinball Mods
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 8.50
Lighting - Led
Bright Lights Pinball
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 27.99
Lighting - Interactive
Lee's Parts
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 131.00
$ 175.00
Lighting - Interactive
Professor Pinball
€ 4.99
Flipper Parts
Multigame
$ 40.00
Lighting - Other
Professor Pinball
$ 20.00
Playfield - Decals
Metal-Mods
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
From: $ 99.99
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 9.99
Eproms
Matt's Basement Arcade
Wanted
Machine - Wanted
Ballston Spa, NY
From: $ 29.00
Boards
KAHR.US Circuits
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 20.00
Lighting - Other
Professor Pinball
Great pinball charity
Pinball Edu
There are 519 posts in this topic. You are on page 10 of 11.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside