(Topic ID: 128980)

RBION weak upper right flipper


By Worstpinballever

5 years ago



Topic Stats

  • 13 posts
  • 6 Pinsiders participating
  • Latest reply 1 year ago by RTS
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 5 years ago

So I just bought a nice RBION. I noticed while playing the upper right flipper seemed weak (the flipper seems to collapse when a ball hits it). I bought and installed a new solenoid and the problem is still there. Also when I go into the coil test it wont fire but it works when I cycle the coils in the test mode. I can also push the coil down with very little pressure when its energized during a game. I tried jumping the Q14 transistor and that worked and the coil was very strong(can't push flipper back down). I'm stumped.

#2 5 years ago

I assume Q14 is the driver transistor by the schematics? I don't own RBION but it sounds like you should replace the transistor if jumping it solves your problem. Could be partially damaged so it has more resistance than it should between the doped layers in the device and is not allowing full current flow through.

#3 5 years ago

I have a STP19N06L Mosfet TO-220, will that work? The manual calls for a STP20N10L, I don't have one of those.

#4 5 years ago

Is there an EOS switch? Is it operating properly?

#5 5 years ago
Quoted from Worstpinballever:

I have a STP19N06L Mosfet TO-220, will that work? The manual calls for a STP20N10L, I don't have one of those.

Those are almost identical transistors spec-wise.. except that you have a much higher driving voltage threshold on the one that the manual calls for -- 100v vs 60v for the one you have on hand. The flipper circuit should be running around 50 - 60v so the one you have on hand is probably fine if you want to try and fix it right away. The max continuous and pulsed current specs are only 1amp off between the two so unlikely that would cause any problems. No promises though.. if you're not in a hurry I'd just order a few of the correct ones. If you want to try to fix it right now, go for it but no promises

Just to clarify -- the flipper is initially strong but it won't stay up when the circuit switches to the holding current or is it weak even when it's "flipping" ?

#6 5 years ago

tjc02002, there isn't an EOS on that flipper.

#7 5 years ago

Mbecker, thanks for the information!

I'm going to order the correct part and do it right the first time. The game is still playable, it's just when a ball with some velocity hits the flipper bat, it pushes it back down. Almost like something was loose in the mechanism (nothing is). It seems like it isn't getting enough voltage.

#8 5 years ago

Good luck! Def. a voltage/current problem with no EOS switch there. I wonder what the voltage is measuring when the flipper is activated and holding?

#9 4 years ago

Well, I replaced the transistor to no avail. My friend came over last night to help me trace the problem. We think it might be something wrong on the CPU/sound board. At the top of the board, in the "dedicated switch in" section. Does this make any sense?

#10 4 years ago

Not sure if there is an issue, but the flipper is supposed to be "weaker" by design. You are not supposed to be able to shoot it around through the upper lanes and back to the upper flipper and loop the ball like in No Fear or something. It shouldn't collapse under the weight of the ball, but if you can make a super jackpot shot and can get the ball to the rollovers up top with the upper flipper, it may be just fine.

#11 4 years ago

In any case keep us posted if you find a fix!

#12 4 years ago

The thing that's odd is that it wont fire in test mode. All other coils do.

3 years later
#13 1 year ago
Quoted from Worstpinballever:

The thing that's odd is that it wont fire in test mode. All other coils do.

I had just rebuilt the lower flippers on RBION, and was testing everything before reattaching the trough (it blocks access to the coil.)

I was in coil test, and couldn't understand why the upper flipper wasn't working ... until I read this comment.

I discovered the same issue - the upper flipper actually works in game-play but not in coil test on Ripley's.

Anybody know why? It's only the upper flipper coil.

Promoted items from the Pinside Marketplace
5,000
Machine - For Sale
Rutledge, PA
$ 99.00
Playfield - Other
Arcade Upkeep
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 40.00
Lighting - Interactive
Professor Pinball
Wanted
Machine - Wanted
Orchard Park, NY
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 16.50
Lighting - Led
Lermods
$ 35.00
Cabinet - Other
Arcade Upkeep
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside