New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 98013)

RBION shooter switch issue


By Lermods

6 years ago



Topic Stats

  • 19 posts
  • 5 Pinsiders participating
  • Latest reply 6 years ago by Lermods
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 6 years ago

I am getting a tech alert for the shooter switch, hyper switch #16.

Seems to be working fine in terms of activating and firing a ball, but when balls shoots into the lane and rolls back it activates the flasher as shown in the video. I don't think that's what it's supposed to do.

In switch test mode, the switch opens and closes as it should when I press on it.
If I roll a ball into it in switch test it opens and stays that way and then closes when I remove the ball.
The wiring all looks good, no breaks or anything loose.
Pushing on the switch from underneath or tapping the PF nearby does not activate it.

Is this a bad switch or maybe something with the the trough nearby since they are on the same column?

Thanks for the help.

#2 6 years ago
Quoted from Lermods:

If I roll a ball into it in switch test it opens and stays that way and then closes when I remove the ball.

That sounds backwards. On Ripley's, with the balls removed, I'm pretty sure the only closed switch should be on the vari-target. If the switch is wired for normally closed, it's wired wrong. Check the nearby lock switches wiring and diodes and compare.

#3 6 years ago

I too believe this is correct. You should have at least 1 position active on vari target and nothing else unless a ball is present.

I can look at wiring on mine if you cannot get it figured out PM me for pictures.

I have watched the video and do not see a problem? The nearest flasher is suppose to flash when it sees the ball and then again when it launches the ball. Maybe the above statement describing the issue was mis understood.

#4 6 years ago
Quoted from Shoot_Again:

I have watched the video and do not see a problem? The nearest flasher is suppose to flash when it sees the ball and then again when it launches the ball.

I couldn't remember because mine is 15 miles away (on location). If he got the part I quoted backwards, he may be good to go.

Those lower white flashers suck. If I hadn't already bastardized my game so much, I might change them to another color. Who puts two big ass white flashers that low on the playfield? (rhetorical question)

#5 6 years ago
Quoted from Shoot_Again:

I too believe this is correct. You should have at least 1 position active on vari target and nothing else unless a ball is present.
I can look at wiring on mine if you cannot get it figured out PM me for pictures.
I have watched the video and do not see a problem? The nearest flasher is suppose to flash when it sees the ball and then again when it launches the ball. Maybe the above statement describing the issue was mis understood.

That is what I have. Four trough switches and one vario target are active. So why am I getting the tech alert for hypersensitive switch 16? I have also noticed once in a while I get a ball search while playing. Related? Could it be the trough optos need cleaning?

#6 6 years ago

Switch 16 is the shooter lane. I would resolder it and make sure it is not closing naturally without the ball present. (hypersensative could be adjustment or could be micro sw on its way out.)

Ball search could be related but is usually the stacking opto. Either connections, weak solder joint or dirty or bad opto.

Check ball trough switch and stacking opto. with switch just actuate it and see how it is working. I have seen them be flaky when new if someone sinches down the screws that hold the switch. It could also be adusted way to close and actuating off of vibration.

As for the stacking opto look at both connectors where they plug into the boards. wiggle with your fingers Do you see any movement on the legs themselves that go through the board? Maybe need resoldered. Molex connector can also wiggle loose. I have fixed this a number of ways in the past. Some times push tool and replace connector. Sometimes slightly bend a pin and reinsert into the connector to make more snug. I have also zip tied around things to hold these in place before although not ideal it can work.

Check these things out and post here or PM me and I will try to help you.

Good news it is working bad news is your phantom ball search will not leave on its own.

#7 6 years ago

Thanks, I will check all of these things. Ignore my open/closed, I may have it backwards. Switches register in switch test when pushed and deactivate when I let go. Only four balls and vario are active. I'm thinking the trough optos are dirty and this is causing the ball search issue, connections on opto board seem good, but could still be a solder issue.

What is the purpose of the shooter lane switch? Is it to let the game know a ball is there to fire it automatically when needed, such as in mb. When you start a game, it basically has no function.

#8 6 years ago

Shooter lane is very key in MB when using autolauncher.

It is just used to follow the path of the ball until truly in play. once stacking opto does not see it bottom or stacked then it checks to insure shooter lane switch is made.

#9 6 years ago

Took a closer look tonight, trough optos and trough switches register as they should. I think the issue is the shooter lane switch. It is not normal when the ball launches and rolls back on the switch that the flasher lights and it makes the launch sound. My LOTR does not do anything when the ball is loaded. I also notice at times during mb, the switch is not activating fast enough and two balls get loaded, tonight all three were loaded in the lane before it shot them out. The switch is easy enough and cheap enough to just replace so that's my next step.

It's strange because in test mode, it registers perfectly, but in game mode it has this issue.

Other thoughts?

#10 6 years ago

Which version of ROM are you running, Stern has issued alert for that on there website. My machine doing the same thing, changed the switch did not change, ordered new Rom's from John Wart and changing them tonight, will post after the change.

#11 6 years ago

Thanks, I have the latest roms, 3.0.

The latest roms don't address the shooter switch in particular, just says it fixes erroneous switch error messages. Im not sure my issue is erroneous as a loaded ball should not trigger the flasher and launched sound. That should only happen when the ball is actually launched.

#12 6 years ago
Quoted from Lermods:

Other thoughts?

Have you checked the shooter lane switch to see if it's opening/closing too early/late? In switch test, hold a ball loosely and very slowly roll it over the actuator. May just need the actuator tweaked (bent).

The switch is cheap and if it's original, it's getting tired (if it's not broke). Order a new one before you check the old one again.

#13 6 years ago

#14 6 years ago

3.0 is not the latest but the problem rom, you need 3.20 from what I have been told. There is another string on pinside about it also.

#15 6 years ago

Sorry, just checked, I have 3.2. Im pretty sure the switch is the issue. I think it's actuating too early. I'll try bending it back a little, and order a new one.

#16 6 years ago

A little late to the game here, but I had the same issue...adjusted the switch and all was fine. Got a new switch to have on hand but still running fine w/original.

#17 6 years ago

Riprock, thanks...and to the others as well, really great resource we have here with pinside. 9 times out of ten someone else has had the same issue as you.

#18 6 years ago

You are quite welcome sir. Yes, always a great resource here. Enjoy your game and the hobby!

#19 6 years ago

I was able to fix this tonight by bending the switch back a little. It's still a little intermittent, so I'll have to keep playing with it. The balls were also launching faster during MB. Seems the ball should activate the shooter switch as far back toward the shooter rod as possible. Not quite sure I understand why this is the case, but it seems to be. Thanks again for the responses!

Promoted items from the Pinside Marketplace
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 279.95
Lighting - Led
Pin Stadium Pinball Mods
Wanted
Machine - Wanted
York, PA
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 499.95
Lighting - Led
Pin Stadium Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
3,800 (OBO)
Machine - For Sale
Oakville, MO
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 40.00
Lighting - Interactive
Professor Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside