(Topic ID: 19826)

RBION Continent Multiball problems - FIXED

By TheLaw

9 years ago


Topic Heartbeat

Topic Stats

  • 13 posts
  • 7 Pinsiders participating
  • Latest reply 1 year ago by boastaflow
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

RBIONopto.jpg

#1 9 years ago

I just updated my ROMS to the latest version last week. Anyway, I have noticed every once in a while when I'm playing a Africa, N. America, or Antarctica multiball, the game just keeps firing the coil for the ball trough endlessly. The ball save is active and never goes away, and the trough keeps firing away so it's stuck there forever until you tilt the machine...I've even opened the coin door for awhile and then closed it but it picks up and keeps going.

So, just wondering if anyone else has run into this problem? The machine doesn't have any other errors or issues that I have seen. It's never confused aboot how many balls are in the trough or when to fire the coil at any other time.

Thanks!

EDIT: Crap....or is it the auto plunger coil? It's one of them...too late to check now and don't know if it matters.

#2 9 years ago

If it's the plunger coil maybe you have a bad shooter lane switch?

#3 9 years ago

Whats weird is that it's just constant shooting. Kicks a ball out, plunger fires it. Then one of them just keeps thumping away. I'll have to get in there and test all the switches for both areas.

#4 9 years ago

ok to update this and get some help...ready for too much info? I ran some tests tongihty and it seems that I have a bad opto?
Clearing the balls out of the game, I still see this image, which I assume means the game thinks there is a ball at this opto location, even though there isn't.
Active switchers shows this(ball trough #4) & vari-traget opto #1 always on...no prob with vari-target & I assume it has an opto for each position it's in which is kosher.
Switch test doesn't change if i push the trough plunger up and block the beam...although both opto LEDs are lit. From what I know of 90s W/B games the opto doesn't actually make a light so I don;t know what the deal is there.

Anywhom, seems to be just a bad opto. Blue pages here show
http://www.sternpinball.com/RBION/77.html

That I need a/or
#515-0173-00
#515-0174-00

Is there anyway i can check which side is bad? Old school was using a LCD camera which would show me a beam of light...still work?

THANKS!

RBIONopto.jpg

#5 9 years ago

Pull both ball trough opto boards. Remove the old solder and flow on new solder on the optos and the pins the connector plugs onto.

Put back in game and enjoy playing again.

LTG

#6 9 years ago

Old solder on a game this new..Known problem?
THANKS!

#7 9 years ago

Same problem on my Monopoly. Cold solder connections on the connector pin on the opto board for the ball trough. Missing ball problem, kept shooting out balls.

#8 9 years ago
Quoted from TheLaw:

Old solder on a game this new..Known problem?
THANKS!

The solder they wash the board with seems to turns gray and crappy after awhile. Known problem.

LTG

#9 9 years ago

Awesome, thanks a bunch. I'll give her a shot this weekend.

1 month later
#10 9 years ago

Problem solved BTW...sorry for not updatig for future lookers. Just as described above....fixed it right up.

#11 9 years ago

I had the same problem with Baywatch and a reflow did the trick. Ripley's is 8 years old and those opto boards are subject to a lot of vibration. The opto design isn't the best, they shouldn't be used in high vibration environments.

7 years later
#12 1 year ago

Reflow worked for me! So glad these posts are still out here. Real life savers!

2 months later
#13 1 year ago
Quoted from austinjw1955:

Reflow worked for me! So glad these posts are still out here. Real life savers!

Joint the club I just picked up a riplies and had these issues when it arrived home thank god these these are out for us all to find and be able to fix

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside