New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 201885)

Random Tilt and Phantom-Switches F-14 TOMCAT


By Defender_LXIV

3 years ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 3 months ago by kvan99
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

download (1) (resized).jpg
F-14 Matrix 001 (resized).jpg

You're currently viewing posts by Pinsider defender_lxiv.
Click here to go back to viewing the entire thread.

#1 3 years ago

Hello Guys!

I know my F-14 since I was born (15 years) and I love it since then! After 15 years we (my father and I) decided to restore the machine a bit (LEDs, new Rubbers, fix some Switches, etc...). We fixed the easy things and for the difficult problems we brought it to an expert.
But since then I've that horrible random Tilt from which many people are talking.
It happens nearly extactly like another Pinside user told (Bok013). It happens when I play on the upper play field when I hit one of the TOM letters --> it Tilts and until I get the next ball the lights of one of the TOMCAT letters are going out.
But there is not only the Tilt that triggers randomly. There are many Phantom-Switches triggering when specific coils are working. Most of them trigger when pressing the right or left flipperbutton (EOS 15, 63). But also the left and the right sling (57, 58) and the bumper (28) provoke such a Phantom-Switch.
Often when I press the left flipperbutton the machine things that I hit the 'Kill Yagov' cave (55) without hitting it. But also the left + right drain (Kickback) (61, 62) + the Ball Shooter Lane (16) and the top left and/or right loop (47, 56) are triggering randomly.
Certainly the most annoying Phantom-Switch after the random Tilt is the middle and the upper ramp (31, 32) so that it shoots out the locked balls without having multiball. I think that this issue also comes when playing on the upper play field and hitting the right or left switch of the loop.

I am in e-mail contact with the expert where we brought our F-14 to and he speculates that one of the Chips on the MPU Board is not working anymore. He said that I should mark the Phantom-Switches on the Matrix and one line or column will be concerned. But when I mark the Phantom-Switches you can't see any pattern/line/column which could be concerned.

I uploaded the Matrix. The yellow marked switches are the ones wich are triggering randomly and the encircled switches are the ones wich provoke such a Phantom-Switch. (of course, there can be some faults in marking the switches but it should be roughly correct)

Does anyone has the same problem(s) and does anyone know how I can fix that problem?
I know, this sounds pretty difficult to fix but I would be very happy if you guys would awnser and tell me how I should go ahead with this problem.

(I apologize for my bad english skills )

Greets
Cedric

F-14 Matrix 001 (resized).jpg

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
Wanted
Machine - Wanted
Cleveland, OH
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
1,800 (OBO)
Machine - For Sale
Marshfield, WI
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 15.75
Cabinet Parts
Tilted Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 9.00
Electronics
Yorktown Arcade Supply
$ 39.99
Eproms
Matt's Basement Arcade
$ 17.00
$ 85.95
Cabinet - Shooter Rods
Super Skill Shot Shop

You're currently viewing posts by Pinsider defender_lxiv.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside