(Topic ID: 276757)

Q*Berts Quest boot up problem

By RaoulJuke

1 year ago



Topic Stats

  • 5 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by Grizlyrig
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Howdy, I am going to start this thread by pointing out my total, utter lack of experience and confidence on working on Gottliebs. Because of this i am very stumped at how to even start off with solving this problem.....

This problem is intermittent. When i start up the machine, it will boot up ok. Then the PF lights drop out, the BG TILT light goes on & the game is unplayable. Sometimes the lights will flicker on and off with a loud "clicking" going with it from under the playfield. Sometimes the clicking will happen with the lights not on.

Sometimes it will let you start up a credit with the lights off, but the flippers will not work and no sound. The ball will load up on each drain though.

I have no idea where to even start on this. I checked the connectors to the tilt and reconnected them again, but i dont think this is the issue.

I have no manual for Q*Bert and i cant find one online. The boards are original, not the Pascal Janin remake.

Can a pinballer with patience help me work through this issue. Love the game, but its on/off workability makes it a difficult game to rely on in a competition format

#2 1 year ago

just a little update - the high score to date light flashes ongoing & occassionaly the P1 score display will start counting up from zero - some weird bloody stuff

#3 1 year ago

SOLVED: Ended up being connector issues, re-pinned a few connectors and it seems to be sorted

#4 1 year ago

Not Solved: So played a few games this mornig and machine is doing some very odd stuff.

One game the sound and light sequence was not for Qberts quest - was a different game completely.

Then played another game where the sounds and lights seemed ok, but it just gave me endless amounts of balls.. On the balls in play count it said "71

During this game it played mostly to expectation, except when a map was completed the PF lights would all drop out, along with the flipper power for a few seconds before everything kicked back in as normal.

Really weird stuff! Heard Gottliebs were a bit 'different', but this is beyond weird. How the hell does one problem solve this??

#5 1 year ago

My first thoughts are doing all ground mods and slam switch mod.
Check that voltages coming out of power supply are where they should be.
I am in the habit of re-capping the power supplies no matter what, for my own peace of mind.

Some very good reading over here

https://pinwiki.com/wiki/index.php?title=Gottlieb_System_80

-Mike

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
$ 10.00
$ 22.95
Electronics
Pinballrom
Hey modders!
Your shop name here

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!