(Topic ID: 295685)

Please help with Prospector not scoring properly

By Brewster007

3 months ago



Topic Stats

  • 5 posts
  • 2 Pinsiders participating
  • Latest reply 3 months ago by HowardR
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

pasted_image (resized).png

#1 3 months ago

Hi all, I have a sonic prospector pinball that I let a nephew play and later he said it's not working. It was not scoring or no lights up on backboard. I had a play with it and left it. This week I checked it again and it would not reset. I went to score reels and cleaned them and now it resets. I pulled out the jones plugs and cleaned them and got the lights to work .So I can play it ,makes all the sounds but score reels will not move. I tried 2 player but it won't move to 2 player because of no score. I do notice that once started and I run over a scoring function there are a couple of relays humming. I found humming coming from the coil on the right hand chime stuck on , reading 27v .The gold and silver progression lights don't light and the middle kicker doesn't kick but collects score. The first two score reels work but the 10 thousand reel doesn't score. This happens on the second player reels as well. I am at a loss as to what's going on. I am about to shift and unfortunately don't have time to order and wait for delivery of schematic from USA. As because of moving to an apartment I don't have room for any pinballs. Any of you clever guys got any idea?

#2 3 months ago
Quoted from Brewster007:

there are a couple of relays humming

Which ones?

#3 3 months ago

Hi Howard. I had a good search and found the small chime coil (closed to cabinet) was buzzing and was reading 27v ac. The other one is the game over coil, maybe that's meant to be on ?

#4 3 months ago

I've checked and cleaned contacts on score motor but still no difference .

#5 3 months ago
Quoted from Brewster007:

I've checked and cleaned contacts on score motor but still no difference

Sorry but that was a mistake. This forum is full of posts from people who tried shotgun cleaning & adjustments, and caused more problems than they were originally trying to solve.
What to do instead: Slowly and carefully diagnose one problem at a time and then fix only that.
http://www.pinrepair.com/em/index2.htm#clean

Quoted from Brewster007:

the small chime coil (closed to cabinet) was buzzing and was reading 27v ac

What are these switches on the 100 Point relay and the 1000 Point relay doing when this happens?

pasted_image (resized).png

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside