(Topic ID: 166606)

Possible power surge on my Flash Gordon


By aKa

4 years ago



Topic Stats

  • 20 posts
  • 3 Pinsiders participating
  • Latest reply 4 years ago by aKa
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

fuse-Breaker_(resized).jpg

You're currently viewing posts by Pinsider aKa.
Click here to go back to viewing the entire thread.

#1 4 years ago

I have an old electrical setup at home, and I believe my Flash Gordon suffered from a power surge yesterday. Anyways, it doesn't light up anymore, apart from a faint light on the edge of the displays.

An electrician will come tomorrow to update my electrical setup, but I doubt he'll check the pinball. I read somewhere that a varistor and an associated fuse protect the rest of the machine from such a misadventure, but I can't locate the fuse next to the varistor (which looks fine, but I didn't test it).

Where and what should I look for to begin with ? Bear in mind that I'm quite challenged when it comes to the electric side of things, which is why I bought a perfectly working machine, that I just happened to finish restoring yesterday.

#5 4 years ago
Quoted from Lovef2k:

The fuse is behind the rectifier board on the floor of the main cabinet. Look for a metal bracket that holds a square connector and the fuse is right next to it with a black cover. Also check to see if the line filter is blown.

I checked that fuse, and with my multimeter on 20k ohms (Am I doing this wrong again ?), it reads 0.06.
As for the line filter, if by blown you mean the case cracked open, then no, it doesn't look blown.

Quoted from vid1900:

If you've got the faint glow, your game still has high voltage power.
Open the backbox, turn on the game while watching the LED on the MPU board (large upper left board).
Seven flashes?

Well, the machine lit briefly before fading away yesterday after the incident in my main electrical box in my kitchen, and on subsequent powering up, there was this faint light on the displays. Today it's definitely dead, no faint lights or blinking. Could it just have been some residual power still left in the machine ?

#7 4 years ago

All right, I'm even more challenged than what I was suggesting in my first post.

Of course the machine is dead when you don't put the fuse back on ...

Things have mysteriously improved. The machine works, except for the sounds and voices (well there is that two tone sound during attract mode, but that's it), and the GI (except strangely the four lights behind Ming's head that light up when you start a game). The rest seems fine.

#9 4 years ago

Yes, F5 (20amps) is dead. I guess it's this one.

Now we're left with the sound issue.

#10 4 years ago

Well, I replaced the F5 fuse (it's a 20 amps fast-blow, right ?), and it blew again. I didn't even put bulbs in the backbox so there should be some room, power wise.

It worked well until that electrical issue in my apartment, caused by my toaster plug being shorted (we figured it out with the electrician), but a power surge should have blown the first fuse after the plug in the pinball.

I'm not sure what to try now.

#12 4 years ago

If I disconnect J1, the fuse holds up, and even the sound works again.

I guess there's a short somewhere below the playfield, and I also guess it'll be a long hunt.
I noticed though that one of the sockets just next to the left flipper mount plate seems to be touching the plate. The socket is quite loose but its wire is desoldered (I didn't take the time to tackle this yet). Could it be it ?

I'm down to 2 fuses left, that I have to go across town to get, and I know that I'll have to buy a circuit breaker. Oddly enough, since I live in a big city (Paris), I've had the hardest time finding a 1 amp one for my other pinball when I needed it, and I had to order it from Germany. Maybe I'm not looking for the right thing ...

#13 4 years ago

Would a 16 amps circuit breaker do the trick in place of the fast-blow 20 amps fuse ?
Like this one : http://www.stquentin-radio.com/index.php?page=info_produit&info=10123&color=9&id=0&act=0
Or one like this that is supposed to go inside a fuse panel : http://www.castorama.fr/store/Disjoncteur-Phase--neutre-16-A-LEGRAND-PRDm824439.html?navCount=0

#15 4 years ago

I remember vid1900 recommending a lower amp value for the circuit breaker than the actual fuse, and a 16 amps breaker like the one on the second link of my previous post can be found at every street corner, so I'll go with that one, unless someone believes a 20 amps breaker is more suited.

#16 4 years ago

So I bought one that you normaly put in a fuse panel (like in the second link of post #13), but of course it is made for two wires (phase and neutral). How do I handle it and not fry my pinball ?

#18 4 years ago
Quoted from vid1900:

Normally, most people do it like this, using a blown fuse.
You may have to use alligator clips.

Thanks vid, but that's not what I meant. I intend to use alligator clips, but my issue is that my circuit breaker is intended to be used in an AC circuit, with to wires in, two wires out (phase and neutral). I believe that for my needs, AC or DC doesn't matter, but I suck at understanding electrical circuits so I'm not sure where to plug the clips (I would tend to believe in and out of the phase slots).

#20 4 years ago
Quoted from vid1900:

You might have to post a picture.

It's the one on the second link of post #13.

Promoted items from the Pinside Marketplace
$ 100.00
Gameroom - Decorations
The Flipper Room
$ 9.00
Cabinet Parts
Third Coast Pinball

You're currently viewing posts by Pinsider aKa.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside