(Topic ID: 282142)

Popeye Won’t Boot, Fuses Good!

By PinballGurus

3 years ago


Topic Heartbeat

Topic Stats

You

Linked Games

Topic Gallery

View topic image gallery

BFEF7591-33D9-47EE-9487-F7FA0F5AD5A1 (resized).jpeg
C5D4F74B-8837-47E1-8673-22D9D5ED7554 (resized).jpeg
1CC6EFA6-E11A-444D-B0DD-96AEFB2FA8E9 (resized).jpeg
609EDB04-C397-45C3-A27D-1C915716FE70 (resized).jpeg
72C9D4CB-D7AA-4EC0-B7A2-54F7C6BDE76F (resized).jpeg
6D45118B-6D07-4615-BCC4-67D259E4F2F2 (resized).png
#1 3 years ago

Game won’t boot. Played for months no issues then suddenly won’t boot up. All fuses are good.

#2 3 years ago

Did you reseat the ribbon cables? Check the fuse in the line filter box under playfield?

#3 3 years ago

Open the backbox and look at the lights on the board.
https://www.pinwiki.com/wiki/index.php?title=Williams_WPC#Power-On_LEDs_and_Sound_Tones_.28Bongs.29

Do you have power at the service outlet?

#5 3 years ago

I'd guess you've lost your logic voltage. The CPU requires 5V to boot and you'll get pretty much nothing if not.

Have a look at your CPU board. There will be 3 status leds. You can check them against how they should look here https://www.pinball.co.uk/pinball-problems/wpc-leds-explained/

If none of them are lighting up, then you've lost power to the board and it's time to check your driver board.
LED4 should be lit and you should be getting 5v at the test point (tp2 I believe). If not getting 5v on that test point, then chances are your bridge rectifier (a series of diodes on the board) or your smoothing capacitor are bad.

If the CPU leds are lighting up but the middle one isn't blinking, try unplugging all except the power to the cpu board and see if it will boot afterwards (middle led blinks).

#6 3 years ago

I got 4 red lights.

6D45118B-6D07-4615-BCC4-67D259E4F2F2 (resized).png6D45118B-6D07-4615-BCC4-67D259E4F2F2 (resized).png
#8 3 years ago
Quoted from PinballGurus:

I got 4 red lights.
[quoted image]

In your picture, the 3 leds on the smaller board on the left are the ones I'm referencing. They are all 3 next to one another in a vertical formation. Is the middle one blinking?

#10 3 years ago

No clue how that could have happened when the game was working fine for months and same day I drop it off they go out?

#13 3 years ago
72C9D4CB-D7AA-4EC0-B7A2-54F7C6BDE76F (resized).jpeg72C9D4CB-D7AA-4EC0-B7A2-54F7C6BDE76F (resized).jpeg
#14 3 years ago

If you've recently moved it, definitely reseat your connectors. They can wiggle loose during transit.

Past that, check F114 (I think; going from memory) on the driver board with a dmm to see if it has continuity. If so, check the 5V test point.

#15 3 years ago

Where is the 5v test point? I don’t have a schematic. Thanks.

#16 3 years ago

Yeah. Probably loose connector but it played fine until I left. So weird.

#17 3 years ago

Sorry, I was giving you wpc-s reference names. Test point should be tp101.

#18 3 years ago

F105 should be the 5v fuse.

#19 3 years ago

Thanks for the help everyone. I’m here now and will report back ASAP.

#20 3 years ago

I seem to have the worst luck dropping off machines only to have them quit right after. Does this only happen to me?

#22 3 years ago
Quoted from PinballGurus:

I don’t have a schematic.

https://ipdb.org/machine.cgi?id=1851
Schematics are in the manual.

#23 3 years ago

So I only have .709 on TP2 for the 5volts and fuses are good. What should I try next?

#24 3 years ago
609EDB04-C397-45C3-A27D-1C915716FE70 (resized).jpeg609EDB04-C397-45C3-A27D-1C915716FE70 (resized).jpeg
#25 3 years ago
1CC6EFA6-E11A-444D-B0DD-96AEFB2FA8E9 (resized).jpeg1CC6EFA6-E11A-444D-B0DD-96AEFB2FA8E9 (resized).jpeg
#26 3 years ago
C5D4F74B-8837-47E1-8673-22D9D5ED7554 (resized).jpegC5D4F74B-8837-47E1-8673-22D9D5ED7554 (resized).jpeg
#27 3 years ago

The only LEDs that turn on are 1, 6, 7, and one other on the mother board. No other lights turn on. Is there a fuse I’m missing somewhere?

#28 3 years ago

No red lights on display board or sound board or driver board...

#29 3 years ago

So I just noticed when I switch the game on via the bottom. If I do it slowly the game lights with flicker. Could the switch be bad?

#30 3 years ago
Quoted from PinballGurus:

So I just noticed when I switch the game on via the bottom. If I do it slowly the game lights with flicker. Could the switch be bad?

You would get no lights at the motherboard or anywhere else if the switch was bad. It's easy to test though. Unplugged, check continuity on either side of the switch. Should be open when off, closed when on.

#31 3 years ago

Need new can of spinach?

#32 3 years ago
Quoted from NoMonkey:

F105 should be the 5v fuse.

Ok, I apologize as I didn't realize popeye was WPC and not WPC-95.

If F113 is good and TP2 isn't showing 5 volts, check your incoming AC voltage on J101.

If that passes, then you need to make sure your continuity is solid from J101 all the way through to at least BR1/C5. It's important to test that the legs of BR1 connect to C5 as they are top-layer traces. It's possible there are cracked solder joints at C5. I'd inspect that cap for bulges/leakage and reflow the solder to see if it repairs potentially broken traces directly underneath it.

If that all looks good, then test BR1. This can be done inline so there's no need to desolder. A quick google search will give you some info/videos on how to perform the test.

If all else fails, I'd replace BR1, C5, and C9.

Schematics: http://arcarc.xmission.com/Pinball/PDF%20Pinball%20Misc/Williams%20WPC%20Schematic%20manual.pdf

#33 3 years ago

Come on your the pinballgurus, You should already have this fixed.

1 week later
#34 3 years ago

Heading back out today with a Doctor Who boards. They live out of town so I’m going to get it going then figure out the cause at my shop. My guess is CSJ somewhere on the 5v. I’ll report back later. Thanks for your help.

#35 3 years ago

So it’s looking like BR2 is bad. Do bridge rectifiers go out a lot? What would cause them to do so?

#36 3 years ago

So today I took another board that was working and swapped out the BR2, C5, and the LM323K; and put the board back in and still nothing. Any other ideas? Still no 5 volts???

Normally lit. Indicates presence of regulated 5VDC. AC voltage is rectified by BR2 and smoothed by C5. The voltage is regulated down by the LM323K at Q1. This 5VDC power is shown as "+5V Digital" on the schematics. This power is fused by F113.

#37 3 years ago

Not getting 12v on BR2 - getting 7.2v instead. Any ideas what would cause this? I know BR2 is good because I took it from a working board.

BFEF7591-33D9-47EE-9487-F7FA0F5AD5A1 (resized).jpegBFEF7591-33D9-47EE-9487-F7FA0F5AD5A1 (resized).jpeg
Promoted items from Pinside Marketplace and Pinside Shops!
$ 95.00
Cabinet - Sound/Speakers
Pinball Mod Co.
 
From: $ 209.00
$ 54.95
Eproms
Pinballrom
 
$ 85.00
$ 40.00
4,000
Machine - For Sale
Pittsburgh, PA
$ 79.00
Boards
PinballReplacementParts
 
From: $ 27.00
Boards
KAHR.US Circuits
 
$ 329.99
Lighting - Other
Lighted Pinball Mods
 
Wanted
$ 9.99
Eproms
Matt's Basement Arcade
 
$ 9.95
Eproms
Pinballrom
 
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
 
From: $ 1.25
Playfield - Other
Rocket City Pinball
 
$ 85.00

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.