(Topic ID: 201150)

Popeye LockJaw Light Issue


By CUJO

2 years ago



Topic Stats

  • 1 post
  • 1 Pinsider participating
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

I've held off forever posting this because I thought I could figure this out but it doesn't appear I can.

For as long as I can remember, the LOCKJAW light will come on but when a ball enters Bluto's mouth, it'll shoot back out and not shoot another ball into the shooter lane. If I fire the ball back into Bluto's mouth (LOCKJAW remains lit) , it'll work properly the second time and shoot a ball into shooter lane.

Also sometimes, the LOCKJAW light once it comes on, stays lit, and I can subsequently lock Ball 2 and then Ball 3 right after for multiball.

I did install a new Rottendog CPU board 3 months ago also but haven't had any other issues in game play.

I have the latest ROMS Ver 5.0 as well.

I've performed a switch test on all the switches on the enter Ball Lock Assy and made sure they activated properly. They activate as they should when tested. Made sure the adjustment was correct on all of them.

Anyone have any suggestions?

Promoted items from the Pinside Marketplace
$ 99.00
Playfield - Other
Arcade Upkeep
From: $ 27.00
Boards
KAHR.US Circuits
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 37.50
$ 9.99
Eproms
Matt's Basement Arcade
From: € 0.39
Rubber/Silicone
Scandinavian Pinball
From: $ 369.95
Boards
PinSound

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside