(Topic ID: 28549)

Popey flippers moves very slow


By arakissun

6 years ago



Topic Stats

  • 16 posts
  • 5 Pinsiders participating
  • Latest reply 6 years ago by Nomad
  • No one calls this topic a favorite

You

Linked Games

#1 6 years ago

I have problem with the upper right flipper.It move very slow,not it not move
I checked the coil it's ok.Checked and the switch that is on the coil,it's ok
Lower right flipper is ok.Other flippers are ok too.
What can it be?

#2 6 years ago

Check out your flipper button switches, see if they are working well.

#3 6 years ago

How slow is very slow? If the high power line isnt working on that transistor or coil and only hold power is working, it may cause this but the description "it move very slow" is very vague.

#4 6 years ago

plus he english not well

#5 6 years ago

I know my english is not well,but I think this is not the main problem for now.
How can I check the high power line on the transistor or coil?

#6 6 years ago

I would first check the flipper button switches inside the cabinet.

See if the flipper button is actually working for lower and top flipper. You can also try this in Switch Edge test.

#7 6 years ago

OK.I will try this first

#8 6 years ago

If the flipper is rising but slowly, I'm going to guess that the flipper button is working. Otherwise the report would be "flipper not working". Look at the coil. It should have 3 wires. Is one of the wires hanging loose?

#9 6 years ago
Quoted from arakissun:

It move very slow,not it not move

I took this to mean, that it was moving very slow, and now it's not moving.

Definitely also look for loose wires on the coil of course.

#10 6 years ago

new coil sleeves?

#11 6 years ago

Yes,I think something is killing the high voltage.
I was not palying for about 2 days.Today I cleaned the OPTOs that are on the right button.And when I played was fine,very strong and nice.But in time begin to be slowly and slowy.
What can it be?
I saw that on opto board on right button,there was previously changed the two optos and the two resistors.I thnik to chage them with new,but I thnik this is not the problem

I generaly-the power to the flipper loose in time

#12 6 years ago

The circuitry that kills the high voltage is the eos switch. It could be a flaky transistor for the high power also. I guess if you are versed in board work you could swap a transistor really easily. If not, probably not. I have actually had a power transistor be flaky. In my black rose, the canon fired very weak and sometimes not at all. I replaced the board transistor and did nothing else and it has fixed it. Note I am not suggesting you start at the board transistor replacement without further debugging. But if boar work is very easy for you, give it a shot.

#13 6 years ago

Which is tha transistor that do that?I can change it ,it's not problem for me

#14 6 years ago

Check the coil chart in the manual.

#15 6 years ago

I think problem i solved for now
Chaged-two optos,two resistor 470omh and reflow the connector on the board
Now flipper works fine and strong.But I will play it for much long this night

#16 6 years ago

needs more spinach

Promoted items from the Pinside Marketplace
$ 135.00
Lighting - Led
LED OCD
$ 28.00
From: € 0.39
Rubber/Silicone
Scandinavian Pinball
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
3,600
Machine - For Sale
Olive Branch, MS
$ 159.99
Lighting - Other
Lighted Pinball Mods
From: $ 29.00
Boards
KAHR.US Circuits
$ 229.99
Lighting - Other
Lighted Pinball Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
2,799 (Firm)
Sale Pending!
Denver, CO

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside